summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/libxml/libxml2_2.9.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-core/libxml/libxml2_2.9.2.bb')
-rw-r--r--meta/recipes-core/libxml/libxml2_2.9.2.bb85
1 files changed, 80 insertions, 5 deletions
diff --git a/meta/recipes-core/libxml/libxml2_2.9.2.bb b/meta/recipes-core/libxml/libxml2_2.9.2.bb
index 79a395cea1..ebb9fa700c 100644
--- a/meta/recipes-core/libxml/libxml2_2.9.2.bb
+++ b/meta/recipes-core/libxml/libxml2_2.9.2.bb
@@ -1,11 +1,86 @@
1require libxml2.inc 1SUMMARY = "XML C Parser Library and Toolkit"
2DESCRIPTION = "The XML Parser Library allows for manipulation of XML files. Libxml2 exports Push and Pull type parser interfaces for both XML and HTML. It can do DTD validation at parse time, on a parsed document instance or with an arbitrary DTD. Libxml2 includes complete XPath, XPointer and Xinclude implementations. It also has a SAX like interface, which is designed to be compatible with Expat."
3HOMEPAGE = "http://www.xmlsoft.org/"
4BUGTRACKER = "http://bugzilla.gnome.org/buglist.cgi?product=libxml2"
5SECTION = "libs"
6LICENSE = "MIT"
7LIC_FILES_CHKSUM = "file://Copyright;md5=2044417e2e5006b65a8b9067b683fcf1 \
8 file://hash.c;beginline=6;endline=15;md5=96f7296605eae807670fb08947829969 \
9 file://list.c;beginline=4;endline=13;md5=cdbfa3dee51c099edb04e39f762ee907 \
10 file://trio.c;beginline=5;endline=14;md5=6c025753c86d958722ec76e94cae932e"
2 11
3SRC_URI += "http://www.w3.org/XML/Test/xmlts20080827.tar.gz;name=testtar \ 12DEPENDS =+ "zlib"
4 file://72a46a519ce7326d9a00f0b6a7f2a8e958cd1675.patch \ 13
5 file://0001-threads-Define-pthread-definitions-for-glibc-complia.patch \ 14SRC_URI = "ftp://xmlsoft.org/libxml2/libxml2-${PV}.tar.gz;name=libtar \
6 " 15 file://libxml-64bit.patch \
16 file://ansidecl.patch \
17 file://runtest.patch \
18 file://run-ptest \
19 file://libxml2-CVE-2014-0191-fix.patch \
20 file://python-sitepackages-dir.patch \
21 file://libxml-m4-use-pkgconfig.patch \
22 file://configure.ac-fix-cross-compiling-warning.patch \
23 file://0001-CVE-2015-1819-Enforce-the-reader-to-run-in-constant-.patch \
24 file://CVE-2015-7942.patch \
25 file://CVE-2015-8035.patch \
26 http://www.w3.org/XML/Test/xmlts20080827.tar.gz;name=testtar \
27 file://72a46a519ce7326d9a00f0b6a7f2a8e958cd1675.patch \
28 file://0001-threads-Define-pthread-definitions-for-glibc-complia.patch \
29 "
7 30
8SRC_URI[libtar.md5sum] = "9e6a9aca9d155737868b3dc5fd82f788" 31SRC_URI[libtar.md5sum] = "9e6a9aca9d155737868b3dc5fd82f788"
9SRC_URI[libtar.sha256sum] = "5178c30b151d044aefb1b08bf54c3003a0ac55c59c866763997529d60770d5bc" 32SRC_URI[libtar.sha256sum] = "5178c30b151d044aefb1b08bf54c3003a0ac55c59c866763997529d60770d5bc"
10SRC_URI[testtar.md5sum] = "ae3d1ebe000a3972afa104ca7f0e1b4a" 33SRC_URI[testtar.md5sum] = "ae3d1ebe000a3972afa104ca7f0e1b4a"
11SRC_URI[testtar.sha256sum] = "96151685cec997e1f9f3387e3626d61e6284d4d6e66e0e440c209286c03e9cc7" 34SRC_URI[testtar.sha256sum] = "96151685cec997e1f9f3387e3626d61e6284d4d6e66e0e440c209286c03e9cc7"
35
36BINCONFIG = "${bindir}/xml2-config"
37
38inherit autotools pkgconfig binconfig-disabled pythonnative ptest
39
40RDEPENDS_${PN}-ptest += "python-core"
41
42RDEPENDS_${PN}-python += "python-core"
43
44RDEPENDS_${PN}-ptest_append_libc-glibc += "glibc-gconv-ebcdic-us glibc-gconv-ibm1141"
45
46# We don't DEPEND on binutils for ansidecl.h so ensure we don't use the header
47do_configure_prepend () {
48 sed -i -e '/.*ansidecl.h.*/d' ${S}/configure.ac
49}
50
51export PYTHON_SITE_PACKAGES="${PYTHON_SITEPACKAGES_DIR}"
52
53PACKAGECONFIG ??= "python"
54
55PACKAGECONFIG[python] = "--with-python=${PYTHON},--without-python,python"
56# WARNING: zlib is require for RPM use
57EXTRA_OECONF = "--without-debug --without-legacy --with-catalog --without-docbook --with-c14n --without-lzma --with-fexceptions"
58EXTRA_OECONF_class-native = "--without-legacy --without-docbook --with-c14n --without-lzma --with-zlib"
59EXTRA_OECONF_class-nativesdk = "--without-legacy --without-docbook --with-c14n --without-lzma --with-zlib"
60EXTRA_OECONF_linuxstdbase = "--with-debug --with-legacy --with-docbook --with-c14n --without-lzma --with-zlib"
61
62# required for pythong binding
63export HOST_SYS
64export BUILD_SYS
65export STAGING_LIBDIR
66export STAGING_INCDIR
67
68python populate_packages_prepend () {
69 # autonamer would call this libxml2-2, but we don't want that
70 if d.getVar('DEBIAN_NAMES', True):
71 d.setVar('PKG_libxml2', '${MLPREFIX}libxml2')
72}
73
74PACKAGES += "${PN}-utils ${PN}-python"
75
76FILES_${PN}-dbg += "${PYTHON_SITEPACKAGES_DIR}/.debug"
77FILES_${PN}-staticdev += "${PYTHON_SITEPACKAGES_DIR}/*.a"
78FILES_${PN}-dev += "${libdir}/xml2Conf.sh ${libdir}/cmake/*"
79FILES_${PN}-utils += "${bindir}/*"
80FILES_${PN}-python += "${PYTHON_SITEPACKAGES_DIR}"
81
82do_install_ptest () {
83 cp -r ${WORKDIR}/xmlconf ${D}${PTEST_PATH}
84}
85
86BBCLASSEXTEND = "native nativesdk"