summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/libxcrypt/libxcrypt_4.4.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-core/libxcrypt/libxcrypt_4.4.1.bb')
-rw-r--r--meta/recipes-core/libxcrypt/libxcrypt_4.4.1.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta/recipes-core/libxcrypt/libxcrypt_4.4.1.bb b/meta/recipes-core/libxcrypt/libxcrypt_4.4.1.bb
new file mode 100644
index 0000000000..5e5d7c077c
--- /dev/null
+++ b/meta/recipes-core/libxcrypt/libxcrypt_4.4.1.bb
@@ -0,0 +1,29 @@
1SUMMARY = "Extended cryptographic library (from glibc)"
2DESCRIPTION = "Forked code from glibc libary to extract only crypto part."
3HOMEPAGE = "https://github.com/besser82/libxcrypt"
4SECTION = "libs"
5LICENSE = "LGPLv2.1"
6LIC_FILES_CHKSUM ?= "file://LICENSING;md5=e28ba6195a4e39904919b78a92bcf27e \
7 file://COPYING.LIB;md5=4fbd65380cdd255951079008b364516c \
8"
9
10inherit autotools pkgconfig
11
12# v4.4.1
13SRCREV ?= "b8714d4e9e37cf0d511917bd5eea0e51e4a397d5"
14SRCBRANCH ?= "develop"
15
16SRC_URI = "git://github.com/besser82/libxcrypt.git;branch=${SRCBRANCH} \
17 file://0001-Add-x32-specific-inline-asm.patch \
18 "
19
20PROVIDES = "virtual/crypt"
21
22FILES_${PN} = "${libdir}/libcrypt*.so.* ${libdir}/libcrypt-*.so ${libdir}/libowcrypt*.so.* ${libdir}/libowcrypt-*.so"
23
24S = "${WORKDIR}/git"
25
26BUILD_CPPFLAGS = "-I${STAGING_INCDIR_NATIVE} -std=gnu99"
27TARGET_CPPFLAGS = "-I${STAGING_DIR_TARGET}${includedir} -Wno-error=missing-attributes"
28
29BBCLASSEXTEND = "nativesdk"