summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/libxcrypt/libxcrypt_4.0.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-core/libxcrypt/libxcrypt_4.0.1.bb')
-rw-r--r--meta/recipes-core/libxcrypt/libxcrypt_4.0.1.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/meta/recipes-core/libxcrypt/libxcrypt_4.0.1.bb b/meta/recipes-core/libxcrypt/libxcrypt_4.0.1.bb
new file mode 100644
index 0000000000..6ed67a6761
--- /dev/null
+++ b/meta/recipes-core/libxcrypt/libxcrypt_4.0.1.bb
@@ -0,0 +1,32 @@
1SUMMARY = "Extended cryptographic library (from glibc)"
2DESCRIPTION = "Forked code from glibc libary to extract only crypto part."
3HOMEPAGE = "https://github.com/besser82/libxcrypt"
4SECTION = "libs"
5LICENSE = "LGPLv2.1"
6LIC_FILES_CHKSUM ?= "file://LICENSING;md5=d1cc18f512ded3bd6000f3729f31be08 \
7 file://COPYING.LIB;md5=4fbd65380cdd255951079008b364516c \
8"
9
10inherit autotools
11
12SRCREV ?= "089479bb24acd168613757a6f12d63caa95416b4"
13SRCBRANCH ?= "master"
14
15SRC_URI = "git://github.com/besser82/libxcrypt.git;branch=${SRCBRANCH} \
16 "
17
18PROVIDES = "virtual/crypt"
19
20FILES_${PN} = "${libdir}/libcrypt*.so.* ${libdir}/libcrypt-*.so ${libdir}/libowcrypt*.so.* ${libdir}/libowcrypt-*.so"
21
22S = "${WORKDIR}/git"
23
24BUILD_CPPFLAGS = "-I${STAGING_INCDIR_NATIVE} -std=gnu99"
25TARGET_CPPFLAGS = "-I${STAGING_DIR_TARGET}${includedir}"
26
27python () {
28 if not bb.data.inherits_class('nativesdk', d):
29 raise bb.parse.SkipRecipe("Recipe only applies in nativesdk case for now")
30}
31
32BBCLASSEXTEND = "nativesdk"