summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/libcgroup/libcgroup_3.1.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-core/libcgroup/libcgroup_3.1.0.bb')
-rw-r--r--meta/recipes-core/libcgroup/libcgroup_3.1.0.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/meta/recipes-core/libcgroup/libcgroup_3.1.0.bb b/meta/recipes-core/libcgroup/libcgroup_3.1.0.bb
new file mode 100644
index 0000000000..4b4f19e36f
--- /dev/null
+++ b/meta/recipes-core/libcgroup/libcgroup_3.1.0.bb
@@ -0,0 +1,33 @@
1SUMMARY = "Linux control group abstraction library"
2HOMEPAGE = "http://libcg.sourceforge.net/"
3DESCRIPTION = "libcgroup is a library that abstracts the control group file system \
4in Linux. Control groups allow you to limit, account and isolate resource usage \
5(CPU, memory, disk I/O, etc.) of groups of processes."
6SECTION = "libs"
7LICENSE = "LGPL-2.1-only"
8LIC_FILES_CHKSUM = "file://COPYING;md5=4d794c5d710e5b3547a6cc6a6609a641"
9
10inherit autotools pkgconfig github-releases
11
12DEPENDS = "bison-native flex-native"
13DEPENDS:append:libc-musl = " fts"
14
15SRC_URI = "${GITHUB_BASE_URI}/download/v${PV}/${BP}.tar.gz \
16"
17UPSTREAM_CHECK_URI = "https://github.com/libcgroup/libcgroup/tags"
18
19SRC_URI[sha256sum] = "976ec4b1e03c0498308cfd28f1b256b40858f636abc8d1f9db24f0a7ea9e1258"
20
21PACKAGECONFIG = "${@bb.utils.filter('DISTRO_FEATURES', 'pam systemd', d)}"
22PACKAGECONFIG[pam] = "--enable-pam-module-dir=${base_libdir}/security --enable-pam=yes,--enable-pam=no,libpam"
23PACKAGECONFIG[systemd] = "--enable-systemd,--disable-systemd,systemd"
24
25PACKAGES =+ "cgroups-pam-plugin"
26FILES:cgroups-pam-plugin = "${base_libdir}/security/pam_cgroup.so*"
27FILES:${PN}-dev += "${base_libdir}/security/*.la"
28FILES:${PN}-staticdev += "${base_libdir}/security/pam_cgroup.a"
29
30do_install:append() {
31 # Until we ship the test suite, this library isn't useful
32 rm -f ${D}${libdir}/libcgroupfortesting.*
33}