summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/kbd/kbd_1.15.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-core/kbd/kbd_1.15.2.bb')
-rw-r--r--meta/recipes-core/kbd/kbd_1.15.2.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/meta/recipes-core/kbd/kbd_1.15.2.bb b/meta/recipes-core/kbd/kbd_1.15.2.bb
new file mode 100644
index 0000000000..a150ff1b54
--- /dev/null
+++ b/meta/recipes-core/kbd/kbd_1.15.2.bb
@@ -0,0 +1,32 @@
1DESCRIPTION = "This package contains keytable files and keyboard utilities"
2# everything minus console-fonts is GPLv2+
3LICENSE = "GPLv2+"
4LIC_FILES_CHKSUM = "file://COPYING;md5=587ce626d15bd61699a64a6b8a5afefb"
5
6inherit autotools gettext
7
8BBCLASSEXTEND = "native"
9RREPLACES_${PN} = "console-tools"
10RPROVIDES_${PN} = "console-tools"
11RCONFLICTS_${PN} = "console-tools"
12
13PR = "r4"
14
15SRC_URI = "${KERNELORG_MIRROR}/linux/utils/kbd/kbd-1.15.2.tar.bz2 \
16 file://Allow-resizecons-on-x86_64.patch"
17
18SRC_URI[md5sum] = "e850eb91e4d3b94b194efe8e953204c5"
19SRC_URI[sha256sum] = "b3602d191eef7a6a8317fc3cd231efa40a89ac235dce57a77cac825a2a21eba6"
20
21PACKAGES += "${PN}-consolefonts ${PN}-keymaps ${PN}-unimaps ${PN}-consoletrans"
22
23FILES_${PN}-consolefonts = "${datadir}/consolefonts"
24FILES_${PN}-consoletrans = "${datadir}/consoletrans"
25FILES_${PN}-keymaps = "${datadir}/keymaps"
26FILES_${PN}-unimaps = "${datadir}/unimaps"
27
28inherit update-alternatives
29
30
31ALTERNATIVE_${PN} = "chvt deallocvt fgconsole openvt"
32ALTERNATIVE_PRIORITY = "100"