summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/jpeg/jpeg_8d.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-core/jpeg/jpeg_8d.bb')
-rw-r--r--meta/recipes-core/jpeg/jpeg_8d.bb56
1 files changed, 56 insertions, 0 deletions
diff --git a/meta/recipes-core/jpeg/jpeg_8d.bb b/meta/recipes-core/jpeg/jpeg_8d.bb
new file mode 100644
index 0000000000..eba5bf46d2
--- /dev/null
+++ b/meta/recipes-core/jpeg/jpeg_8d.bb
@@ -0,0 +1,56 @@
1SUMMARY = "libjpeg is a library for handling the JPEG (JFIF) image format."
2DESCRIPTION = "libjpeg contains a library for handling the JPEG (JFIF) image format, as well as related programs for accessing the libjpeg functions."
3HOMEPAGE = "http://www.ijg.org/"
4BUGTRACKER = ""
5
6LICENSE ="BSD-3-Clause"
7LIC_FILES_CHKSUM = "file://README;md5=4f46756b064c225fae088903300e5c98"
8
9SECTION = "libs"
10
11DEPENDS = "libtool-cross"
12DEPENDS_class-native = "libtool-native"
13
14PR = "r1"
15
16SRC_URI = "http://www.ijg.org/files/jpegsrc.v${PV}.tar.gz \
17 file://debian-libjpeg7_7-1.diff \
18 file://fix_for_automake_1.12.1.patch"
19
20SRC_URI[md5sum] = "52654eb3b2e60c35731ea8fc87f1bd29"
21SRC_URI[sha256sum] = "00029b1473f0f0ea72fbca3230e8cb25797fbb27e58ae2e46bb8bf5a806fe0b3"
22
23inherit autotools
24
25EXTRA_OECONF="--enable-static --enable-shared"
26EXTRA_OEMAKE='"LIBTOOL=${STAGING_BINDIR_CROSS}/${HOST_SYS}-libtool"'
27
28CFLAGS_append = " -D_REENTRANT"
29
30do_configure_prepend () {
31 rm -f ${S}/ltconfig
32 rm -f ${S}/ltmain.sh
33}
34
35do_install() {
36 install -d ${D}${bindir} ${D}${includedir} \
37 ${D}${mandir}/man1 ${D}${libdir}
38 oe_runmake 'DESTDIR=${D}' install
39}
40
41PACKAGES =+ "jpeg-tools "
42DESCRIPTION_jpeg-tools = "The jpeg-tools package includes the client programs for access libjpeg functionality. These tools allow for the compression, decompression, transformation and display of JPEG files."
43FILES_jpeg-tools = "${bindir}/*"
44
45BBCLASSEXTEND = "native"
46
47pkg_postinst_${PN}_linuxstdbase () {
48 if [ "$D" = "" ]; then
49 if [ ! -e ${libdir}/libjpeg.so.62 ]; then
50 JPEG=`find ${libdir} -type f -name libjpeg.so.\*.\*.\*`
51 ln -sf `basename $JPEG` ${libdir}/libjpeg.so.62
52 fi
53 else
54 exit 1
55 fi
56}