summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/jpeg/jpeg_8d.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-core/jpeg/jpeg_8d.bb')
-rw-r--r--meta/recipes-core/jpeg/jpeg_8d.bb51
1 files changed, 51 insertions, 0 deletions
diff --git a/meta/recipes-core/jpeg/jpeg_8d.bb b/meta/recipes-core/jpeg/jpeg_8d.bb
new file mode 100644
index 0000000000..da23302149
--- /dev/null
+++ b/meta/recipes-core/jpeg/jpeg_8d.bb
@@ -0,0 +1,51 @@
1SUMMARY = "libjpeg is a library for handling the JPEG (JFIF) image format"
2DESCRIPTION = "libjpeg contains a library for handling the JPEG (JFIF) image format, as well as related programs for accessing the libjpeg functions."
3HOMEPAGE = "http://www.ijg.org/"
4
5LICENSE ="BSD-3-Clause"
6LIC_FILES_CHKSUM = "file://README;md5=4f46756b064c225fae088903300e5c98"
7
8SECTION = "libs"
9
10DEPENDS = "libtool-cross"
11DEPENDS_class-native = "libtool-native"
12
13PR = "r1"
14
15SRC_URI = "http://www.ijg.org/files/jpegsrc.v${PV}.tar.gz \
16 file://debian-libjpeg7_7-1.diff \
17 file://fix_for_automake_1.12.1.patch"
18
19SRC_URI[md5sum] = "52654eb3b2e60c35731ea8fc87f1bd29"
20SRC_URI[sha256sum] = "00029b1473f0f0ea72fbca3230e8cb25797fbb27e58ae2e46bb8bf5a806fe0b3"
21
22inherit autotools
23
24EXTRA_OECONF="--enable-static --enable-shared"
25EXTRA_OEMAKE='"LIBTOOL=${STAGING_BINDIR_CROSS}/${HOST_SYS}-libtool"'
26
27CFLAGS_append = " -D_REENTRANT"
28
29do_configure_prepend () {
30 rm -f ${S}/ltconfig
31 rm -f ${S}/ltmain.sh
32}
33
34do_install() {
35 install -d ${D}${bindir} ${D}${includedir} \
36 ${D}${mandir}/man1 ${D}${libdir}
37 oe_runmake 'DESTDIR=${D}' install
38}
39
40PACKAGES =+ "jpeg-tools "
41DESCRIPTION_jpeg-tools = "The jpeg-tools package includes the client programs for access libjpeg functionality. These tools allow for the compression, decompression, transformation and display of JPEG files."
42FILES_jpeg-tools = "${bindir}/*"
43
44BBCLASSEXTEND = "native"
45
46pkg_postinst_${PN}_linuxstdbase () {
47 if [ ! -e $D${libdir}/libjpeg.so.62 ]; then
48 JPEG=`find $D${libdir} -type f -name libjpeg.so.\*.\*.\*`
49 ln -sf `basename $JPEG` $D${libdir}/libjpeg.so.62
50 fi
51}