summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/jpeg/jpeg_8c.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-core/jpeg/jpeg_8c.bb')
-rw-r--r--meta/recipes-core/jpeg/jpeg_8c.bb58
1 files changed, 58 insertions, 0 deletions
diff --git a/meta/recipes-core/jpeg/jpeg_8c.bb b/meta/recipes-core/jpeg/jpeg_8c.bb
new file mode 100644
index 0000000000..ac00275337
--- /dev/null
+++ b/meta/recipes-core/jpeg/jpeg_8c.bb
@@ -0,0 +1,58 @@
1SUMMARY = "libjpeg is a library for handling the JPEG (JFIF) image format."
2DESCRIPTION = "libjpeg contains a library for handling the JPEG (JFIF) image format, as well as related programs for accessing the libjpeg functions."
3HOMEPAGE = "http://www.ijg.org/"
4BUGTRACKER = ""
5
6LICENSE ="jpeg"
7LIC_FILES_CHKSUM = "file://cdjpeg.h;endline=12;md5=78fa8dbac547bb5b2a0e6457a6cfe21d \
8 file://jpeglib.h;endline=14;md5=22f1e0f8fc71f6f7563146d3b210dbe5 \
9 file://djpeg.c;endline=13;md5=ca89254925da06fef47e4b6468233432"
10
11SECTION = "libs"
12PRIORITY = "required"
13
14DEPENDS = "libtool-cross"
15DEPENDS_virtclass-native = "libtool-native"
16
17PR = "r1"
18
19SRC_URI = "http://www.ijg.org/files/jpegsrc.v${PV}.tar.gz \
20 file://debian-libjpeg7_7-1.diff;"
21
22SRC_URI[md5sum] = "a2c10c04f396a9ce72894beb18b4e1f9"
23SRC_URI[sha256sum] = "edfc0b3e004b2fe58ffeeec89f96e3a3c28972c46725ec127d01edf8a1cc7c9a"
24
25inherit autotools
26
27EXTRA_OECONF="--enable-static --enable-shared"
28EXTRA_OEMAKE='"LIBTOOL=${STAGING_BINDIR_CROSS}/${HOST_SYS}-libtool"'
29
30CFLAGS_append = " -D_REENTRANT"
31
32do_configure_prepend () {
33 rm -f ${S}/ltconfig
34 rm -f ${S}/ltmain.sh
35}
36
37do_install() {
38 install -d ${D}${bindir} ${D}${includedir} \
39 ${D}${mandir}/man1 ${D}${libdir}
40 oe_runmake 'DESTDIR=${D}' install
41}
42
43PACKAGES =+ "jpeg-tools "
44DESCRIPTION_jpeg-tools = "The jpeg-tools package includes the client programs for access libjpeg functionality. These tools allow for the compression, decompression, transformation and display of JPEG files."
45FILES_jpeg-tools = "${bindir}/*"
46
47BBCLASSEXTEND = "native"
48
49pkg_postinst_${PN}_linuxstdbase () {
50 if [ "$D" = "" ]; then
51 if [ ! -e ${libdir}/libjpeg.so.62 ]; then
52 JPEG=`find ${libdir} -type f -name libjpeg.so.\*.\*.\*`
53 ln -sf `basename $JPEG` ${libdir}/libjpeg.so.62
54 fi
55 else
56 exit 1
57 fi
58}