summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/jpeg/jpeg_8b.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-core/jpeg/jpeg_8b.bb')
-rw-r--r--meta/recipes-core/jpeg/jpeg_8b.bb42
1 files changed, 42 insertions, 0 deletions
diff --git a/meta/recipes-core/jpeg/jpeg_8b.bb b/meta/recipes-core/jpeg/jpeg_8b.bb
new file mode 100644
index 0000000000..53847e715a
--- /dev/null
+++ b/meta/recipes-core/jpeg/jpeg_8b.bb
@@ -0,0 +1,42 @@
1DESCRIPTION = "libjpeg is a library for handling the JPEG (JFIF) image format."
2HOMEPAGE = "http://www.ijg.org/"
3BUGTRACKER = ""
4
5LICENSE ="jpeg"
6LIC_FILES_CHKSUM = "file://cdjpeg.h;endline=12;md5=78fa8dbac547bb5b2a0e6457a6cfe21d \
7 file://jpeglib.h;endline=14;md5=dd06b5575519f735ec2565ed36ce62e7 \
8 file://djpeg.c;endline=13;md5=ca89254925da06fef47e4b6468233432"
9
10SECTION = "libs"
11PRIORITY = "required"
12
13DEPENDS = "libtool-cross"
14DEPENDS_virtclass-native = "libtool-native"
15
16PR = "r0"
17
18SRC_URI = "http://www.ijg.org/files/jpegsrc.v${PV}.tar.gz \
19 file://debian-libjpeg7_7-1.diff;patch=1"
20
21inherit autotools
22
23EXTRA_OECONF="--enable-static --enable-shared"
24EXTRA_OEMAKE='"LIBTOOL=${STAGING_BINDIR_CROSS}/${HOST_SYS}-libtool"'
25
26CFLAGS_append = " -D_REENTRANT"
27
28do_configure_prepend () {
29 rm -f ${S}/ltconfig
30 rm -f ${S}/ltmain.sh
31}
32
33do_install() {
34 install -d ${D}${bindir} ${D}${includedir} \
35 ${D}${mandir}/man1 ${D}${libdir}
36 oe_runmake 'DESTDIR=${D}' install
37}
38
39PACKAGES =+ "jpeg-tools "
40FILES_jpeg-tools = "${bindir}/*"
41
42BBCLASSEXTEND = "native"