summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/jpeg/jpeg-8d/debian-libjpeg7_7-1.diff
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-core/jpeg/jpeg-8d/debian-libjpeg7_7-1.diff')
-rw-r--r--meta/recipes-core/jpeg/jpeg-8d/debian-libjpeg7_7-1.diff1070
1 files changed, 1070 insertions, 0 deletions
diff --git a/meta/recipes-core/jpeg/jpeg-8d/debian-libjpeg7_7-1.diff b/meta/recipes-core/jpeg/jpeg-8d/debian-libjpeg7_7-1.diff
new file mode 100644
index 0000000000..3b8fa6980a
--- /dev/null
+++ b/meta/recipes-core/jpeg/jpeg-8d/debian-libjpeg7_7-1.diff
@@ -0,0 +1,1070 @@
1This is a well-known debian patch used by many Linux distribution, but not
2accepted by upstream yet.
3Upstream-Status: Pending
4
5--- libjpeg7-7.orig/config.sub
6+++ libjpeg7-7/config.sub
7@@ -1,4 +1,10 @@
8 #! /bin/sh
9+# autotools-dev hack (<ballombe@debian.org>, Wed, 14 Nov 2001 10:13:10 +0100)
10+if [ -x /usr/share/misc/config.sub ]; then
11+ /usr/share/misc/config.sub $*
12+ exit $?
13+fi
14+
15 # Configuration validation subroutine script.
16 # Copyright (C) 1992, 1993, 1994, 1995, 1996, 1997, 1998, 1999,
17 # 2000, 2001, 2002, 2003, 2004, 2005, 2006, 2007, 2008
18--- libjpeg7-7.orig/config.guess
19+++ libjpeg7-7/config.guess
20@@ -1,4 +1,10 @@
21 #! /bin/sh
22+# autotools-dev hack (<ballombe@debian.org>, Wed, 14 Nov 2001 10:13:10 +0100)
23+if [ -x /usr/share/misc/config.guess ]; then
24+ /usr/share/misc/config.guess $*
25+ exit $?
26+fi
27+
28 # Attempt to guess a canonical system name.
29 # Copyright (C) 1992, 1993, 1994, 1995, 1996, 1997, 1998, 1999,
30 # 2000, 2001, 2002, 2003, 2004, 2005, 2006, 2007, 2008
31--- libjpeg7-7.orig/debian/libjpeg7-dev.files
32+++ libjpeg7-7/debian/libjpeg7-dev.files
33@@ -0,0 +1,4 @@
34+usr/include
35+usr/lib/libjpeg.a
36+usr/lib/libjpeg.la
37+usr/lib/libjpeg.so
38--- libjpeg7-7.orig/debian/libjpeg-progs.README.Debian
39+++ libjpeg7-7/debian/libjpeg-progs.README.Debian
40@@ -0,0 +1,13 @@
41+libjpeg-progs for Debian
42+========================
43+
44+This package contains programs for manipulating JPEG files:
45+ cjpeg/djpeg: convert to/from the JPEG file format
46+ rdjpgcom/wrjpgcom: read/write comments in JPEG files
47+ jpegtran: lossless transformations of JPEG files
48+ jpegexiforient/exifautotran: manipulate EXIF orientation tag
49+
50+Thanks for using Debian!
51+
52+--
53+Bill Allombert <ballombe@debian.org> Sun, 05 Jul 2009 15:18:59 +0200
54--- libjpeg7-7.orig/debian/shlibs.local
55+++ libjpeg7-7/debian/shlibs.local
56@@ -0,0 +1 @@
57+libjpeg 7 libjpeg7
58--- libjpeg7-7.orig/debian/rules
59+++ libjpeg7-7/debian/rules
60@@ -0,0 +1,71 @@
61+#!/usr/bin/make -f
62+# Made with the aid of debmake, by Christoph Lameter,
63+# based on the sample debian/rules file for GNU hello by Ian Jackson.
64+
65+package=libjpeg
66+
67+export DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
68+export DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
69+
70+export CFLAGS=-D_REENTRANT -g -Wall
71+ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
72+CFLAGS += -O0
73+else
74+CFLAGS += -O2
75+endif
76+
77+#export DH_VERBOSE=1
78+
79+build: build-stamp
80+build-stamp:
81+ dh_testdir
82+ ./configure --prefix=/usr --mandir=/usr/share/man \
83+ --enable-static --enable-shared \
84+ --build=$(DEB_BUILD_GNU_TYPE) --host=$(DEB_HOST_GNU_TYPE)
85+ $(MAKE)
86+ifeq (,$(findstring nocheck,$(DEB_BUILD_OPTIONS)))
87+ $(MAKE) check
88+endif
89+ $(MAKE) -C debian/extra
90+
91+ touch build-stamp
92+
93+clean:
94+ dh_testdir
95+ dh_testroot
96+ -rm -f build-stamp
97+ if [ -f Makefile ]; then $(MAKE) distclean; fi
98+ $(MAKE) clean -C debian/extra
99+ dh_clean
100+
101+binary-indep:
102+
103+binary-arch: build
104+ dh_testdir
105+ dh_testroot
106+ dh_clean -k
107+ dh_installdirs
108+ $(MAKE) install DESTDIR=`pwd`/debian/tmp
109+ $(MAKE) install -C debian/extra prefix=/usr DESTDIR=`pwd`/debian/tmp
110+ # fix jconfig.h
111+ rm debian/tmp/usr/include/jconfig.h
112+ sed -e "s/#\(undef\|define\) HAVE_\(LOCALE\|\(STD\(DEF\|LIB\)\)\)_H 1//g" \
113+ jconfig.h > debian/tmp/usr/include/jconfig.h
114+ # separate out lib package
115+ dh_movefiles
116+ # Finish it off with debhelper
117+ dh_installdocs README
118+ dh_installexamples
119+ dh_installchangelogs change.log
120+ dh_strip --dbg-package=libjpeg7-dbg
121+ dh_compress
122+ dh_fixperms
123+ dh_installdeb
124+ dh_shlibdeps -l`pwd`/debian/libjpeg7/usr/lib
125+ dh_gencontrol
126+ dh_md5sums
127+ dh_builddeb
128+
129+binary: binary-indep binary-arch
130+
131+.PHONY: clean binary-indep binary-arch binary build
132--- libjpeg7-7.orig/debian/libjpeg7-dev.README.Debian
133+++ libjpeg7-7/debian/libjpeg7-dev.README.Debian
134@@ -0,0 +1,18 @@
135+IJG JPEG for Debian
136+===================
137+
138+The following patch has been applied to the headers files:
139+
140+--- jconfig.h: Remove unused symbol HAVE_STDDEF_H, HAVE_STDLIB_H and
141+HAVE_LOCALE_H since they are not used by the installed headers files and cause
142+problem with autoconf.
143+
144+This can theoretically cause problems if your software relies on theses symbols
145+being defined by this header. If it ever happens, please define them manually.
146+
147+Note: this is not Debian-specific, others distributions apply similar patches.
148+
149+Thanks for using Debian!
150+
151+---
152+Bill Allombert <ballombe@debian.org> Sun, 05 Jul 2009 15:17:56 +0200
153--- libjpeg7-7.orig/debian/shlibs
154+++ libjpeg7-7/debian/shlibs
155@@ -0,0 +1 @@
156+libjpeg 7 libjpeg7
157--- libjpeg7-7.orig/debian/control
158+++ libjpeg7-7/debian/control
159@@ -0,0 +1,52 @@
160+Source: libjpeg7
161+Maintainer: Bill Allombert <ballombe@debian.org>
162+Section: graphics
163+Priority: optional
164+Build-Depends: debhelper (>= 5), autotools-dev
165+Standards-Version: 3.8.2
166+
167+Package: libjpeg7
168+Architecture: any
169+Section: libs
170+Description: The Independent JPEG Group's JPEG runtime library
171+ The Independent JPEG Group's JPEG library is a library for handling
172+ JPEG files.
173+ .
174+ This package contains the shared library.
175+Depends: ${shlibs:Depends}
176+
177+Package: libjpeg7-dev
178+Architecture: any
179+Section: libdevel
180+Description: Development files for the IJG JPEG library
181+ The Independent JPEG Group's JPEG library is a library for handling
182+ JPEG files.
183+ .
184+ This package contains the static library, headers and documentation.
185+Depends: libjpeg7 (=${binary:Version}), libc-dev
186+Conflicts: libjpeg62-dev
187+Replaces: libjpeg62-dev
188+
189+Package: libjpeg7-dbg
190+Architecture: any
191+Section: debug
192+Priority: extra
193+Description: Development files for the IJG JPEG library
194+ The Independent JPEG Group's JPEG library is a library for handling
195+ JPEG files.
196+ .
197+ This package contains the debugging symbols for libjpeg.
198+Provides: libjpeg-dbg
199+Depends: libjpeg7 (=${binary:Version})
200+Conflicts: libjpeg62-dbg
201+Replaces: libjpeg62-dbg
202+
203+Package: libjpeg-progs
204+Architecture: any
205+Description: Programs for manipulating JPEG files
206+ This package contains programs for manipulating JPEG files:
207+ cjpeg/djpeg: convert to/from the JPEG file format
208+ rdjpgcom/wrjpgcom: read/write comments in JPEG files
209+ jpegtran: lossless transformations of JPEG files
210+ jpegexiforient/exifautotran: manipulate EXIF orientation tag
211+Depends: ${shlibs:Depends}
212--- libjpeg7-7.orig/debian/libjpeg7.files
213+++ libjpeg7-7/debian/libjpeg7.files
214@@ -0,0 +1,2 @@
215+/usr/lib/libjpeg.so.7.0.0
216+/usr/lib/libjpeg.so.7
217--- libjpeg7-7.orig/debian/postinst
218+++ libjpeg7-7/debian/postinst
219@@ -0,0 +1,8 @@
220+#!/bin/sh -e
221+
222+#DEBHELPER#
223+
224+if [ "$1" = "configure" ]; then
225+ ldconfig
226+fi
227+
228--- libjpeg7-7.orig/debian/compat
229+++ libjpeg7-7/debian/compat
230@@ -0,0 +1 @@
231+5
232--- libjpeg7-7.orig/debian/libjpeg7-dev.examples
233+++ libjpeg7-7/debian/libjpeg7-dev.examples
234@@ -0,0 +1 @@
235+example.c
236--- libjpeg7-7.orig/debian/changelog
237+++ libjpeg7-7/debian/changelog
238@@ -0,0 +1,245 @@
239+libjpeg7 (7-1) unstable; urgency=low
240+
241+ * The "Yoan" release.
242+ * New upstream release. closes: #535350
243+ - This release includes configure.ac and Makefile.am. closes: #346126
244+ - All patches merged upstream.
245+ - Remove dpatch support.
246+ * debian/control:
247+ - Remove Build-Dependency on libtool and sharutils.
248+ - Move libjpeg7-dbg to debug section.
249+ - Bump standard version to 3.8.2.
250+ * Skip test-suite if nocheck is set. closes: #451222
251+
252+ -- Bill Allombert <ballombe@debian.org> Sun, 05 Jul 2009 15:29:27 +0200
253+
254+libjpeg6b (6b-14) unstable; urgency=low
255+
256+ * The "Lino" release.
257+ * exifautotran:
258+ - fix typo in manpage. closes: #376371, thanks Reuben Thomas.
259+ - preserve file mode. closes: #383379, thanks Vincent Arkesteijn.
260+ * debian/control, debian/rules, debian/compat:
261+ + switch to debhelper v5
262+ + add libjpeg-dbg debugging package.
263+ * debian/rules: remove - before "make clean" rules.
264+ * Add patch 204_jpegtran_man to improve readability of manpage.
265+ closes: #437453. Thanks Jorgen Grahn.
266+ * jpegexiforient.1: Apply patch from Jorgen Grahn to improve formatting.
267+ closes: #437446.
268+
269+ -- Bill Allombert <ballombe@debian.org> Thu, 16 Aug 2007 22:59:21 +0200
270+
271+libjpeg6b (6b-13) unstable; urgency=low
272+
273+ * The "If at first you don't succeed..." release.
274+ * Change --enable-maxmem to 1024, following Guido advice.
275+ This should fix the slowdowns with large files (for large < 1Gb):
276+ closes: #356556, #365025, Thanks Nicolas.
277+ If you hit performance problems, please set the JPEGMEM variable to
278+ about half your available RAM, see jpegtran(1).
279+ * Update libjpeg-progs README.Debian to reflect the new patch set and
280+ the JPEGMEM feature.
281+ * Bump standard version to 3.7.2.
282+
283+ -- Bill Allombert <ballombe@debian.org> Fri, 5 May 2006 19:14:25 +0200
284+
285+libjpeg6b (6b-12) unstable; urgency=low
286+
287+ * The "vote for me" release
288+ * Bump standard version to 3.6.2.
289+ * Run 'make test' instead of home-made test-suite.
290+ * Switch to debhelper v4.
291+ * libjpeg is now configured with --enable-maxmem=32. This limits the memory
292+ usage to 32Mb and it can be overrided by JPEGMEM. Without this flag
293+ JPEGMEM is ignored and there were no limits.
294+ closes: #346023. Thanks C. Scott Ananian.
295+
296+ -- Bill Allombert <ballombe@debian.org> Thu, 2 Mar 2006 18:52:44 +0100
297+
298+libjpeg6b (6b-11) unstable; urgency=high
299+
300+ * The "Silencio" release
301+ * exifautotran: Apply patch by Uwe Zeisberger to fix bad temporary file
302+ handling. closes: #340079
303+
304+ -- Bill Allombert <ballombe@debian.org> Sun, 20 Nov 2005 20:57:07 +0100
305+
306+libjpeg6b (6b-10) unstable; urgency=low
307+
308+ * The "timeout" release.
309+ * Rebuild with current toolchain.
310+ * Depends on libc-dev instead of libc6-dev. closes: #294696
311+ Thanks Joel Aelwyn for discussing thoroughly the matter.
312+ * Instead of copying /usr/bin/libtool, we replace it by a script that
313+ call libtool (using standard path search). Remarked by Jesus Climent.
314+ * debian/control: remove pre-hamm cruft.
315+ * Add jpegexiforient and jpegautotran by Guido Vollbeding
316+ <http://sylvana.net/jpegcrop/exif_orientation.html> as proposed by Philip
317+ Armstrong. closes: #257061.
318+ * Run the test-suite at build time instead of shipping it in the package:
319+ - /usr/share/doc/libjpeg-progs/tests: removed.
320+ - debian/control: Add Build-Depends on sharutils for uuencode.
321+ - debian/libjpeg-progs.dirs: removed.
322+ - debian/libjpeg-progs.test: removed.
323+
324+ -- Bill Allombert <ballombe@debian.org> Tue, 1 Mar 2005 19:43:26 +0100
325+
326+libjpeg6b (6b-9) unstable; urgency=low
327+
328+ * The "I'm all for aggressive goals" release.
329+ * Rebuild with new libtool. closes: #201943.
330+ * patch 100_crop: Updated from Guido Vollbeding <guido@jpegclub.org>
331+ to include patches 203_jpegtran_errmsg,204_perfect.
332+ * patch 200_crop_man: Include 205_perfect_man.
333+ * patches 203_jpegtran_errmsg, 204_perfect, 205_perfect_man: removed
334+ * Add patch 203_rdppm: fix cjpeg issue with 16-bit PPM files. closes: #208937
335+ * Bump standard version to 3.6.1.
336+ * Update debian/edit-patch.
337+
338+ -- Bill Allombert <ballombe@debian.org> Mon, 8 Sep 2003 16:22:08 +0200
339+
340+libjpeg6b (6b-8) unstable; urgency=low
341+
342+ * The "I *hate* when that happens" release.
343+ * Move libjpeg62-dev to libdevel section.
344+ * See debian/README.sources for detail about the (d)patch system.
345+ * debian/rules: avoid to run configure twice.
346+ * Add patches 204_perfect and 205_perfect_man. They implement the
347+ -perfect jpegtran option as proposed by Mark W. Eichin. closes: #189027
348+ * Bump standard version to 3.5.10.
349+ * Use /usr/bin/libtool instead of ldconfig-generated libtool, and remove
350+ various libtool related kludges, including patch 301_configure.
351+ closes: #195281. Thanks Robert Millan for the suggestion.
352+ * Remove patch 302_makefile. Fix debian/rules instead.
353+
354+ -- Bill Allombert <ballombe@debian.org> Sat, 31 May 2003 16:16:59 +0200
355+
356+libjpeg6b (6b-7) unstable; urgency=low
357+
358+ * Rebuild with new gcc/new glibc/new debhelper.
359+ * Add -g to build options according to new policy.
360+ * Add support for DEB_BUILD_OPTIONS noopt. nostrip is handled by dh_strip.
361+ * Bump standard version to 3.5.9.
362+ * Extend description a bit (If you have a better one please email me!).
363+ * Use dpatch to handle the patches.
364+
365+ -- Bill Allombert <ballombe@debian.org> Sun, 16 Mar 2003 12:19:36 +0100
366+
367+libjpeg6b (6b-6) unstable; urgency=low
368+
369+ * The "Try to break sarge before it even got a name" release
370+ * jpegtran: better error messages when opening files.
371+ closes: #147516 Thanks Mark W. Eichin.
372+ * Add debian/patch dir with my patches.
373+ * Add extern "C" if we are under C++.
374+ closes: #113167 Thanks, Fredrik Jagenheim.
375+ * Remove HAVE_STD{LIB,DEF}_H from jconfig.h since they are not used and
376+ conflict with autoconf. closes: #109516 Thanks <Benedikt.Roth@gmx.net>
377+ * Add README.Debian in /usr/share/libjpeg62-dev
378+
379+ -- Bill Allombert <ballombe@debian.org> Mon, 3 Jun 2002 19:34:08 +0200
380+
381+libjpeg6b (6b-5) unstable; urgency=low
382+
383+ * jpeg-->JPEG in libjpeg-progs description.
384+ * Add lib path to dh_shlibdeps to avoid warning.
385+ * Apply patch from <http://sylvana.net/jpegcrop/croppatch.tar.gz> by
386+ <guido@jpegclub.org> closes: #129412 Thanks, Colin Marquardt.
387+
388+ -- Bill Allombert <ballombe@debian.org> Mon, 20 May 2002 11:55:22 +0200
389+
390+libjpeg6b (6b-4) unstable; urgency=low
391+
392+ * Avoid bashism in debian/rules.
393+ * Update libtool to 1.3.5. (1.4 will break).
394+ closes: #52095 Thanks, <Marcus.Brinkmann@ruhr-uni-bochum.de>
395+ * Patch config.guess to use version in the autotools-dev package.
396+ * Correct Section: field of libjpeg62 and libjpeg62-dev.
397+
398+ -- Bill Allombert <ballombe@debian.org> Tue, 20 Nov 2001 10:23:47 +0100
399+
400+libjpeg6b (6b-3) unstable; urgency=low
401+
402+ * The "Where is ltconfig ?" release.
403+ * Remove jconfig.h in debian/rules clean and do some clean up.
404+ * Install libjpeg.la per Policy 11.2.
405+ * Remove duplicate wizard.doc file in libjpeg62-dev.
406+ * Use dpkg-architecture instead of config.guess.
407+ * Patch config.sub to use version in the autotools-dev package.
408+ closes: #85558, #120039
409+ * Patch rdjpgcom.c to use locales for isprint check on comment chars.
410+ closes: #116589 Thanks, Neal H Walfield <neal@cs.uml.edu>
411+ * Apply patch from <http://sylvana.net/jpegcrop/transupp.c> by
412+ <guido@jpegclub.org> closes: #114415 Thanks, <Jean-Marc.Notin@loria.fr>
413+
414+ -- Bill Allombert <ballombe@debian.org> Tue, 13 Nov 2001 21:41:49 +0000
415+
416+libjpeg6b (6b-2) unstable; urgency=low
417+
418+ * New Maintainer. Mark, If you want back the package, just ask!
419+ * Acknowledge previous NMU:
420+ Jordi: closes: #74087, #24330, #24291
421+ Colin: closes: #80752
422+ Joel: closes: #25324, #27033, #28341
423+ * Write source location as a valid URL in debian/copyright.
424+ closes: #118628 Thanks, Doug Porter <dsp@debian.org>.
425+ * Fix formating of description of libjpeg-progs.
426+ closes: #114378 Thanks, Colin Watson <cjwatson@flatline.org.uk>.
427+ * Install jpegint.h header needed by some apps. closes: #100171
428+ * Remove unused/empty debian/postrm.
429+ closes: #24849 Thanks, Adrian Bridgett <adrian.bridgett@zetnet.co.uk>.
430+ * Install wizard.doc file. closes: #64807 Thanks <amc@arwen.cs.berkeley.edu>.
431+ * Fix libjpeg-progs test.sh.
432+ * Fix lintian bugs: typo in copyright, emacs user info in changelog.
433+ * Fix false lintian bug: unsafe ldconfig in postinst, by reformatting.
434+ * Remove "-g" from CFLAGS per Policy 11.1, hoping m68k is fixed now.
435+ * Remove libtool and Makefile in debian/rules clean.
436+ * Fix the test system. As a side effect,
437+ closes: #109195 Thanks Daniel Schepler <schepler@math.berkeley.edu>
438+ * Standards-Version is now 3.5.6.
439+
440+ -- Bill Allombert <ballombe@debian.org> Fri, 9 Nov 2001 22:40:16 +0100
441+
442+libjpeg6b (6b-1.3) frozen unstable; urgency=low
443+
444+ * Non-Maintainer Upload.
445+ * Added Build-Depends.
446+ * Gil Bahat <coutal@netvision.net.il> did the rest of the changes.
447+ * Close bug regarding non-standard jpegs not being processed
448+ (closes: #74087).
449+ * The output gifs are uncompressed, so have no UNISYS patent issues.
450+ (closes: #24330, #24291).
451+ * Standards-Version is now 3.0.0.
452+
453+ -- Jordi Mallach <jordi@debian.org> Sat, 24 Feb 2001 22:17:38 +0100
454+
455+libjpeg6b (6b-1.2) frozen unstable; urgency=low (HIGH for m68k)
456+
457+ * Non-maintainer release.
458+ * Recompile for m68k since existing djpeg binary claims all jpegs I have
459+ are invalid (yet hamm djpeg has no problem with them).
460+ Specifically, added "-O2 -g -Wall" to CFLAGS -- possible gcc bug?
461+
462+ -- Chris Lawrence <lawrencc@debian.org> Tue, 10 Nov 1998 20:57:38 -0600
463+
464+libjpeg6b (6b-1.1) frozen unstable; urgency=high
465+
466+ * Non-maintainer release.
467+ * Use upstream library soname (62).
468+ * Removed libjpeg-gif package, as the source notes
469+ that the GIF reading has been removed, and the GIFs written
470+ do not infringe on the LZW patent.
471+
472+ -- Joel Klecker <espy@debian.org> Thu, 22 Oct 1998 05:49:48 -0700
473+
474+libjpeg6b (6b-1) unstable; urgency=low
475+
476+ * New binary packages for 6b
477+ * New upstream release
478+
479+ -- Mark Mickan <mmickan@debian.org> Tue, 7 Jul 1998 22:27:10 +0930
480+
481+Local variables:
482+mode: debian-changelog
483+End:
484--- libjpeg7-7.orig/debian/libjpeg-progs.files
485+++ libjpeg7-7/debian/libjpeg-progs.files
486@@ -0,0 +1,2 @@
487+usr/bin
488+usr/share/man/man1
489--- libjpeg7-7.orig/debian/libjpeg7-dev.docs
490+++ libjpeg7-7/debian/libjpeg7-dev.docs
491@@ -0,0 +1,3 @@
492+libjpeg.txt
493+structure.txt
494+coderules.txt
495--- libjpeg7-7.orig/debian/libjpeg-progs.docs
496+++ libjpeg7-7/debian/libjpeg-progs.docs
497@@ -0,0 +1,2 @@
498+usage.txt
499+wizard.txt
500--- libjpeg7-7.orig/debian/copyright
501+++ libjpeg7-7/debian/copyright
502@@ -0,0 +1,96 @@
503+This is Debian's prepackaged version of the `jpeg library' by the Independent
504+JPEG Group.
505+
506+This package was created by Mark Mickan <mmickan@debian.org> from sources
507+which can be found at ftp://ftp.uu.net/graphics/jpeg/jpegsrc.v6b.tar.gz
508+
509+It is partly based on the libjpeg6a package originally put together by
510+Andy Guy <awpguy@acs.ucalgary.ca> and later maintained by Mark Mickan.
511+
512+Current Debian maintainer is Bill Allombert <ballombe@debian.org>.
513+
514+LEGAL ISSUES [ from README supplied with source - MM ]
515+============
516+
517+In plain English:
518+
519+1. We don't promise that this software works. (But if you find any bugs,
520+ please let us know!)
521+2. You can use this software for whatever you want. You don't have to pay us.
522+3. You may not pretend that you wrote this software. If you use it in a
523+ program, you must acknowledge somewhere in your documentation that
524+ you've used the IJG code.
525+
526+In legalese:
527+
528+The authors make NO WARRANTY or representation, either express or implied,
529+with respect to this software, its quality, accuracy, merchantability, or
530+fitness for a particular purpose. This software is provided "AS IS", and you,
531+its user, assume the entire risk as to its quality and accuracy.
532+
533+This software is copyright (C) 1991-2009, Thomas G. Lane, Guido Vollbeding.
534+All Rights Reserved except as specified below.
535+
536+Permission is hereby granted to use, copy, modify, and distribute this
537+software (or portions thereof) for any purpose, without fee, subject to these
538+conditions:
539+(1) If any part of the source code for this software is distributed, then this
540+README file must be included, with this copyright and no-warranty notice
541+unaltered; and any additions, deletions, or changes to the original files
542+must be clearly indicated in accompanying documentation.
543+(2) If only executable code is distributed, then the accompanying
544+documentation must state that "this software is based in part on the work of
545+the Independent JPEG Group".
546+(3) Permission for use of this software is granted only if the user accepts
547+full responsibility for any undesirable consequences; the authors accept
548+NO LIABILITY for damages of any kind.
549+
550+These conditions apply to any software derived from or based on the IJG code,
551+not just to the unmodified library. If you use our work, you ought to
552+acknowledge us.
553+
554+Permission is NOT granted for the use of any IJG author's name or company name
555+in advertising or publicity relating to this software or products derived from
556+it. This software may be referred to only as "the Independent JPEG Group's
557+software".
558+
559+We specifically permit and encourage the use of this software as the basis of
560+commercial products, provided that all warranty or liability claims are
561+assumed by the product vendor.
562+
563+
564+ansi2knr.c is included in this distribution by permission of L. Peter Deutsch,
565+sole proprietor of its copyright holder, Aladdin Enterprises of Menlo Park, CA.
566+ansi2knr.c is NOT covered by the above copyright and conditions, but instead
567+by the usual distribution terms of the Free Software Foundation; principally,
568+that you must include source code if you redistribute it. (See the file
569+ansi2knr.c for full details.) However, since ansi2knr.c is not needed as part
570+of any program generated from the IJG code, this does not limit you more than
571+the foregoing paragraphs do.
572+
573+The Unix configuration script "configure" was produced with GNU Autoconf.
574+It is copyright by the Free Software Foundation but is freely distributable.
575+The same holds for its supporting scripts (config.guess, config.sub,
576+ltconfig, ltmain.sh). Another support script, install-sh, is copyright
577+by M.I.T. but is also freely distributable.
578+
579+It appears that the arithmetic coding option of the JPEG spec is covered by
580+patents owned by IBM, AT&T, and Mitsubishi. Hence arithmetic coding cannot
581+legally be used without obtaining one or more licenses. For this reason,
582+support for arithmetic coding has been removed from the free JPEG software.
583+(Since arithmetic coding provides only a marginal gain over the unpatented
584+Huffman mode, it is unlikely that very many implementations will support it.)
585+So far as we are aware, there are no patent restrictions on the remaining
586+code.
587+
588+The IJG distribution formerly included code to read and write GIF files.
589+To avoid entanglement with the Unisys LZW patent, GIF reading support has
590+been removed altogether, and the GIF writer has been simplified to produce
591+"uncompressed GIFs". This technique does not use the LZW algorithm; the
592+resulting GIF files are larger than usual, but are readable by all standard
593+GIF decoders.
594+
595+We are required to state that
596+ "The Graphics Interchange Format(c) is the Copyright property of
597+ CompuServe Incorporated. GIF(sm) is a Service Mark property of
598+ CompuServe Incorporated."
599--- libjpeg7-7.orig/debian/extra/jpegexiforient.c
600+++ libjpeg7-7/debian/extra/jpegexiforient.c
601@@ -0,0 +1,299 @@
602+/*
603+ * jpegexiforient.c
604+ *
605+ * This is a utility program to get and set the Exif Orientation Tag.
606+ * It can be used together with jpegtran in scripts for automatic
607+ * orientation correction of digital camera pictures.
608+ *
609+ * The Exif orientation value gives the orientation of the camera
610+ * relative to the scene when the image was captured. The relation
611+ * of the '0th row' and '0th column' to visual position is shown as
612+ * below.
613+ *
614+ * Value | 0th Row | 0th Column
615+ * ------+-------------+-----------
616+ * 1 | top | left side
617+ * 2 | top | rigth side
618+ * 3 | bottom | rigth side
619+ * 4 | bottom | left side
620+ * 5 | left side | top
621+ * 6 | right side | top
622+ * 7 | right side | bottom
623+ * 8 | left side | bottom
624+ *
625+ * For convenience, here is what the letter F would look like if it were
626+ * tagged correctly and displayed by a program that ignores the orientation
627+ * tag:
628+ *
629+ * 1 2 3 4 5 6 7 8
630+ *
631+ * 888888 888888 88 88 8888888888 88 88 8888888888
632+ * 88 88 88 88 88 88 88 88 88 88 88 88
633+ * 8888 8888 8888 8888 88 8888888888 8888888888 88
634+ * 88 88 88 88
635+ * 88 88 888888 888888
636+ *
637+ */
638+
639+#include <stdio.h>
640+#include <stdlib.h>
641+
642+static FILE * myfile; /* My JPEG file */
643+
644+static unsigned char exif_data[65536L];
645+
646+/* Return next input byte, or EOF if no more */
647+#define NEXTBYTE() getc(myfile)
648+
649+/* Error exit handler */
650+#define ERREXIT(msg) (exit(0))
651+
652+/* Read one byte, testing for EOF */
653+static int
654+read_1_byte (void)
655+{
656+ int c;
657+
658+ c = NEXTBYTE();
659+ if (c == EOF)
660+ ERREXIT("Premature EOF in JPEG file");
661+ return c;
662+}
663+
664+/* Read 2 bytes, convert to unsigned int */
665+/* All 2-byte quantities in JPEG markers are MSB first */
666+static unsigned int
667+read_2_bytes (void)
668+{
669+ int c1, c2;
670+
671+ c1 = NEXTBYTE();
672+ if (c1 == EOF)
673+ ERREXIT("Premature EOF in JPEG file");
674+ c2 = NEXTBYTE();
675+ if (c2 == EOF)
676+ ERREXIT("Premature EOF in JPEG file");
677+ return (((unsigned int) c1) << 8) + ((unsigned int) c2);
678+}
679+
680+static const char * progname; /* program name for error messages */
681+
682+static void
683+usage (FILE *out)
684+/* complain about bad command line */
685+{
686+ fprintf(out, "jpegexiforient reads or writes the Exif Orientation Tag ");
687+ fprintf(out, "in a JPEG Exif file.\n");
688+
689+ fprintf(out, "Usage: %s [switches] jpegfile\n", progname);
690+
691+ fprintf(out, "Switches:\n");
692+ fprintf(out, " --help display this help and exit\n");
693+ fprintf(out, " --version output version information and exit\n");
694+ fprintf(out, " -n Do not output the trailing newline\n");
695+ fprintf(out, " -1 .. -8 Set orientation value 1 .. 8\n");
696+}
697+
698+/*
699+ * The main program.
700+ */
701+
702+int
703+main (int argc, char **argv)
704+{
705+ int n_flag, set_flag;
706+ unsigned int length, i;
707+ int is_motorola; /* Flag for byte order */
708+ unsigned int offset, number_of_tags, tagnum;
709+
710+ progname = argv[0];
711+ if (progname == NULL || progname[0] == 0)
712+ progname = "jpegexiforient"; /* in case C library doesn't provide it */
713+
714+ if (argc < 2) { usage(stderr); return 1; }
715+
716+ n_flag = 0; set_flag = 0;
717+
718+ i = 1;
719+ while (argv[i][0] == '-') {
720+ switch (argv[i][1]) {
721+ case '-':
722+ switch (argv[i][2]) {
723+ case 'h': usage(stdout); return 0;
724+ case 'v': fprintf(stdout,"jpegexiforient\n"); return 0;
725+ }
726+ case 'n':
727+ n_flag = 1;
728+ break;
729+ case '1':
730+ case '2':
731+ case '3':
732+ case '4':
733+ case '5':
734+ case '6':
735+ case '7':
736+ case '8':
737+ set_flag = argv[i][1] - '0';
738+ break;
739+ default:
740+ usage(stderr); return 1;
741+ }
742+ if (++i >= argc) { usage(stderr); return 1; }
743+ }
744+
745+ if (set_flag) {
746+ if ((myfile = fopen(argv[i], "rb+")) == NULL) {
747+ fprintf(stderr, "%s: can't open %s\n", progname, argv[i]);
748+ return 0;
749+ }
750+ } else {
751+ if ((myfile = fopen(argv[i], "rb")) == NULL) {
752+ fprintf(stderr, "%s: can't open %s\n", progname, argv[i]);
753+ return 0;
754+ }
755+ }
756+
757+ /* Read File head, check for JPEG SOI + Exif APP1 */
758+ for (i = 0; i < 4; i++)
759+ exif_data[i] = (unsigned char) read_1_byte();
760+ if (exif_data[0] != 0xFF ||
761+ exif_data[1] != 0xD8 ||
762+ exif_data[2] != 0xFF ||
763+ exif_data[3] != 0xE1)
764+ return 0;
765+
766+ /* Get the marker parameter length count */
767+ length = read_2_bytes();
768+ /* Length includes itself, so must be at least 2 */
769+ /* Following Exif data length must be at least 6 */
770+ if (length < 8)
771+ return 0;
772+ length -= 8;
773+ /* Read Exif head, check for "Exif" */
774+ for (i = 0; i < 6; i++)
775+ exif_data[i] = (unsigned char) read_1_byte();
776+ if (exif_data[0] != 0x45 ||
777+ exif_data[1] != 0x78 ||
778+ exif_data[2] != 0x69 ||
779+ exif_data[3] != 0x66 ||
780+ exif_data[4] != 0 ||
781+ exif_data[5] != 0)
782+ return 0;
783+ /* Read Exif body */
784+ for (i = 0; i < length; i++)
785+ exif_data[i] = (unsigned char) read_1_byte();
786+
787+ if (length < 12) return 0; /* Length of an IFD entry */
788+
789+ /* Discover byte order */
790+ if (exif_data[0] == 0x49 && exif_data[1] == 0x49)
791+ is_motorola = 0;
792+ else if (exif_data[0] == 0x4D && exif_data[1] == 0x4D)
793+ is_motorola = 1;
794+ else
795+ return 0;
796+
797+ /* Check Tag Mark */
798+ if (is_motorola) {
799+ if (exif_data[2] != 0) return 0;
800+ if (exif_data[3] != 0x2A) return 0;
801+ } else {
802+ if (exif_data[3] != 0) return 0;
803+ if (exif_data[2] != 0x2A) return 0;
804+ }
805+
806+ /* Get first IFD offset (offset to IFD0) */
807+ if (is_motorola) {
808+ if (exif_data[4] != 0) return 0;
809+ if (exif_data[5] != 0) return 0;
810+ offset = exif_data[6];
811+ offset <<= 8;
812+ offset += exif_data[7];
813+ } else {
814+ if (exif_data[7] != 0) return 0;
815+ if (exif_data[6] != 0) return 0;
816+ offset = exif_data[5];
817+ offset <<= 8;
818+ offset += exif_data[4];
819+ }
820+ if (offset > length - 2) return 0; /* check end of data segment */
821+
822+ /* Get the number of directory entries contained in this IFD */
823+ if (is_motorola) {
824+ number_of_tags = exif_data[offset];
825+ number_of_tags <<= 8;
826+ number_of_tags += exif_data[offset+1];
827+ } else {
828+ number_of_tags = exif_data[offset+1];
829+ number_of_tags <<= 8;
830+ number_of_tags += exif_data[offset];
831+ }
832+ if (number_of_tags == 0) return 0;
833+ offset += 2;
834+
835+ /* Search for Orientation Tag in IFD0 */
836+ for (;;) {
837+ if (offset > length - 12) return 0; /* check end of data segment */
838+ /* Get Tag number */
839+ if (is_motorola) {
840+ tagnum = exif_data[offset];
841+ tagnum <<= 8;
842+ tagnum += exif_data[offset+1];
843+ } else {
844+ tagnum = exif_data[offset+1];
845+ tagnum <<= 8;
846+ tagnum += exif_data[offset];
847+ }
848+ if (tagnum == 0x0112) break; /* found Orientation Tag */
849+ if (--number_of_tags == 0) return 0;
850+ offset += 12;
851+ }
852+
853+ if (set_flag) {
854+ /* Set the Orientation value */
855+ if (is_motorola) {
856+ exif_data[offset+2] = 0; /* Format = unsigned short (2 octets) */
857+ exif_data[offset+3] = 3;
858+ exif_data[offset+4] = 0; /* Number Of Components = 1 */
859+ exif_data[offset+5] = 0;
860+ exif_data[offset+6] = 0;
861+ exif_data[offset+7] = 1;
862+ exif_data[offset+8] = 0;
863+ exif_data[offset+9] = (unsigned char)set_flag;
864+ exif_data[offset+10] = 0;
865+ exif_data[offset+11] = 0;
866+ } else {
867+ exif_data[offset+2] = 3; /* Format = unsigned short (2 octets) */
868+ exif_data[offset+3] = 0;
869+ exif_data[offset+4] = 1; /* Number Of Components = 1 */
870+ exif_data[offset+5] = 0;
871+ exif_data[offset+6] = 0;
872+ exif_data[offset+7] = 0;
873+ exif_data[offset+8] = (unsigned char)set_flag;
874+ exif_data[offset+9] = 0;
875+ exif_data[offset+10] = 0;
876+ exif_data[offset+11] = 0;
877+ }
878+ fseek(myfile, (4 + 2 + 6 + 2) + offset, SEEK_SET);
879+ fwrite(exif_data + 2 + offset, 1, 10, myfile);
880+ } else {
881+ /* Get the Orientation value */
882+ if (is_motorola) {
883+ if (exif_data[offset+8] != 0) return 0;
884+ set_flag = exif_data[offset+9];
885+ } else {
886+ if (exif_data[offset+9] != 0) return 0;
887+ set_flag = exif_data[offset+8];
888+ }
889+ if (set_flag > 8) return 0;
890+ }
891+
892+ /* Write out Orientation value */
893+ if (n_flag)
894+ printf("%c", '0' + set_flag);
895+ else
896+ printf("%c\n", '0' + set_flag);
897+
898+ /* All done. */
899+ return 0;
900+}
901--- libjpeg7-7.orig/debian/extra/exifautotran.1
902+++ libjpeg7-7/debian/extra/exifautotran.1
903@@ -0,0 +1,13 @@
904+.TH EXIFAUTOTRAN "1" "February 2005" "exifautotran" "User Commands"
905+.SH NAME
906+exifautotran \- Transforms Exif files so that Orientation becomes 1
907+.SH DESCRIPTION
908+exifautotran [list of files]
909+.PP
910+Take a list of files as input and transform them in place so that the
911+Orientation becomes 1.
912+.SH "AUTHOR"
913+ Guido Vollbeding <guido@jpegclub.org>
914+.SH "SEE ALSO"
915+.BR jpegtran(1)
916+.BR jpegexiforient(1)
917--- libjpeg7-7.orig/debian/extra/jpegexiforient.1
918+++ libjpeg7-7/debian/extra/jpegexiforient.1
919@@ -0,0 +1,73 @@
920+.TH JPEGEXIFORIENT "1" "February 2005" "jpegexiforient" "User Commands"
921+.SH NAME
922+jpegexiforient \- reads or writes the Exif Orientation Tag
923+.SH SYNOPSIS
924+.B jpegexiforient
925+[\fIswitches\fR] \fIjpegfile\fR
926+.SH DESCRIPTION
927+.
928+This is a utility program to get and set the Exif Orientation Tag.
929+It can be used together with jpegtran in scripts for automatic
930+orientation correction of digital camera pictures.
931+.PP
932+The Exif orientation value gives the orientation of the camera
933+relative to the scene when the image was captured. The relation
934+of the '0th row' and '0th column' to visual position is shown as
935+below.
936+.IP
937+.nf
938+.ft CR
939+Value | 0th Row | 0th Column
940+------+-------------+-----------
941+ 1 | top | left side
942+ 2 | top | rigth side
943+ 3 | bottom | rigth side
944+ 4 | bottom | left side
945+ 5 | left side | top
946+ 6 | right side | top
947+ 7 | right side | bottom
948+ 8 | left side | bottom
949+.fi
950+.PP
951+For convenience, here is what the letter F would look like if it were
952+tagged correctly and displayed by a program that ignores the orientation
953+tag:
954+.IP
955+.nf
956+.ft CB
957+ 1 2 3 4
958+
959+888888 888888 88 88
960+88 88 88 88
961+8888 8888 8888 8888
962+88 88 88 88
963+88 88 888888 888888
964+
965+ 5 6 7 8
966+
967+8888888888 88 88 8888888888
968+88 88 88 88 88 88 88 88
969+88 8888888888 8888888888 88
970+.fi
971+.PP
972+jpegexiforient output the Exif Orientation Tag in a JPEG Exif file.
973+With the options -1 .. -8, it can also be used to set the tag.
974+.
975+.SS "OPTIONS"
976+.TP
977+\fB\-\-help\fR
978+display this help and exit
979+.TP
980+\fB\-\-version\fR
981+output version information and exit
982+.TP
983+\fB\-n\fR
984+Do not output the trailing newline
985+.TP
986+\fB\-1\fR .. \fB\-8\fR
987+Set orientation value 1 .. 8
988+.SH "AUTHOR"
989+ Guido Vollbeding <guido@jpegclub.org>
990+.SH "SEE ALSO"
991+.BR jpegtran(1)
992+.BR exifautotran(1)
993--- libjpeg7-7.orig/debian/extra/exifautotran
994+++ libjpeg7-7/debian/extra/exifautotran
995@@ -0,0 +1,50 @@
996+#!/bin/sh
997+# exifautotran [list of files]
998+#
999+# Transforms Exif files so that Orientation becomes 1
1000+#
1001+
1002+trap "if test -n \"\$tempfile\"; then rm -f \"\$tempfile\"; fi" INT QUIT TERM
1003+
1004+for i
1005+do
1006+ case $i in
1007+ -v|--version) echo "exifautotran"; exit 0;;
1008+ -h|--help)
1009+ cat <<EOF
1010+exifautotran [list of files]
1011+
1012+Transforms Exif files so that Orientation becomes 1
1013+EOF
1014+ exit 0;;
1015+ esac
1016+
1017+ case `jpegexiforient -n "$i"` in
1018+ 1) transform="";;
1019+ 2) transform="-flip horizontal";;
1020+ 3) transform="-rotate 180";;
1021+ 4) transform="-flip vertical";;
1022+ 5) transform="-transpose";;
1023+ 6) transform="-rotate 90";;
1024+ 7) transform="-transverse";;
1025+ 8) transform="-rotate 270";;
1026+ *) transform="";;
1027+ esac
1028+ if test -n "$transform"; then
1029+ tempfile=`mktemp`;
1030+ if test "$?" -ne "0"; then
1031+ echo "Failed to create temporary file" >&2
1032+ exit 1;
1033+ fi
1034+ echo Executing: jpegtran -copy all $transform $i >&2
1035+ jpegtran -copy all $transform "$i" > $tempfile
1036+ if test $? -ne 0; then
1037+ echo Error while transforming $i - skipped. >&2
1038+ rm "$tempfile"
1039+ else
1040+ cp "$tempfile" "$i"
1041+ rm "$tempfile"
1042+ jpegexiforient -1 "$i" > /dev/null
1043+ fi
1044+ fi
1045+done
1046--- libjpeg7-7.orig/debian/extra/Makefile
1047+++ libjpeg7-7/debian/extra/Makefile
1048@@ -0,0 +1,22 @@
1049+CFLAGS = -O2 -Wall -g
1050+CC = cc
1051+INSTALL = install -m755 -o root -g root
1052+INSTALLDIR = install -m755 -o root -g root -d
1053+DESTDIR =
1054+prefix = /usr/local
1055+bindir = $(prefix)/bin
1056+mandir = $(prefix)/share/man/man1
1057+
1058+all: jpegexiforient
1059+
1060+jpegexiforient: jpegexiforient.c
1061+ $(CC) $(CFLAGS) -o jpegexiforient jpegexiforient.c
1062+clean:
1063+ -rm -f jpegexiforient
1064+install:
1065+ $(INSTALLDIR) $(DESTDIR)$(bindir)
1066+ $(INSTALLDIR) $(DESTDIR)$(mandir)
1067+ $(INSTALL) jpegexiforient $(DESTDIR)$(bindir)
1068+ $(INSTALL) jpegexiforient.1 $(DESTDIR)$(mandir)
1069+ $(INSTALL) exifautotran $(DESTDIR)$(bindir)
1070+ $(INSTALL) exifautotran.1 $(DESTDIR)$(mandir)