summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/jpeg/jpeg-8b/debian-libjpeg7_7-1.diff
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-core/jpeg/jpeg-8b/debian-libjpeg7_7-1.diff')
-rwxr-xr-xmeta/recipes-core/jpeg/jpeg-8b/debian-libjpeg7_7-1.diff1066
1 files changed, 1066 insertions, 0 deletions
diff --git a/meta/recipes-core/jpeg/jpeg-8b/debian-libjpeg7_7-1.diff b/meta/recipes-core/jpeg/jpeg-8b/debian-libjpeg7_7-1.diff
new file mode 100755
index 0000000000..2e4867aa75
--- /dev/null
+++ b/meta/recipes-core/jpeg/jpeg-8b/debian-libjpeg7_7-1.diff
@@ -0,0 +1,1066 @@
1--- libjpeg7-7.orig/config.sub
2+++ libjpeg7-7/config.sub
3@@ -1,4 +1,10 @@
4 #! /bin/sh
5+# autotools-dev hack (<ballombe@debian.org>, Wed, 14 Nov 2001 10:13:10 +0100)
6+if [ -x /usr/share/misc/config.sub ]; then
7+ /usr/share/misc/config.sub $*
8+ exit $?
9+fi
10+
11 # Configuration validation subroutine script.
12 # Copyright (C) 1992, 1993, 1994, 1995, 1996, 1997, 1998, 1999,
13 # 2000, 2001, 2002, 2003, 2004, 2005, 2006, 2007, 2008
14--- libjpeg7-7.orig/config.guess
15+++ libjpeg7-7/config.guess
16@@ -1,4 +1,10 @@
17 #! /bin/sh
18+# autotools-dev hack (<ballombe@debian.org>, Wed, 14 Nov 2001 10:13:10 +0100)
19+if [ -x /usr/share/misc/config.guess ]; then
20+ /usr/share/misc/config.guess $*
21+ exit $?
22+fi
23+
24 # Attempt to guess a canonical system name.
25 # Copyright (C) 1992, 1993, 1994, 1995, 1996, 1997, 1998, 1999,
26 # 2000, 2001, 2002, 2003, 2004, 2005, 2006, 2007, 2008
27--- libjpeg7-7.orig/debian/libjpeg7-dev.files
28+++ libjpeg7-7/debian/libjpeg7-dev.files
29@@ -0,0 +1,4 @@
30+usr/include
31+usr/lib/libjpeg.a
32+usr/lib/libjpeg.la
33+usr/lib/libjpeg.so
34--- libjpeg7-7.orig/debian/libjpeg-progs.README.Debian
35+++ libjpeg7-7/debian/libjpeg-progs.README.Debian
36@@ -0,0 +1,13 @@
37+libjpeg-progs for Debian
38+========================
39+
40+This package contains programs for manipulating JPEG files:
41+ cjpeg/djpeg: convert to/from the JPEG file format
42+ rdjpgcom/wrjpgcom: read/write comments in JPEG files
43+ jpegtran: lossless transformations of JPEG files
44+ jpegexiforient/exifautotran: manipulate EXIF orientation tag
45+
46+Thanks for using Debian!
47+
48+--
49+Bill Allombert <ballombe@debian.org> Sun, 05 Jul 2009 15:18:59 +0200
50--- libjpeg7-7.orig/debian/shlibs.local
51+++ libjpeg7-7/debian/shlibs.local
52@@ -0,0 +1 @@
53+libjpeg 7 libjpeg7
54--- libjpeg7-7.orig/debian/rules
55+++ libjpeg7-7/debian/rules
56@@ -0,0 +1,71 @@
57+#!/usr/bin/make -f
58+# Made with the aid of debmake, by Christoph Lameter,
59+# based on the sample debian/rules file for GNU hello by Ian Jackson.
60+
61+package=libjpeg
62+
63+export DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
64+export DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
65+
66+export CFLAGS=-D_REENTRANT -g -Wall
67+ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
68+CFLAGS += -O0
69+else
70+CFLAGS += -O2
71+endif
72+
73+#export DH_VERBOSE=1
74+
75+build: build-stamp
76+build-stamp:
77+ dh_testdir
78+ ./configure --prefix=/usr --mandir=/usr/share/man \
79+ --enable-static --enable-shared \
80+ --build=$(DEB_BUILD_GNU_TYPE) --host=$(DEB_HOST_GNU_TYPE)
81+ $(MAKE)
82+ifeq (,$(findstring nocheck,$(DEB_BUILD_OPTIONS)))
83+ $(MAKE) check
84+endif
85+ $(MAKE) -C debian/extra
86+
87+ touch build-stamp
88+
89+clean:
90+ dh_testdir
91+ dh_testroot
92+ -rm -f build-stamp
93+ if [ -f Makefile ]; then $(MAKE) distclean; fi
94+ $(MAKE) clean -C debian/extra
95+ dh_clean
96+
97+binary-indep:
98+
99+binary-arch: build
100+ dh_testdir
101+ dh_testroot
102+ dh_clean -k
103+ dh_installdirs
104+ $(MAKE) install DESTDIR=`pwd`/debian/tmp
105+ $(MAKE) install -C debian/extra prefix=/usr DESTDIR=`pwd`/debian/tmp
106+ # fix jconfig.h
107+ rm debian/tmp/usr/include/jconfig.h
108+ sed -e "s/#\(undef\|define\) HAVE_\(LOCALE\|\(STD\(DEF\|LIB\)\)\)_H 1//g" \
109+ jconfig.h > debian/tmp/usr/include/jconfig.h
110+ # separate out lib package
111+ dh_movefiles
112+ # Finish it off with debhelper
113+ dh_installdocs README
114+ dh_installexamples
115+ dh_installchangelogs change.log
116+ dh_strip --dbg-package=libjpeg7-dbg
117+ dh_compress
118+ dh_fixperms
119+ dh_installdeb
120+ dh_shlibdeps -l`pwd`/debian/libjpeg7/usr/lib
121+ dh_gencontrol
122+ dh_md5sums
123+ dh_builddeb
124+
125+binary: binary-indep binary-arch
126+
127+.PHONY: clean binary-indep binary-arch binary build
128--- libjpeg7-7.orig/debian/libjpeg7-dev.README.Debian
129+++ libjpeg7-7/debian/libjpeg7-dev.README.Debian
130@@ -0,0 +1,18 @@
131+IJG JPEG for Debian
132+===================
133+
134+The following patch has been applied to the headers files:
135+
136+--- jconfig.h: Remove unused symbol HAVE_STDDEF_H, HAVE_STDLIB_H and
137+HAVE_LOCALE_H since they are not used by the installed headers files and cause
138+problem with autoconf.
139+
140+This can theoretically cause problems if your software relies on theses symbols
141+being defined by this header. If it ever happens, please define them manually.
142+
143+Note: this is not Debian-specific, others distributions apply similar patches.
144+
145+Thanks for using Debian!
146+
147+---
148+Bill Allombert <ballombe@debian.org> Sun, 05 Jul 2009 15:17:56 +0200
149--- libjpeg7-7.orig/debian/shlibs
150+++ libjpeg7-7/debian/shlibs
151@@ -0,0 +1 @@
152+libjpeg 7 libjpeg7
153--- libjpeg7-7.orig/debian/control
154+++ libjpeg7-7/debian/control
155@@ -0,0 +1,52 @@
156+Source: libjpeg7
157+Maintainer: Bill Allombert <ballombe@debian.org>
158+Section: graphics
159+Priority: optional
160+Build-Depends: debhelper (>= 5), autotools-dev
161+Standards-Version: 3.8.2
162+
163+Package: libjpeg7
164+Architecture: any
165+Section: libs
166+Description: The Independent JPEG Group's JPEG runtime library
167+ The Independent JPEG Group's JPEG library is a library for handling
168+ JPEG files.
169+ .
170+ This package contains the shared library.
171+Depends: ${shlibs:Depends}
172+
173+Package: libjpeg7-dev
174+Architecture: any
175+Section: libdevel
176+Description: Development files for the IJG JPEG library
177+ The Independent JPEG Group's JPEG library is a library for handling
178+ JPEG files.
179+ .
180+ This package contains the static library, headers and documentation.
181+Depends: libjpeg7 (=${binary:Version}), libc-dev
182+Conflicts: libjpeg62-dev
183+Replaces: libjpeg62-dev
184+
185+Package: libjpeg7-dbg
186+Architecture: any
187+Section: debug
188+Priority: extra
189+Description: Development files for the IJG JPEG library
190+ The Independent JPEG Group's JPEG library is a library for handling
191+ JPEG files.
192+ .
193+ This package contains the debugging symbols for libjpeg.
194+Provides: libjpeg-dbg
195+Depends: libjpeg7 (=${binary:Version})
196+Conflicts: libjpeg62-dbg
197+Replaces: libjpeg62-dbg
198+
199+Package: libjpeg-progs
200+Architecture: any
201+Description: Programs for manipulating JPEG files
202+ This package contains programs for manipulating JPEG files:
203+ cjpeg/djpeg: convert to/from the JPEG file format
204+ rdjpgcom/wrjpgcom: read/write comments in JPEG files
205+ jpegtran: lossless transformations of JPEG files
206+ jpegexiforient/exifautotran: manipulate EXIF orientation tag
207+Depends: ${shlibs:Depends}
208--- libjpeg7-7.orig/debian/libjpeg7.files
209+++ libjpeg7-7/debian/libjpeg7.files
210@@ -0,0 +1,2 @@
211+/usr/lib/libjpeg.so.7.0.0
212+/usr/lib/libjpeg.so.7
213--- libjpeg7-7.orig/debian/postinst
214+++ libjpeg7-7/debian/postinst
215@@ -0,0 +1,8 @@
216+#!/bin/sh -e
217+
218+#DEBHELPER#
219+
220+if [ "$1" = "configure" ]; then
221+ ldconfig
222+fi
223+
224--- libjpeg7-7.orig/debian/compat
225+++ libjpeg7-7/debian/compat
226@@ -0,0 +1 @@
227+5
228--- libjpeg7-7.orig/debian/libjpeg7-dev.examples
229+++ libjpeg7-7/debian/libjpeg7-dev.examples
230@@ -0,0 +1 @@
231+example.c
232--- libjpeg7-7.orig/debian/changelog
233+++ libjpeg7-7/debian/changelog
234@@ -0,0 +1,245 @@
235+libjpeg7 (7-1) unstable; urgency=low
236+
237+ * The "Yoan" release.
238+ * New upstream release. closes: #535350
239+ - This release includes configure.ac and Makefile.am. closes: #346126
240+ - All patches merged upstream.
241+ - Remove dpatch support.
242+ * debian/control:
243+ - Remove Build-Dependency on libtool and sharutils.
244+ - Move libjpeg7-dbg to debug section.
245+ - Bump standard version to 3.8.2.
246+ * Skip test-suite if nocheck is set. closes: #451222
247+
248+ -- Bill Allombert <ballombe@debian.org> Sun, 05 Jul 2009 15:29:27 +0200
249+
250+libjpeg6b (6b-14) unstable; urgency=low
251+
252+ * The "Lino" release.
253+ * exifautotran:
254+ - fix typo in manpage. closes: #376371, thanks Reuben Thomas.
255+ - preserve file mode. closes: #383379, thanks Vincent Arkesteijn.
256+ * debian/control, debian/rules, debian/compat:
257+ + switch to debhelper v5
258+ + add libjpeg-dbg debugging package.
259+ * debian/rules: remove - before "make clean" rules.
260+ * Add patch 204_jpegtran_man to improve readability of manpage.
261+ closes: #437453. Thanks Jorgen Grahn.
262+ * jpegexiforient.1: Apply patch from Jorgen Grahn to improve formatting.
263+ closes: #437446.
264+
265+ -- Bill Allombert <ballombe@debian.org> Thu, 16 Aug 2007 22:59:21 +0200
266+
267+libjpeg6b (6b-13) unstable; urgency=low
268+
269+ * The "If at first you don't succeed..." release.
270+ * Change --enable-maxmem to 1024, following Guido advice.
271+ This should fix the slowdowns with large files (for large < 1Gb):
272+ closes: #356556, #365025, Thanks Nicolas.
273+ If you hit performance problems, please set the JPEGMEM variable to
274+ about half your available RAM, see jpegtran(1).
275+ * Update libjpeg-progs README.Debian to reflect the new patch set and
276+ the JPEGMEM feature.
277+ * Bump standard version to 3.7.2.
278+
279+ -- Bill Allombert <ballombe@debian.org> Fri, 5 May 2006 19:14:25 +0200
280+
281+libjpeg6b (6b-12) unstable; urgency=low
282+
283+ * The "vote for me" release
284+ * Bump standard version to 3.6.2.
285+ * Run 'make test' instead of home-made test-suite.
286+ * Switch to debhelper v4.
287+ * libjpeg is now configured with --enable-maxmem=32. This limits the memory
288+ usage to 32Mb and it can be overrided by JPEGMEM. Without this flag
289+ JPEGMEM is ignored and there were no limits.
290+ closes: #346023. Thanks C. Scott Ananian.
291+
292+ -- Bill Allombert <ballombe@debian.org> Thu, 2 Mar 2006 18:52:44 +0100
293+
294+libjpeg6b (6b-11) unstable; urgency=high
295+
296+ * The "Silencio" release
297+ * exifautotran: Apply patch by Uwe Zeisberger to fix bad temporary file
298+ handling. closes: #340079
299+
300+ -- Bill Allombert <ballombe@debian.org> Sun, 20 Nov 2005 20:57:07 +0100
301+
302+libjpeg6b (6b-10) unstable; urgency=low
303+
304+ * The "timeout" release.
305+ * Rebuild with current toolchain.
306+ * Depends on libc-dev instead of libc6-dev. closes: #294696
307+ Thanks Joel Aelwyn for discussing thoroughly the matter.
308+ * Instead of copying /usr/bin/libtool, we replace it by a script that
309+ call libtool (using standard path search). Remarked by Jesus Climent.
310+ * debian/control: remove pre-hamm cruft.
311+ * Add jpegexiforient and jpegautotran by Guido Vollbeding
312+ <http://sylvana.net/jpegcrop/exif_orientation.html> as proposed by Philip
313+ Armstrong. closes: #257061.
314+ * Run the test-suite at build time instead of shipping it in the package:
315+ - /usr/share/doc/libjpeg-progs/tests: removed.
316+ - debian/control: Add Build-Depends on sharutils for uuencode.
317+ - debian/libjpeg-progs.dirs: removed.
318+ - debian/libjpeg-progs.test: removed.
319+
320+ -- Bill Allombert <ballombe@debian.org> Tue, 1 Mar 2005 19:43:26 +0100
321+
322+libjpeg6b (6b-9) unstable; urgency=low
323+
324+ * The "I'm all for aggressive goals" release.
325+ * Rebuild with new libtool. closes: #201943.
326+ * patch 100_crop: Updated from Guido Vollbeding <guido@jpegclub.org>
327+ to include patches 203_jpegtran_errmsg,204_perfect.
328+ * patch 200_crop_man: Include 205_perfect_man.
329+ * patches 203_jpegtran_errmsg, 204_perfect, 205_perfect_man: removed
330+ * Add patch 203_rdppm: fix cjpeg issue with 16-bit PPM files. closes: #208937
331+ * Bump standard version to 3.6.1.
332+ * Update debian/edit-patch.
333+
334+ -- Bill Allombert <ballombe@debian.org> Mon, 8 Sep 2003 16:22:08 +0200
335+
336+libjpeg6b (6b-8) unstable; urgency=low
337+
338+ * The "I *hate* when that happens" release.
339+ * Move libjpeg62-dev to libdevel section.
340+ * See debian/README.sources for detail about the (d)patch system.
341+ * debian/rules: avoid to run configure twice.
342+ * Add patches 204_perfect and 205_perfect_man. They implement the
343+ -perfect jpegtran option as proposed by Mark W. Eichin. closes: #189027
344+ * Bump standard version to 3.5.10.
345+ * Use /usr/bin/libtool instead of ldconfig-generated libtool, and remove
346+ various libtool related kludges, including patch 301_configure.
347+ closes: #195281. Thanks Robert Millan for the suggestion.
348+ * Remove patch 302_makefile. Fix debian/rules instead.
349+
350+ -- Bill Allombert <ballombe@debian.org> Sat, 31 May 2003 16:16:59 +0200
351+
352+libjpeg6b (6b-7) unstable; urgency=low
353+
354+ * Rebuild with new gcc/new glibc/new debhelper.
355+ * Add -g to build options according to new policy.
356+ * Add support for DEB_BUILD_OPTIONS noopt. nostrip is handled by dh_strip.
357+ * Bump standard version to 3.5.9.
358+ * Extend description a bit (If you have a better one please email me!).
359+ * Use dpatch to handle the patches.
360+
361+ -- Bill Allombert <ballombe@debian.org> Sun, 16 Mar 2003 12:19:36 +0100
362+
363+libjpeg6b (6b-6) unstable; urgency=low
364+
365+ * The "Try to break sarge before it even got a name" release
366+ * jpegtran: better error messages when opening files.
367+ closes: #147516 Thanks Mark W. Eichin.
368+ * Add debian/patch dir with my patches.
369+ * Add extern "C" if we are under C++.
370+ closes: #113167 Thanks, Fredrik Jagenheim.
371+ * Remove HAVE_STD{LIB,DEF}_H from jconfig.h since they are not used and
372+ conflict with autoconf. closes: #109516 Thanks <Benedikt.Roth@gmx.net>
373+ * Add README.Debian in /usr/share/libjpeg62-dev
374+
375+ -- Bill Allombert <ballombe@debian.org> Mon, 3 Jun 2002 19:34:08 +0200
376+
377+libjpeg6b (6b-5) unstable; urgency=low
378+
379+ * jpeg-->JPEG in libjpeg-progs description.
380+ * Add lib path to dh_shlibdeps to avoid warning.
381+ * Apply patch from <http://sylvana.net/jpegcrop/croppatch.tar.gz> by
382+ <guido@jpegclub.org> closes: #129412 Thanks, Colin Marquardt.
383+
384+ -- Bill Allombert <ballombe@debian.org> Mon, 20 May 2002 11:55:22 +0200
385+
386+libjpeg6b (6b-4) unstable; urgency=low
387+
388+ * Avoid bashism in debian/rules.
389+ * Update libtool to 1.3.5. (1.4 will break).
390+ closes: #52095 Thanks, <Marcus.Brinkmann@ruhr-uni-bochum.de>
391+ * Patch config.guess to use version in the autotools-dev package.
392+ * Correct Section: field of libjpeg62 and libjpeg62-dev.
393+
394+ -- Bill Allombert <ballombe@debian.org> Tue, 20 Nov 2001 10:23:47 +0100
395+
396+libjpeg6b (6b-3) unstable; urgency=low
397+
398+ * The "Where is ltconfig ?" release.
399+ * Remove jconfig.h in debian/rules clean and do some clean up.
400+ * Install libjpeg.la per Policy 11.2.
401+ * Remove duplicate wizard.doc file in libjpeg62-dev.
402+ * Use dpkg-architecture instead of config.guess.
403+ * Patch config.sub to use version in the autotools-dev package.
404+ closes: #85558, #120039
405+ * Patch rdjpgcom.c to use locales for isprint check on comment chars.
406+ closes: #116589 Thanks, Neal H Walfield <neal@cs.uml.edu>
407+ * Apply patch from <http://sylvana.net/jpegcrop/transupp.c> by
408+ <guido@jpegclub.org> closes: #114415 Thanks, <Jean-Marc.Notin@loria.fr>
409+
410+ -- Bill Allombert <ballombe@debian.org> Tue, 13 Nov 2001 21:41:49 +0000
411+
412+libjpeg6b (6b-2) unstable; urgency=low
413+
414+ * New Maintainer. Mark, If you want back the package, just ask!
415+ * Acknowledge previous NMU:
416+ Jordi: closes: #74087, #24330, #24291
417+ Colin: closes: #80752
418+ Joel: closes: #25324, #27033, #28341
419+ * Write source location as a valid URL in debian/copyright.
420+ closes: #118628 Thanks, Doug Porter <dsp@debian.org>.
421+ * Fix formating of description of libjpeg-progs.
422+ closes: #114378 Thanks, Colin Watson <cjwatson@flatline.org.uk>.
423+ * Install jpegint.h header needed by some apps. closes: #100171
424+ * Remove unused/empty debian/postrm.
425+ closes: #24849 Thanks, Adrian Bridgett <adrian.bridgett@zetnet.co.uk>.
426+ * Install wizard.doc file. closes: #64807 Thanks <amc@arwen.cs.berkeley.edu>.
427+ * Fix libjpeg-progs test.sh.
428+ * Fix lintian bugs: typo in copyright, emacs user info in changelog.
429+ * Fix false lintian bug: unsafe ldconfig in postinst, by reformatting.
430+ * Remove "-g" from CFLAGS per Policy 11.1, hoping m68k is fixed now.
431+ * Remove libtool and Makefile in debian/rules clean.
432+ * Fix the test system. As a side effect,
433+ closes: #109195 Thanks Daniel Schepler <schepler@math.berkeley.edu>
434+ * Standards-Version is now 3.5.6.
435+
436+ -- Bill Allombert <ballombe@debian.org> Fri, 9 Nov 2001 22:40:16 +0100
437+
438+libjpeg6b (6b-1.3) frozen unstable; urgency=low
439+
440+ * Non-Maintainer Upload.
441+ * Added Build-Depends.
442+ * Gil Bahat <coutal@netvision.net.il> did the rest of the changes.
443+ * Close bug regarding non-standard jpegs not being processed
444+ (closes: #74087).
445+ * The output gifs are uncompressed, so have no UNISYS patent issues.
446+ (closes: #24330, #24291).
447+ * Standards-Version is now 3.0.0.
448+
449+ -- Jordi Mallach <jordi@debian.org> Sat, 24 Feb 2001 22:17:38 +0100
450+
451+libjpeg6b (6b-1.2) frozen unstable; urgency=low (HIGH for m68k)
452+
453+ * Non-maintainer release.
454+ * Recompile for m68k since existing djpeg binary claims all jpegs I have
455+ are invalid (yet hamm djpeg has no problem with them).
456+ Specifically, added "-O2 -g -Wall" to CFLAGS -- possible gcc bug?
457+
458+ -- Chris Lawrence <lawrencc@debian.org> Tue, 10 Nov 1998 20:57:38 -0600
459+
460+libjpeg6b (6b-1.1) frozen unstable; urgency=high
461+
462+ * Non-maintainer release.
463+ * Use upstream library soname (62).
464+ * Removed libjpeg-gif package, as the source notes
465+ that the GIF reading has been removed, and the GIFs written
466+ do not infringe on the LZW patent.
467+
468+ -- Joel Klecker <espy@debian.org> Thu, 22 Oct 1998 05:49:48 -0700
469+
470+libjpeg6b (6b-1) unstable; urgency=low
471+
472+ * New binary packages for 6b
473+ * New upstream release
474+
475+ -- Mark Mickan <mmickan@debian.org> Tue, 7 Jul 1998 22:27:10 +0930
476+
477+Local variables:
478+mode: debian-changelog
479+End:
480--- libjpeg7-7.orig/debian/libjpeg-progs.files
481+++ libjpeg7-7/debian/libjpeg-progs.files
482@@ -0,0 +1,2 @@
483+usr/bin
484+usr/share/man/man1
485--- libjpeg7-7.orig/debian/libjpeg7-dev.docs
486+++ libjpeg7-7/debian/libjpeg7-dev.docs
487@@ -0,0 +1,3 @@
488+libjpeg.txt
489+structure.txt
490+coderules.txt
491--- libjpeg7-7.orig/debian/libjpeg-progs.docs
492+++ libjpeg7-7/debian/libjpeg-progs.docs
493@@ -0,0 +1,2 @@
494+usage.txt
495+wizard.txt
496--- libjpeg7-7.orig/debian/copyright
497+++ libjpeg7-7/debian/copyright
498@@ -0,0 +1,96 @@
499+This is Debian's prepackaged version of the `jpeg library' by the Independent
500+JPEG Group.
501+
502+This package was created by Mark Mickan <mmickan@debian.org> from sources
503+which can be found at ftp://ftp.uu.net/graphics/jpeg/jpegsrc.v6b.tar.gz
504+
505+It is partly based on the libjpeg6a package originally put together by
506+Andy Guy <awpguy@acs.ucalgary.ca> and later maintained by Mark Mickan.
507+
508+Current Debian maintainer is Bill Allombert <ballombe@debian.org>.
509+
510+LEGAL ISSUES [ from README supplied with source - MM ]
511+============
512+
513+In plain English:
514+
515+1. We don't promise that this software works. (But if you find any bugs,
516+ please let us know!)
517+2. You can use this software for whatever you want. You don't have to pay us.
518+3. You may not pretend that you wrote this software. If you use it in a
519+ program, you must acknowledge somewhere in your documentation that
520+ you've used the IJG code.
521+
522+In legalese:
523+
524+The authors make NO WARRANTY or representation, either express or implied,
525+with respect to this software, its quality, accuracy, merchantability, or
526+fitness for a particular purpose. This software is provided "AS IS", and you,
527+its user, assume the entire risk as to its quality and accuracy.
528+
529+This software is copyright (C) 1991-2009, Thomas G. Lane, Guido Vollbeding.
530+All Rights Reserved except as specified below.
531+
532+Permission is hereby granted to use, copy, modify, and distribute this
533+software (or portions thereof) for any purpose, without fee, subject to these
534+conditions:
535+(1) If any part of the source code for this software is distributed, then this
536+README file must be included, with this copyright and no-warranty notice
537+unaltered; and any additions, deletions, or changes to the original files
538+must be clearly indicated in accompanying documentation.
539+(2) If only executable code is distributed, then the accompanying
540+documentation must state that "this software is based in part on the work of
541+the Independent JPEG Group".
542+(3) Permission for use of this software is granted only if the user accepts
543+full responsibility for any undesirable consequences; the authors accept
544+NO LIABILITY for damages of any kind.
545+
546+These conditions apply to any software derived from or based on the IJG code,
547+not just to the unmodified library. If you use our work, you ought to
548+acknowledge us.
549+
550+Permission is NOT granted for the use of any IJG author's name or company name
551+in advertising or publicity relating to this software or products derived from
552+it. This software may be referred to only as "the Independent JPEG Group's
553+software".
554+
555+We specifically permit and encourage the use of this software as the basis of
556+commercial products, provided that all warranty or liability claims are
557+assumed by the product vendor.
558+
559+
560+ansi2knr.c is included in this distribution by permission of L. Peter Deutsch,
561+sole proprietor of its copyright holder, Aladdin Enterprises of Menlo Park, CA.
562+ansi2knr.c is NOT covered by the above copyright and conditions, but instead
563+by the usual distribution terms of the Free Software Foundation; principally,
564+that you must include source code if you redistribute it. (See the file
565+ansi2knr.c for full details.) However, since ansi2knr.c is not needed as part
566+of any program generated from the IJG code, this does not limit you more than
567+the foregoing paragraphs do.
568+
569+The Unix configuration script "configure" was produced with GNU Autoconf.
570+It is copyright by the Free Software Foundation but is freely distributable.
571+The same holds for its supporting scripts (config.guess, config.sub,
572+ltconfig, ltmain.sh). Another support script, install-sh, is copyright
573+by M.I.T. but is also freely distributable.
574+
575+It appears that the arithmetic coding option of the JPEG spec is covered by
576+patents owned by IBM, AT&T, and Mitsubishi. Hence arithmetic coding cannot
577+legally be used without obtaining one or more licenses. For this reason,
578+support for arithmetic coding has been removed from the free JPEG software.
579+(Since arithmetic coding provides only a marginal gain over the unpatented
580+Huffman mode, it is unlikely that very many implementations will support it.)
581+So far as we are aware, there are no patent restrictions on the remaining
582+code.
583+
584+The IJG distribution formerly included code to read and write GIF files.
585+To avoid entanglement with the Unisys LZW patent, GIF reading support has
586+been removed altogether, and the GIF writer has been simplified to produce
587+"uncompressed GIFs". This technique does not use the LZW algorithm; the
588+resulting GIF files are larger than usual, but are readable by all standard
589+GIF decoders.
590+
591+We are required to state that
592+ "The Graphics Interchange Format(c) is the Copyright property of
593+ CompuServe Incorporated. GIF(sm) is a Service Mark property of
594+ CompuServe Incorporated."
595--- libjpeg7-7.orig/debian/extra/jpegexiforient.c
596+++ libjpeg7-7/debian/extra/jpegexiforient.c
597@@ -0,0 +1,299 @@
598+/*
599+ * jpegexiforient.c
600+ *
601+ * This is a utility program to get and set the Exif Orientation Tag.
602+ * It can be used together with jpegtran in scripts for automatic
603+ * orientation correction of digital camera pictures.
604+ *
605+ * The Exif orientation value gives the orientation of the camera
606+ * relative to the scene when the image was captured. The relation
607+ * of the '0th row' and '0th column' to visual position is shown as
608+ * below.
609+ *
610+ * Value | 0th Row | 0th Column
611+ * ------+-------------+-----------
612+ * 1 | top | left side
613+ * 2 | top | rigth side
614+ * 3 | bottom | rigth side
615+ * 4 | bottom | left side
616+ * 5 | left side | top
617+ * 6 | right side | top
618+ * 7 | right side | bottom
619+ * 8 | left side | bottom
620+ *
621+ * For convenience, here is what the letter F would look like if it were
622+ * tagged correctly and displayed by a program that ignores the orientation
623+ * tag:
624+ *
625+ * 1 2 3 4 5 6 7 8
626+ *
627+ * 888888 888888 88 88 8888888888 88 88 8888888888
628+ * 88 88 88 88 88 88 88 88 88 88 88 88
629+ * 8888 8888 8888 8888 88 8888888888 8888888888 88
630+ * 88 88 88 88
631+ * 88 88 888888 888888
632+ *
633+ */
634+
635+#include <stdio.h>
636+#include <stdlib.h>
637+
638+static FILE * myfile; /* My JPEG file */
639+
640+static unsigned char exif_data[65536L];
641+
642+/* Return next input byte, or EOF if no more */
643+#define NEXTBYTE() getc(myfile)
644+
645+/* Error exit handler */
646+#define ERREXIT(msg) (exit(0))
647+
648+/* Read one byte, testing for EOF */
649+static int
650+read_1_byte (void)
651+{
652+ int c;
653+
654+ c = NEXTBYTE();
655+ if (c == EOF)
656+ ERREXIT("Premature EOF in JPEG file");
657+ return c;
658+}
659+
660+/* Read 2 bytes, convert to unsigned int */
661+/* All 2-byte quantities in JPEG markers are MSB first */
662+static unsigned int
663+read_2_bytes (void)
664+{
665+ int c1, c2;
666+
667+ c1 = NEXTBYTE();
668+ if (c1 == EOF)
669+ ERREXIT("Premature EOF in JPEG file");
670+ c2 = NEXTBYTE();
671+ if (c2 == EOF)
672+ ERREXIT("Premature EOF in JPEG file");
673+ return (((unsigned int) c1) << 8) + ((unsigned int) c2);
674+}
675+
676+static const char * progname; /* program name for error messages */
677+
678+static void
679+usage (FILE *out)
680+/* complain about bad command line */
681+{
682+ fprintf(out, "jpegexiforient reads or writes the Exif Orientation Tag ");
683+ fprintf(out, "in a JPEG Exif file.\n");
684+
685+ fprintf(out, "Usage: %s [switches] jpegfile\n", progname);
686+
687+ fprintf(out, "Switches:\n");
688+ fprintf(out, " --help display this help and exit\n");
689+ fprintf(out, " --version output version information and exit\n");
690+ fprintf(out, " -n Do not output the trailing newline\n");
691+ fprintf(out, " -1 .. -8 Set orientation value 1 .. 8\n");
692+}
693+
694+/*
695+ * The main program.
696+ */
697+
698+int
699+main (int argc, char **argv)
700+{
701+ int n_flag, set_flag;
702+ unsigned int length, i;
703+ int is_motorola; /* Flag for byte order */
704+ unsigned int offset, number_of_tags, tagnum;
705+
706+ progname = argv[0];
707+ if (progname == NULL || progname[0] == 0)
708+ progname = "jpegexiforient"; /* in case C library doesn't provide it */
709+
710+ if (argc < 2) { usage(stderr); return 1; }
711+
712+ n_flag = 0; set_flag = 0;
713+
714+ i = 1;
715+ while (argv[i][0] == '-') {
716+ switch (argv[i][1]) {
717+ case '-':
718+ switch (argv[i][2]) {
719+ case 'h': usage(stdout); return 0;
720+ case 'v': fprintf(stdout,"jpegexiforient\n"); return 0;
721+ }
722+ case 'n':
723+ n_flag = 1;
724+ break;
725+ case '1':
726+ case '2':
727+ case '3':
728+ case '4':
729+ case '5':
730+ case '6':
731+ case '7':
732+ case '8':
733+ set_flag = argv[i][1] - '0';
734+ break;
735+ default:
736+ usage(stderr); return 1;
737+ }
738+ if (++i >= argc) { usage(stderr); return 1; }
739+ }
740+
741+ if (set_flag) {
742+ if ((myfile = fopen(argv[i], "rb+")) == NULL) {
743+ fprintf(stderr, "%s: can't open %s\n", progname, argv[i]);
744+ return 0;
745+ }
746+ } else {
747+ if ((myfile = fopen(argv[i], "rb")) == NULL) {
748+ fprintf(stderr, "%s: can't open %s\n", progname, argv[i]);
749+ return 0;
750+ }
751+ }
752+
753+ /* Read File head, check for JPEG SOI + Exif APP1 */
754+ for (i = 0; i < 4; i++)
755+ exif_data[i] = (unsigned char) read_1_byte();
756+ if (exif_data[0] != 0xFF ||
757+ exif_data[1] != 0xD8 ||
758+ exif_data[2] != 0xFF ||
759+ exif_data[3] != 0xE1)
760+ return 0;
761+
762+ /* Get the marker parameter length count */
763+ length = read_2_bytes();
764+ /* Length includes itself, so must be at least 2 */
765+ /* Following Exif data length must be at least 6 */
766+ if (length < 8)
767+ return 0;
768+ length -= 8;
769+ /* Read Exif head, check for "Exif" */
770+ for (i = 0; i < 6; i++)
771+ exif_data[i] = (unsigned char) read_1_byte();
772+ if (exif_data[0] != 0x45 ||
773+ exif_data[1] != 0x78 ||
774+ exif_data[2] != 0x69 ||
775+ exif_data[3] != 0x66 ||
776+ exif_data[4] != 0 ||
777+ exif_data[5] != 0)
778+ return 0;
779+ /* Read Exif body */
780+ for (i = 0; i < length; i++)
781+ exif_data[i] = (unsigned char) read_1_byte();
782+
783+ if (length < 12) return 0; /* Length of an IFD entry */
784+
785+ /* Discover byte order */
786+ if (exif_data[0] == 0x49 && exif_data[1] == 0x49)
787+ is_motorola = 0;
788+ else if (exif_data[0] == 0x4D && exif_data[1] == 0x4D)
789+ is_motorola = 1;
790+ else
791+ return 0;
792+
793+ /* Check Tag Mark */
794+ if (is_motorola) {
795+ if (exif_data[2] != 0) return 0;
796+ if (exif_data[3] != 0x2A) return 0;
797+ } else {
798+ if (exif_data[3] != 0) return 0;
799+ if (exif_data[2] != 0x2A) return 0;
800+ }
801+
802+ /* Get first IFD offset (offset to IFD0) */
803+ if (is_motorola) {
804+ if (exif_data[4] != 0) return 0;
805+ if (exif_data[5] != 0) return 0;
806+ offset = exif_data[6];
807+ offset <<= 8;
808+ offset += exif_data[7];
809+ } else {
810+ if (exif_data[7] != 0) return 0;
811+ if (exif_data[6] != 0) return 0;
812+ offset = exif_data[5];
813+ offset <<= 8;
814+ offset += exif_data[4];
815+ }
816+ if (offset > length - 2) return 0; /* check end of data segment */
817+
818+ /* Get the number of directory entries contained in this IFD */
819+ if (is_motorola) {
820+ number_of_tags = exif_data[offset];
821+ number_of_tags <<= 8;
822+ number_of_tags += exif_data[offset+1];
823+ } else {
824+ number_of_tags = exif_data[offset+1];
825+ number_of_tags <<= 8;
826+ number_of_tags += exif_data[offset];
827+ }
828+ if (number_of_tags == 0) return 0;
829+ offset += 2;
830+
831+ /* Search for Orientation Tag in IFD0 */
832+ for (;;) {
833+ if (offset > length - 12) return 0; /* check end of data segment */
834+ /* Get Tag number */
835+ if (is_motorola) {
836+ tagnum = exif_data[offset];
837+ tagnum <<= 8;
838+ tagnum += exif_data[offset+1];
839+ } else {
840+ tagnum = exif_data[offset+1];
841+ tagnum <<= 8;
842+ tagnum += exif_data[offset];
843+ }
844+ if (tagnum == 0x0112) break; /* found Orientation Tag */
845+ if (--number_of_tags == 0) return 0;
846+ offset += 12;
847+ }
848+
849+ if (set_flag) {
850+ /* Set the Orientation value */
851+ if (is_motorola) {
852+ exif_data[offset+2] = 0; /* Format = unsigned short (2 octets) */
853+ exif_data[offset+3] = 3;
854+ exif_data[offset+4] = 0; /* Number Of Components = 1 */
855+ exif_data[offset+5] = 0;
856+ exif_data[offset+6] = 0;
857+ exif_data[offset+7] = 1;
858+ exif_data[offset+8] = 0;
859+ exif_data[offset+9] = (unsigned char)set_flag;
860+ exif_data[offset+10] = 0;
861+ exif_data[offset+11] = 0;
862+ } else {
863+ exif_data[offset+2] = 3; /* Format = unsigned short (2 octets) */
864+ exif_data[offset+3] = 0;
865+ exif_data[offset+4] = 1; /* Number Of Components = 1 */
866+ exif_data[offset+5] = 0;
867+ exif_data[offset+6] = 0;
868+ exif_data[offset+7] = 0;
869+ exif_data[offset+8] = (unsigned char)set_flag;
870+ exif_data[offset+9] = 0;
871+ exif_data[offset+10] = 0;
872+ exif_data[offset+11] = 0;
873+ }
874+ fseek(myfile, (4 + 2 + 6 + 2) + offset, SEEK_SET);
875+ fwrite(exif_data + 2 + offset, 1, 10, myfile);
876+ } else {
877+ /* Get the Orientation value */
878+ if (is_motorola) {
879+ if (exif_data[offset+8] != 0) return 0;
880+ set_flag = exif_data[offset+9];
881+ } else {
882+ if (exif_data[offset+9] != 0) return 0;
883+ set_flag = exif_data[offset+8];
884+ }
885+ if (set_flag > 8) return 0;
886+ }
887+
888+ /* Write out Orientation value */
889+ if (n_flag)
890+ printf("%c", '0' + set_flag);
891+ else
892+ printf("%c\n", '0' + set_flag);
893+
894+ /* All done. */
895+ return 0;
896+}
897--- libjpeg7-7.orig/debian/extra/exifautotran.1
898+++ libjpeg7-7/debian/extra/exifautotran.1
899@@ -0,0 +1,13 @@
900+.TH EXIFAUTOTRAN "1" "February 2005" "exifautotran" "User Commands"
901+.SH NAME
902+exifautotran \- Transforms Exif files so that Orientation becomes 1
903+.SH DESCRIPTION
904+exifautotran [list of files]
905+.PP
906+Take a list of files as input and transform them in place so that the
907+Orientation becomes 1.
908+.SH "AUTHOR"
909+ Guido Vollbeding <guido@jpegclub.org>
910+.SH "SEE ALSO"
911+.BR jpegtran(1)
912+.BR jpegexiforient(1)
913--- libjpeg7-7.orig/debian/extra/jpegexiforient.1
914+++ libjpeg7-7/debian/extra/jpegexiforient.1
915@@ -0,0 +1,73 @@
916+.TH JPEGEXIFORIENT "1" "February 2005" "jpegexiforient" "User Commands"
917+.SH NAME
918+jpegexiforient \- reads or writes the Exif Orientation Tag
919+.SH SYNOPSIS
920+.B jpegexiforient
921+[\fIswitches\fR] \fIjpegfile\fR
922+.SH DESCRIPTION
923+.
924+This is a utility program to get and set the Exif Orientation Tag.
925+It can be used together with jpegtran in scripts for automatic
926+orientation correction of digital camera pictures.
927+.PP
928+The Exif orientation value gives the orientation of the camera
929+relative to the scene when the image was captured. The relation
930+of the '0th row' and '0th column' to visual position is shown as
931+below.
932+.IP
933+.nf
934+.ft CR
935+Value | 0th Row | 0th Column
936+------+-------------+-----------
937+ 1 | top | left side
938+ 2 | top | rigth side
939+ 3 | bottom | rigth side
940+ 4 | bottom | left side
941+ 5 | left side | top
942+ 6 | right side | top
943+ 7 | right side | bottom
944+ 8 | left side | bottom
945+.fi
946+.PP
947+For convenience, here is what the letter F would look like if it were
948+tagged correctly and displayed by a program that ignores the orientation
949+tag:
950+.IP
951+.nf
952+.ft CB
953+ 1 2 3 4
954+
955+888888 888888 88 88
956+88 88 88 88
957+8888 8888 8888 8888
958+88 88 88 88
959+88 88 888888 888888
960+
961+ 5 6 7 8
962+
963+8888888888 88 88 8888888888
964+88 88 88 88 88 88 88 88
965+88 8888888888 8888888888 88
966+.fi
967+.PP
968+jpegexiforient output the Exif Orientation Tag in a JPEG Exif file.
969+With the options -1 .. -8, it can also be used to set the tag.
970+.
971+.SS "OPTIONS"
972+.TP
973+\fB\-\-help\fR
974+display this help and exit
975+.TP
976+\fB\-\-version\fR
977+output version information and exit
978+.TP
979+\fB\-n\fR
980+Do not output the trailing newline
981+.TP
982+\fB\-1\fR .. \fB\-8\fR
983+Set orientation value 1 .. 8
984+.SH "AUTHOR"
985+ Guido Vollbeding <guido@jpegclub.org>
986+.SH "SEE ALSO"
987+.BR jpegtran(1)
988+.BR exifautotran(1)
989--- libjpeg7-7.orig/debian/extra/exifautotran
990+++ libjpeg7-7/debian/extra/exifautotran
991@@ -0,0 +1,50 @@
992+#!/bin/sh
993+# exifautotran [list of files]
994+#
995+# Transforms Exif files so that Orientation becomes 1
996+#
997+
998+trap "if test -n \"\$tempfile\"; then rm -f \"\$tempfile\"; fi" INT QUIT TERM
999+
1000+for i
1001+do
1002+ case $i in
1003+ -v|--version) echo "exifautotran"; exit 0;;
1004+ -h|--help)
1005+ cat <<EOF
1006+exifautotran [list of files]
1007+
1008+Transforms Exif files so that Orientation becomes 1
1009+EOF
1010+ exit 0;;
1011+ esac
1012+
1013+ case `jpegexiforient -n "$i"` in
1014+ 1) transform="";;
1015+ 2) transform="-flip horizontal";;
1016+ 3) transform="-rotate 180";;
1017+ 4) transform="-flip vertical";;
1018+ 5) transform="-transpose";;
1019+ 6) transform="-rotate 90";;
1020+ 7) transform="-transverse";;
1021+ 8) transform="-rotate 270";;
1022+ *) transform="";;
1023+ esac
1024+ if test -n "$transform"; then
1025+ tempfile=`mktemp`;
1026+ if test "$?" -ne "0"; then
1027+ echo "Failed to create temporary file" >&2
1028+ exit 1;
1029+ fi
1030+ echo Executing: jpegtran -copy all $transform $i >&2
1031+ jpegtran -copy all $transform "$i" > $tempfile
1032+ if test $? -ne 0; then
1033+ echo Error while transforming $i - skipped. >&2
1034+ rm "$tempfile"
1035+ else
1036+ cp "$tempfile" "$i"
1037+ rm "$tempfile"
1038+ jpegexiforient -1 "$i" > /dev/null
1039+ fi
1040+ fi
1041+done
1042--- libjpeg7-7.orig/debian/extra/Makefile
1043+++ libjpeg7-7/debian/extra/Makefile
1044@@ -0,0 +1,22 @@
1045+CFLAGS = -O2 -Wall -g
1046+CC = cc
1047+INSTALL = install -m755 -o root -g root
1048+INSTALLDIR = install -m755 -o root -g root -d
1049+DESTDIR =
1050+prefix = /usr/local
1051+bindir = $(prefix)/bin
1052+mandir = $(prefix)/share/man/man1
1053+
1054+all: jpegexiforient
1055+
1056+jpegexiforient: jpegexiforient.c
1057+ $(CC) $(CFLAGS) -o jpegexiforient jpegexiforient.c
1058+clean:
1059+ -rm -f jpegexiforient
1060+install:
1061+ $(INSTALLDIR) $(DESTDIR)$(bindir)
1062+ $(INSTALLDIR) $(DESTDIR)$(mandir)
1063+ $(INSTALL) jpegexiforient $(DESTDIR)$(bindir)
1064+ $(INSTALL) jpegexiforient.1 $(DESTDIR)$(mandir)
1065+ $(INSTALL) exifautotran $(DESTDIR)$(bindir)
1066+ $(INSTALL) exifautotran.1 $(DESTDIR)$(mandir)