summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/images/build-appliance-image_15.0.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-core/images/build-appliance-image_15.0.0.bb')
-rw-r--r--meta/recipes-core/images/build-appliance-image_15.0.0.bb6
1 files changed, 3 insertions, 3 deletions
diff --git a/meta/recipes-core/images/build-appliance-image_15.0.0.bb b/meta/recipes-core/images/build-appliance-image_15.0.0.bb
index 6abab60d7f..f03ef969ad 100644
--- a/meta/recipes-core/images/build-appliance-image_15.0.0.bb
+++ b/meta/recipes-core/images/build-appliance-image_15.0.0.bb
@@ -79,7 +79,7 @@ fakeroot do_populate_poky_src () {
79 echo "# export ALL_PROXY=https://proxy.example.com:8080" >> ${IMAGE_ROOTFS}/home/builder/.bashrc 79 echo "# export ALL_PROXY=https://proxy.example.com:8080" >> ${IMAGE_ROOTFS}/home/builder/.bashrc
80 echo "# export ALL_PROXY=socks://socks.example.com:1080" >> ${IMAGE_ROOTFS}/home/builder/.bashrc 80 echo "# export ALL_PROXY=socks://socks.example.com:1080" >> ${IMAGE_ROOTFS}/home/builder/.bashrc
81 81
82 chown -R builder.builder ${IMAGE_ROOTFS}/home/builder/poky 82 chown -R builder:builder ${IMAGE_ROOTFS}/home/builder/poky
83 chmod -R ug+rw ${IMAGE_ROOTFS}/home/builder/poky 83 chmod -R ug+rw ${IMAGE_ROOTFS}/home/builder/poky
84 84
85 # Assume we will need CDROM to install guest additions 85 # Assume we will need CDROM to install guest additions
@@ -107,8 +107,8 @@ fakeroot do_populate_poky_src () {
107 pip3_install_params="${pip3_install_params} --proxy ${http_proxy}" 107 pip3_install_params="${pip3_install_params} --proxy ${http_proxy}"
108 fi 108 fi
109 pip3 install ${pip3_install_params} 109 pip3 install ${pip3_install_params}
110 chown -R builder.builder ${IMAGE_ROOTFS}/home/builder/.local 110 chown -R builder:builder ${IMAGE_ROOTFS}/home/builder/.local
111 chown -R builder.builder ${IMAGE_ROOTFS}/home/builder/.cache 111 chown -R builder:builder ${IMAGE_ROOTFS}/home/builder/.cache
112} 112}
113 113
114IMAGE_PREPROCESS_COMMAND += "do_populate_poky_src; " 114IMAGE_PREPROCESS_COMMAND += "do_populate_poky_src; "