summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/glibc/glibc_2.33.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-core/glibc/glibc_2.33.bb')
-rw-r--r--meta/recipes-core/glibc/glibc_2.33.bb114
1 files changed, 114 insertions, 0 deletions
diff --git a/meta/recipes-core/glibc/glibc_2.33.bb b/meta/recipes-core/glibc/glibc_2.33.bb
new file mode 100644
index 0000000000..2259d60196
--- /dev/null
+++ b/meta/recipes-core/glibc/glibc_2.33.bb
@@ -0,0 +1,114 @@
1require glibc.inc
2require glibc-version.inc
3
4CVE_CHECK_WHITELIST += "CVE-2020-10029"
5
6DEPENDS += "gperf-native bison-native make-native"
7
8NATIVESDKFIXES ?= ""
9NATIVESDKFIXES_class-nativesdk = "\
10 file://0003-nativesdk-glibc-Look-for-host-system-ld.so.cache-as-.patch \
11 file://0004-nativesdk-glibc-Fix-buffer-overrun-with-a-relocated-.patch \
12 file://0005-nativesdk-glibc-Raise-the-size-of-arrays-containing-.patch \
13 file://0006-nativesdk-glibc-Allow-64-bit-atomics-for-x86.patch \
14 file://0007-nativesdk-glibc-Make-relocatable-install-for-locales.patch \
15"
16
17SRC_URI = "${GLIBC_GIT_URI};branch=${SRCBRANCH};name=glibc \
18 file://etc/ld.so.conf \
19 file://generate-supported.mk \
20 file://makedbs.sh \
21 \
22 ${NATIVESDKFIXES} \
23 file://0008-fsl-e500-e5500-e6500-603e-fsqrt-implementation.patch \
24 file://0009-ppc-sqrt-Fix-undefined-reference-to-__sqrt_finite.patch \
25 file://0010-__ieee754_sqrt-f-are-now-inline-functions-and-call-o.patch \
26 file://0011-Quote-from-bug-1443-which-explains-what-the-patch-do.patch \
27 file://0012-eglibc-run-libm-err-tab.pl-with-specific-dirs-in-S.patch \
28 file://0013-__ieee754_sqrt-f-are-now-inline-functions-and-call-o.patch \
29 file://0014-sysdeps-gnu-configure.ac-handle-correctly-libc_cv_ro.patch \
30 file://0015-yes-within-the-path-sets-wrong-config-variables.patch \
31 file://0016-timezone-re-written-tzselect-as-posix-sh.patch \
32 file://0017-Remove-bash-dependency-for-nscd-init-script.patch \
33 file://0018-eglibc-Cross-building-and-testing-instructions.patch \
34 file://0019-eglibc-Help-bootstrap-cross-toolchain.patch \
35 file://0020-eglibc-Resolve-__fpscr_values-on-SH4.patch \
36 file://0021-eglibc-Forward-port-cross-locale-generation-support.patch \
37 file://0022-Define-DUMMY_LOCALE_T-if-not-defined.patch \
38 file://0023-localedef-add-to-archive-uses-a-hard-coded-locale-pa.patch \
39 file://0024-elf-dl-deps.c-Make-_dl_build_local_scope-breadth-fir.patch \
40 file://0025-intl-Emit-no-lines-in-bison-generated-files.patch \
41 file://0027-locale-prevent-maybe-uninitialized-errors-with-Os-BZ.patch \
42 file://0028-readlib-Add-OECORE_KNOWN_INTERPRETER_NAMES-to-known-.patch \
43 file://0029-wordsize.h-Unify-the-header-between-arm-and-aarch64.patch \
44 file://0030-powerpc-Do-not-ask-compiler-for-finding-arch.patch \
45 "
46S = "${WORKDIR}/git"
47B = "${WORKDIR}/build-${TARGET_SYS}"
48
49PACKAGES_DYNAMIC = ""
50
51# the -isystem in bitbake.conf screws up glibc do_stage
52BUILD_CPPFLAGS = "-I${STAGING_INCDIR_NATIVE}"
53TARGET_CPPFLAGS = "-I${STAGING_DIR_TARGET}${includedir}"
54
55GLIBC_BROKEN_LOCALES = ""
56
57GLIBCPIE ??= ""
58
59EXTRA_OECONF = "--enable-kernel=${OLDEST_KERNEL} \
60 --disable-profile \
61 --disable-debug --without-gd \
62 --enable-clocale=gnu \
63 --with-headers=${STAGING_INCDIR} \
64 --without-selinux \
65 --enable-tunables \
66 --enable-bind-now \
67 --enable-stack-protector=strong \
68 --enable-stackguard-randomization \
69 --disable-crypt \
70 --with-default-link \
71 ${@bb.utils.contains_any('SELECTED_OPTIMIZATION', '-O0 -Og', '--disable-werror', '', d)} \
72 ${GLIBCPIE} \
73 ${GLIBC_EXTRA_OECONF}"
74
75EXTRA_OECONF += "${@get_libc_fpu_setting(bb, d)}"
76
77PACKAGECONFIG ??= "nscd"
78PACKAGECONFIG[nscd] = "--enable-nscd,--disable-nscd"
79
80do_patch_append() {
81 bb.build.exec_func('do_fix_readlib_c', d)
82}
83
84do_fix_readlib_c () {
85 sed -i -e 's#OECORE_KNOWN_INTERPRETER_NAMES#${EGLIBC_KNOWN_INTERPRETER_NAMES}#' ${S}/elf/readlib.c
86}
87
88do_configure () {
89# override this function to avoid the autoconf/automake/aclocal/autoheader
90# calls for now
91# don't pass CPPFLAGS into configure, since it upsets the kernel-headers
92# version check and doesn't really help with anything
93 (cd ${S} && gnu-configize) || die "failure in running gnu-configize"
94 find ${S} -name "configure" | xargs touch
95 CPPFLAGS="" oe_runconf
96}
97
98LDFLAGS += "-fuse-ld=bfd"
99do_compile () {
100 base_do_compile
101 echo "Adjust ldd script"
102 if [ -n "${RTLDLIST}" ]
103 then
104 prevrtld=`cat ${B}/elf/ldd | grep "^RTLDLIST=" | sed 's#^RTLDLIST="\?\([^"]*\)"\?$#\1#'`
105 # remove duplicate entries
106 newrtld=`echo $(printf '%s\n' ${prevrtld} ${RTLDLIST} | LC_ALL=C sort -u)`
107 echo "ldd \"${prevrtld} ${RTLDLIST}\" -> \"${newrtld}\""
108 sed -i ${B}/elf/ldd -e "s#^RTLDLIST=.*\$#RTLDLIST=\"${newrtld}\"#"
109 fi
110}
111
112require glibc-package.inc
113
114BBCLASSEXTEND = "nativesdk"