summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/glibc/glibc_2.29.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-core/glibc/glibc_2.29.bb')
-rw-r--r--meta/recipes-core/glibc/glibc_2.29.bb134
1 files changed, 134 insertions, 0 deletions
diff --git a/meta/recipes-core/glibc/glibc_2.29.bb b/meta/recipes-core/glibc/glibc_2.29.bb
new file mode 100644
index 0000000000..362c172833
--- /dev/null
+++ b/meta/recipes-core/glibc/glibc_2.29.bb
@@ -0,0 +1,134 @@
1require glibc.inc
2
3LIC_FILES_CHKSUM = "file://LICENSES;md5=cfc0ed77a9f62fa62eded042ebe31d72 \
4 file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
5 file://posix/rxspencer/COPYRIGHT;md5=dc5485bb394a13b2332ec1c785f5d83a \
6 file://COPYING.LIB;md5=4fbd65380cdd255951079008b364516c"
7
8DEPENDS += "gperf-native bison-native make-native"
9
10PV = "2.29"
11
12SRCREV ?= "56c86f5dd516284558e106d04b92875d5b623b7a"
13
14SRCBRANCH ?= "release/${PV}/master"
15
16GLIBC_GIT_URI ?= "git://sourceware.org/git/glibc.git"
17UPSTREAM_CHECK_GITTAGREGEX = "(?P<pver>\d+\.\d+(\.(?!90)\d+)*)"
18
19NATIVESDKFIXES ?= ""
20NATIVESDKFIXES_class-nativesdk = "\
21 file://0001-nativesdk-glibc-Look-for-host-system-ld.so.cache-as-.patch \
22 file://0002-nativesdk-glibc-Fix-buffer-overrun-with-a-relocated-.patch \
23 file://0003-nativesdk-glibc-Raise-the-size-of-arrays-containing-.patch \
24 file://0004-nativesdk-glibc-Allow-64-bit-atomics-for-x86.patch \
25 file://0005-nativesdk-glibc-Make-relocatable-install-for-locales.patch \
26"
27
28SRC_URI = "${GLIBC_GIT_URI};branch=${SRCBRANCH};name=glibc \
29 file://etc/ld.so.conf \
30 file://generate-supported.mk \
31 file://makedbs.sh \
32 \
33 ${NATIVESDKFIXES} \
34 file://0006-fsl-e500-e5500-e6500-603e-fsqrt-implementation.patch \
35 file://0007-readlib-Add-OECORE_KNOWN_INTERPRETER_NAMES-to-known-.patch \
36 file://0008-ppc-sqrt-Fix-undefined-reference-to-__sqrt_finite.patch \
37 file://0009-__ieee754_sqrt-f-are-now-inline-functions-and-call-o.patch \
38 file://0010-Quote-from-bug-1443-which-explains-what-the-patch-do.patch \
39 file://0011-eglibc-run-libm-err-tab.pl-with-specific-dirs-in-S.patch \
40 file://0012-__ieee754_sqrt-f-are-now-inline-functions-and-call-o.patch \
41 file://0013-sysdeps-gnu-configure.ac-handle-correctly-libc_cv_ro.patch \
42 file://0014-Add-unused-attribute.patch \
43 file://0015-yes-within-the-path-sets-wrong-config-variables.patch \
44 file://0016-timezone-re-written-tzselect-as-posix-sh.patch \
45 file://0017-Remove-bash-dependency-for-nscd-init-script.patch \
46 file://0018-eglibc-Cross-building-and-testing-instructions.patch \
47 file://0019-eglibc-Help-bootstrap-cross-toolchain.patch \
48 file://0020-eglibc-Clear-cache-lines-on-ppc8xx.patch \
49 file://0021-eglibc-Resolve-__fpscr_values-on-SH4.patch \
50 file://0022-eglibc-Forward-port-cross-locale-generation-support.patch \
51 file://0023-Define-DUMMY_LOCALE_T-if-not-defined.patch \
52 file://0024-localedef-add-to-archive-uses-a-hard-coded-locale-pa.patch \
53 file://0025-elf-dl-deps.c-Make-_dl_build_local_scope-breadth-fir.patch \
54 file://0026-reset-dl_load_write_lock-after-forking.patch \
55 file://0027-Acquire-ld.so-lock-before-switching-to-malloc_atfork.patch \
56 file://0028-intl-Emit-no-lines-in-bison-generated-files.patch \
57 file://0029-inject-file-assembly-directives.patch \
58 file://0030-locale-prevent-maybe-uninitialized-errors-with-Os-BZ.patch \
59"
60
61S = "${WORKDIR}/git"
62B = "${WORKDIR}/build-${TARGET_SYS}"
63
64PACKAGES_DYNAMIC = ""
65
66# the -isystem in bitbake.conf screws up glibc do_stage
67BUILD_CPPFLAGS = "-I${STAGING_INCDIR_NATIVE}"
68TARGET_CPPFLAGS = "-I${STAGING_DIR_TARGET}${includedir}"
69
70GLIBC_BROKEN_LOCALES = ""
71#
72# We will skip parsing glibc when target system C library selection is not glibc
73# this helps in easing out parsing for non-glibc system libraries
74#
75COMPATIBLE_HOST_libc-musl_class-target = "null"
76
77GLIBCPIE ??= ""
78
79EXTRA_OECONF = "--enable-kernel=${OLDEST_KERNEL} \
80 --disable-profile \
81 --disable-debug --without-gd \
82 --enable-clocale=gnu \
83 --with-headers=${STAGING_INCDIR} \
84 --without-selinux \
85 --enable-tunables \
86 --enable-bind-now \
87 --enable-stack-protector=strong \
88 --enable-stackguard-randomization \
89 --disable-crypt \
90 --with-default-link \
91 ${GLIBCPIE} \
92 ${GLIBC_EXTRA_OECONF}"
93
94EXTRA_OECONF += "${@get_libc_fpu_setting(bb, d)}"
95EXTRA_OECONF += "${@bb.utils.contains('DISTRO_FEATURES', 'libc-inet-anl', '--enable-nscd', '--disable-nscd', d)}"
96
97
98do_patch_append() {
99 bb.build.exec_func('do_fix_readlib_c', d)
100}
101
102do_fix_readlib_c () {
103 sed -i -e 's#OECORE_KNOWN_INTERPRETER_NAMES#${EGLIBC_KNOWN_INTERPRETER_NAMES}#' ${S}/elf/readlib.c
104}
105
106do_configure () {
107# override this function to avoid the autoconf/automake/aclocal/autoheader
108# calls for now
109# don't pass CPPFLAGS into configure, since it upsets the kernel-headers
110# version check and doesn't really help with anything
111 (cd ${S} && gnu-configize) || die "failure in running gnu-configize"
112 find ${S} -name "configure" | xargs touch
113 CPPFLAGS="" oe_runconf
114}
115
116do_compile () {
117 # -Wl,-rpath-link <staging>/lib in LDFLAGS can cause breakage if another glibc is in staging
118 unset LDFLAGS
119 base_do_compile
120 echo "Adjust ldd script"
121 if [ -n "${RTLDLIST}" ]
122 then
123 prevrtld=`cat ${B}/elf/ldd | grep "^RTLDLIST=" | sed 's#^RTLDLIST="\?\([^"]*\)"\?$#\1#'`
124 # remove duplicate entries
125 newrtld=`echo $(printf '%s\n' ${prevrtld} ${RTLDLIST} | LC_ALL=C sort -u)`
126 echo "ldd \"${prevrtld} ${RTLDLIST}\" -> \"${newrtld}\""
127 sed -i ${B}/elf/ldd -e "s#^RTLDLIST=.*\$#RTLDLIST=\"${newrtld}\"#"
128 fi
129
130}
131
132require glibc-package.inc
133
134BBCLASSEXTEND = "nativesdk"