summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/glibc/glibc-locale_2.10.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-core/glibc/glibc-locale_2.10.1.bb')
-rw-r--r--meta/recipes-core/glibc/glibc-locale_2.10.1.bb63
1 files changed, 0 insertions, 63 deletions
diff --git a/meta/recipes-core/glibc/glibc-locale_2.10.1.bb b/meta/recipes-core/glibc/glibc-locale_2.10.1.bb
deleted file mode 100644
index 1ddc40e228..0000000000
--- a/meta/recipes-core/glibc/glibc-locale_2.10.1.bb
+++ /dev/null
@@ -1,63 +0,0 @@
1INHIBIT_DEFAULT_DEPS = "1"
2LICENSE = "LGPL"
3
4BPN = "glibc"
5
6do_fetch[noexec] = "1"
7do_unpack[noexec] = "1"
8do_patch[noexec] = "1"
9do_configure[noexec] = "1"
10do_compile[noexec] = "1"
11
12# Binary locales are generated at build time if ENABLE_BINARY_LOCALE_GENERATION
13# is set. The idea is to avoid running localedef on the target (at first boot)
14# to decrease initial boot time and avoid localedef being killed by the OOM
15# killer which used to effectively break i18n on machines with < 128MB RAM.
16
17# default to disabled
18ENABLE_BINARY_LOCALE_GENERATION ?= "0"
19ENABLE_BINARY_LOCALE_GENERATION_pn-glibc-locale-nativesdk = "0"
20
21#enable locale generation on these arches
22# BINARY_LOCALE_ARCHES is a space separated list of regular expressions
23BINARY_LOCALE_ARCHES ?= "arm.* i[3-6]86 x86_64 powerpc mips"
24
25# set "1" to use cross-localedef for locale generation
26# set "0" for qemu emulation of native localedef for locale generation
27LOCALE_GENERATION_WITH_CROSS-LOCALEDEF = "1"
28
29PR = "r1"
30
31PKGSUFFIX = ""
32PKGSUFFIX_virtclass-nativesdk = "-nativesdk"
33
34PROVIDES = "virtual/libc-locale${PKGSUFFIX}"
35
36PACKAGES = "localedef${PKGSUFFIX} ${PN}-dbg"
37
38PACKAGES_DYNAMIC = "locale-base-* \
39 glibc-gconv-*${PKGSUFFIX} glibc-charmap-* glibc-localedata-* glibc-binary-localedata-*"
40
41
42DESCRIPTION_localedef = "glibc: compile locale definition files"
43
44FILES_${PN}-dbg += "${libdir}/gconv/.debug/*"
45FILES_localedef${PKGSUFFIX} = "${bindir}/localedef"
46
47LOCALETREESRC = "${STAGING_INCDIR}/glibc-locale-internal-${MULTIMACH_TARGET_SYS}"
48
49do_install () {
50 mkdir -p ${D}${bindir} ${D}${datadir} ${D}${libdir}
51 cp -fpPR ${LOCALETREESRC}/${bindir}/* ${D}${bindir}
52 cp -fpPR ${LOCALETREESRC}/${libdir}/locale ${D}${libdir}
53 cp -fpPR ${LOCALETREESRC}/${libdir}/gconv ${D}${libdir}
54 cp -fpPR ${LOCALETREESRC}/${datadir}/i18n ${D}${datadir}
55 cp -fpPR ${LOCALETREESRC}/${datadir}/locale ${D}${datadir}
56 cp -fpPR ${LOCALETREESRC}/SUPPORTED ${WORKDIR}
57}
58
59inherit libc-package
60
61do_install[depends] += "virtual/libc${PKGSUFFIX}:do_populate_sysroot"
62
63BBCLASSEXTEND = "nativesdk"