summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/glib-networking/glib-networking_2.62.4.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-core/glib-networking/glib-networking_2.62.4.bb')
-rw-r--r--meta/recipes-core/glib-networking/glib-networking_2.62.4.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/meta/recipes-core/glib-networking/glib-networking_2.62.4.bb b/meta/recipes-core/glib-networking/glib-networking_2.62.4.bb
new file mode 100644
index 0000000000..b74532087c
--- /dev/null
+++ b/meta/recipes-core/glib-networking/glib-networking_2.62.4.bb
@@ -0,0 +1,34 @@
1SUMMARY = "GLib networking extensions"
2DESCRIPTION = "glib-networking contains the implementations of certain GLib networking features that cannot be implemented directly in GLib itself because of their dependencies."
3HOMEPAGE = "https://gitlab.gnome.org/GNOME/glib-networking/"
4BUGTRACKER = "http://bugzilla.gnome.org"
5
6LICENSE = "LGPLv2.1"
7LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c"
8
9SECTION = "libs"
10DEPENDS = "glib-2.0"
11
12SRC_URI[archive.md5sum] = "fad14a4a2cac73f0c2f9d426f1a9e5af"
13SRC_URI[archive.sha256sum] = "c18f289eec480fdce12044c0a06f77521edf9f460d16ad4213de61f2a3b294cf"
14
15PACKAGECONFIG ??= "gnutls"
16
17PACKAGECONFIG[gnutls] = "-Dgnutls=enabled,-Dgnutls=disabled,gnutls"
18PACKAGECONFIG[openssl] = "-Dopenssl=enabled,-Dopenssl=disabled,openssl"
19PACKAGECONFIG[libproxy] = "-Dlibproxy=enabled,-Dlibproxy=disabled,libproxy"
20
21EXTRA_OEMESON = "-Dgnome_proxy=disabled"
22
23GNOMEBASEBUILDCLASS = "meson"
24inherit gnomebase gettext upstream-version-is-even gio-module-cache
25
26FILES_${PN} += "\
27 ${libdir}/gio/modules/libgio*.so \
28 ${datadir}/dbus-1/services/ \
29 ${systemd_user_unitdir} \
30 "
31FILES_${PN}-dev += "${libdir}/gio/modules/libgio*.la"
32FILES_${PN}-staticdev += "${libdir}/gio/modules/libgio*.a"
33
34BBCLASSEXTEND = "native"