summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/glib-networking/glib-networking_2.60.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-core/glib-networking/glib-networking_2.60.1.bb')
-rw-r--r--meta/recipes-core/glib-networking/glib-networking_2.60.1.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/meta/recipes-core/glib-networking/glib-networking_2.60.1.bb b/meta/recipes-core/glib-networking/glib-networking_2.60.1.bb
new file mode 100644
index 0000000000..09af229d69
--- /dev/null
+++ b/meta/recipes-core/glib-networking/glib-networking_2.60.1.bb
@@ -0,0 +1,31 @@
1SUMMARY = "GLib networking extensions"
2DESCRIPTION = "glib-networking contains the implementations of certain GLib networking features that cannot be implemented directly in GLib itself because of their dependencies."
3HOMEPAGE = "https://gitlab.gnome.org/GNOME/glib-networking/"
4BUGTRACKER = "http://bugzilla.gnome.org"
5
6LICENSE = "LGPLv2.1"
7LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c"
8
9SECTION = "libs"
10DEPENDS = "glib-2.0"
11
12SRC_URI[archive.md5sum] = "83321ffc3c336894b8a5bc18db3fe58d"
13SRC_URI[archive.sha256sum] = "d71c6b2faa5ac29100314f08a1be020a2afd0291f025614c0af0d17b14435d92"
14
15PACKAGECONFIG ??= "gnutls"
16
17PACKAGECONFIG[gnutls] = "-Dgnutls=enabled,-Dgnutls=disabled,gnutls"
18PACKAGECONFIG[libproxy] = "-Dlibproxy=enabled,-Dlibproxy=disabled,libproxy"
19
20EXTRA_OEMESON = "-Dgnome_proxy=disabled"
21
22GNOMEBASEBUILDCLASS = "meson"
23inherit gnomebase gettext upstream-version-is-even gio-module-cache
24
25FILES_${PN} += "\
26 ${libdir}/gio/modules/libgio*.so \
27 ${datadir}/dbus-1/services/ \
28 ${systemd_user_unitdir} \
29 "
30FILES_${PN}-dev += "${libdir}/gio/modules/libgio*.la"
31FILES_${PN}-staticdev += "${libdir}/gio/modules/libgio*.a"