summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/glib-networking/glib-networking_2.48.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-core/glib-networking/glib-networking_2.48.2.bb')
-rw-r--r--meta/recipes-core/glib-networking/glib-networking_2.48.2.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta/recipes-core/glib-networking/glib-networking_2.48.2.bb b/meta/recipes-core/glib-networking/glib-networking_2.48.2.bb
new file mode 100644
index 0000000000..50d9983fe9
--- /dev/null
+++ b/meta/recipes-core/glib-networking/glib-networking_2.48.2.bb
@@ -0,0 +1,29 @@
1SUMMARY = "GLib networking extensions"
2DESCRIPTION = "glib-networking contains the implementations of certain GLib networking features that cannot be implemented directly in GLib itself because of their dependencies."
3HOMEPAGE = "http://git.gnome.org/browse/glib-networking/"
4BUGTRACKER = "http://bugzilla.gnome.org"
5
6LICENSE = "LGPLv2"
7LIC_FILES_CHKSUM = "file://COPYING;md5=5f30f0716dfdd0d91eb439ebec522ec2"
8
9SECTION = "libs"
10DEPENDS = "glib-2.0 intltool-native"
11
12SRC_URI[archive.md5sum] = "d7cf81d52c856b0c66f7821021f40e08"
13SRC_URI[archive.sha256sum] = "925c0c49d6b2b8b5695f2e33cd952d1dbb7d18d3f2f796413577719315bb3a84"
14
15PACKAGECONFIG ??= "ca-certificates gnutls"
16
17# No explicit dependency as it works without ca-certificates installed
18PACKAGECONFIG[ca-certificates] = "--with-ca-certificates=${sysconfdir}/ssl/certs/ca-certificates.crt,--without-ca-certificates"
19PACKAGECONFIG[gnutls] = "--with-gnutls,--without-gnutls,gnutls"
20PACKAGECONFIG[libproxy] = "--with-libproxy,--without-libproxy,libproxy"
21PACKAGECONFIG[pkcs11] = "--with-pkcs11,--without-pkcs11,p11-kit"
22
23EXTRA_OECONF = "--without-gnome-proxy"
24
25inherit gnomebase gettext upstream-version-is-even gio-module-cache
26
27FILES_${PN} += "${libdir}/gio/modules/libgio*.so ${datadir}/dbus-1/services/"
28FILES_${PN}-dev += "${libdir}/gio/modules/libgio*.la"
29FILES_${PN}-staticdev += "${libdir}/gio/modules/libgio*.a"