summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/glib-networking/glib-networking_2.46.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-core/glib-networking/glib-networking_2.46.1.bb')
-rw-r--r--meta/recipes-core/glib-networking/glib-networking_2.46.1.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/meta/recipes-core/glib-networking/glib-networking_2.46.1.bb b/meta/recipes-core/glib-networking/glib-networking_2.46.1.bb
new file mode 100644
index 0000000000..b56e75744b
--- /dev/null
+++ b/meta/recipes-core/glib-networking/glib-networking_2.46.1.bb
@@ -0,0 +1,30 @@
1SUMMARY = "GLib networking extensions"
2DESCRIPTION = "glib-networking contains the implementations of certain GLib networking features that cannot be implemented directly in GLib itself because of their dependencies."
3HOMEPAGE = "http://git.gnome.org/browse/glib-networking/"
4BUGTRACKER = "http://bugzilla.gnome.org"
5
6LICENSE = "LGPLv2"
7LIC_FILES_CHKSUM = "file://COPYING;md5=5f30f0716dfdd0d91eb439ebec522ec2"
8
9SECTION = "libs"
10DEPENDS = "glib-2.0 intltool-native"
11
12SRC_URI[archive.md5sum] = "c000e0b579f5d8fd48efebc7ac4d95dc"
13SRC_URI[archive.sha256sum] = "d5034214217f705891b6c9e719cc2c583c870bfcfdc454ebbb5e5e8940ac90b1"
14
15PACKAGECONFIG ??= "ca-certificates gnutls"
16
17# No explicit dependency as it works without ca-certificates installed
18PACKAGECONFIG[ca-certificates] = "--with-ca-certificates=${sysconfdir}/ssl/certs/ca-certificates.crt,--without-ca-certificates"
19PACKAGECONFIG[gnutls] = "--with-gnutls,--without-gnutls,gnutls"
20PACKAGECONFIG[libproxy] = "--with-libproxy,--without-libproxy,libproxy"
21PACKAGECONFIG[pkcs11] = "--with-pkcs11,--without-pkcs11,p11-kit"
22
23EXTRA_OECONF = "--without-gnome-proxy"
24
25inherit gnomebase gettext
26
27FILES_${PN} += "${libdir}/gio/modules/libgio*.so ${datadir}/dbus-1/services/"
28FILES_${PN}-dbg += "${libdir}/gio/modules/.debug/"
29FILES_${PN}-dev += "${libdir}/gio/modules/libgio*.la"
30FILES_${PN}-staticdev += "${libdir}/gio/modules/libgio*.a"