summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/glib-networking/glib-networking_2.38.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-core/glib-networking/glib-networking_2.38.0.bb')
-rw-r--r--meta/recipes-core/glib-networking/glib-networking_2.38.0.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/meta/recipes-core/glib-networking/glib-networking_2.38.0.bb b/meta/recipes-core/glib-networking/glib-networking_2.38.0.bb
new file mode 100644
index 0000000000..b9ba2d6217
--- /dev/null
+++ b/meta/recipes-core/glib-networking/glib-networking_2.38.0.bb
@@ -0,0 +1,32 @@
1SUMMARY = "GLib networking extensions"
2DESCRIPTION = "glib-networking contains the implementations of certain GLib networking features that cannot be implemented directly in GLib itself because of their dependencies."
3HOMEPAGE = "http://git.gnome.org/browse/glib-networking/"
4BUGTRACKER = "http://bugzilla.gnome.org"
5
6LICENSE = "LGPLv2"
7LIC_FILES_CHKSUM = "file://COPYING;md5=5f30f0716dfdd0d91eb439ebec522ec2"
8
9SECTION = "libs"
10DEPENDS = "glib-2.0 intltool-native"
11
12GNOME_COMPRESS_TYPE = "xz"
13
14SRC_URI[archive.md5sum] = "a22907deed3d956860d83aa3233e86ff"
15SRC_URI[archive.sha256sum] = "a43eacbf721b475cf6ba0cd2eab02a332014f71a4c41d0b44bd7bbf8ed1f840d"
16
17PACKAGECONFIG ??= "ca-certificates gnutls"
18
19# No explicit dependency as it works without ca-certificates installed
20PACKAGECONFIG[ca-certificates] = "--with-ca-certificates=${sysconfdir}/ssl/certs/ca-certificates.crt,--without-ca-certificates"
21PACKAGECONFIG[gnutls] = "--with-gnutls,--without-gnutls,gnutls"
22PACKAGECONFIG[libproxy] = "--with-libproxy,--without-libproxy,libproxy"
23PACKAGECONFIG[pkcs11] = "--with-pkcs11,--without-pkcs11,p11-kit"
24
25EXTRA_OECONF = "--without-gnome-proxy"
26
27inherit gnomebase gettext
28
29FILES_${PN} += "${libdir}/gio/modules/libgio*.so ${datadir}/dbus-1/services/"
30FILES_${PN}-dbg += "${libdir}/gio/modules/.debug/"
31FILES_${PN}-dev += "${libdir}/gio/modules/libgio*.la"
32FILES_${PN}-staticdev += "${libdir}/gio/modules/libgio*.a"