summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/glib-2.0/glib-2.0_2.76.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-core/glib-2.0/glib-2.0_2.76.2.bb')
-rw-r--r--meta/recipes-core/glib-2.0/glib-2.0_2.76.2.bb51
1 files changed, 51 insertions, 0 deletions
diff --git a/meta/recipes-core/glib-2.0/glib-2.0_2.76.2.bb b/meta/recipes-core/glib-2.0/glib-2.0_2.76.2.bb
new file mode 100644
index 0000000000..224f2c262e
--- /dev/null
+++ b/meta/recipes-core/glib-2.0/glib-2.0_2.76.2.bb
@@ -0,0 +1,51 @@
1require glib.inc
2
3PE = "1"
4
5SHRT_VER = "${@oe.utils.trim_version("${PV}", 2)}"
6
7SRC_URI = "${GNOME_MIRROR}/glib/${SHRT_VER}/glib-${PV}.tar.xz \
8 file://run-ptest \
9 file://0001-Fix-DATADIRNAME-on-uclibc-Linux.patch \
10 file://0001-Remove-the-warning-about-deprecated-paths-in-schemas.patch \
11 file://0001-Install-gio-querymodules-as-libexec_PROGRAM.patch \
12 file://0010-Do-not-hardcode-python-path-into-various-tools.patch \
13 file://0001-Set-host_machine-correctly-when-building-with-mingw3.patch \
14 file://0001-Do-not-write-bindir-into-pkg-config-files.patch \
15 file://0001-meson-Run-atomics-test-on-clang-as-well.patch \
16 file://0001-gio-tests-resources.c-comment-out-a-build-host-only-.patch \
17 "
18SRC_URI:append:class-native = " file://relocate-modules.patch"
19
20SRC_URI[sha256sum] = "24f3847857b1d8674cdb0389a36edec0f13c666cd3ce727ecd340eb9da8aca9e"
21
22# Find any meson cross files in FILESPATH that are relevant for the current
23# build (using siteinfo) and add them to EXTRA_OEMESON.
24inherit siteinfo
25def find_meson_cross_files(d):
26 if bb.data.inherits_class('native', d):
27 return ""
28
29 thisdir = os.path.normpath(d.getVar("THISDIR"))
30 import collections
31 sitedata = siteinfo_data(d)
32 # filename -> found
33 files = collections.OrderedDict()
34 for path in d.getVar("FILESPATH").split(":"):
35 for element in sitedata:
36 filename = os.path.normpath(os.path.join(path, "meson.cross.d", element))
37 sanitized_path = filename.replace(thisdir, "${THISDIR}")
38 if sanitized_path == filename:
39 if os.path.exists(filename):
40 bb.error("Cannot add '%s' to --cross-file, because it's not relative to THISDIR '%s' and sstate signature would contain this full path" % (filename, thisdir))
41 continue
42 files[filename.replace(thisdir, "${THISDIR}")] = os.path.exists(filename)
43
44 items = ["--cross-file=" + k for k,v in files.items() if v]
45 d.appendVar("EXTRA_OEMESON", " " + " ".join(items))
46 items = ["%s:%s" % (k, "True" if v else "False") for k,v in files.items()]
47 d.appendVarFlag("do_configure", "file-checksums", " " + " ".join(items))
48
49python () {
50 find_meson_cross_files(d)
51}