summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/glib-2.0/glib-2.0_2.36.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-core/glib-2.0/glib-2.0_2.36.1.bb')
-rw-r--r--meta/recipes-core/glib-2.0/glib-2.0_2.36.1.bb63
1 files changed, 63 insertions, 0 deletions
diff --git a/meta/recipes-core/glib-2.0/glib-2.0_2.36.1.bb b/meta/recipes-core/glib-2.0/glib-2.0_2.36.1.bb
new file mode 100644
index 0000000000..74370048a9
--- /dev/null
+++ b/meta/recipes-core/glib-2.0/glib-2.0_2.36.1.bb
@@ -0,0 +1,63 @@
1require glib.inc
2
3PE = "1"
4
5DEPENDS += "libffi python-argparse-native zlib"
6DEPENDS_class-native += "libffi-native python-argparse-native"
7DEPENDS_class-nativesdk += "nativesdk-libffi python-argparse-native nativesdk-zlib ${BPN}-native"
8
9SHRT_VER = "${@d.getVar('PV',1).split('.')[0]}.${@d.getVar('PV',1).split('.')[1]}"
10
11SRC_URI = "${GNOME_MIRROR}/glib/${SHRT_VER}/glib-${PV}.tar.xz \
12 file://configure-libtool.patch \
13 file://glib-2.0_fix_for_x32.patch \
14 file://fix-conflicting-rand.patch \
15 file://Makefile-ptest.patch \
16 file://run-ptest \
17 "
18
19SRC_URI_append_class-native = " file://glib-gettextize-dir.patch"
20
21SRC_URI[md5sum] = "a3bbee44a13facb5a3cab18be5ece14c"
22SRC_URI[sha256sum] = "7de37586794e92c024feebe5d306bf5f245fef4803c3666af1ae8dac6ee10b24"
23
24BBCLASSEXTEND = "native nativesdk"
25
26RDEPENDS_${PN}-ptest += "\
27 tzdata \
28 tzdata-americas \
29 tzdata-asia \
30 tzdata-europe \
31 tzdata-posix \
32 python-pygobject \
33 python-dbus \
34 "
35
36RDEPENDS_${PN}-ptest_append_libc-glibc = "\
37 eglibc-gconv-utf-16 \
38 eglibc-charmap-utf-8 \
39 eglibc-gconv-cp1255 \
40 eglibc-charmap-cp1255 \
41 eglibc-gconv-utf-32 \
42 eglibc-gconv-utf-7 \
43 eglibc-charmap-invariant \
44 eglibc-localedata-translit-cjk-variants \
45 "
46
47do_configure_prepend() {
48 sed -i -e '1s,#!.*,#!${USRBINPATH}/env python,' ${S}/gio/gdbus-2.0/codegen/gdbus-codegen.in
49}
50
51do_install_append() {
52 # remove some unpackaged files
53 rm -f ${D}${datadir}/glib-2.0/codegen/*.pyc
54 rm -f ${D}${datadir}/glib-2.0/codegen/*.pyo
55 # and empty dirs
56 rm -rf ${D}${libdir}/gio
57
58 # Some distros have both /bin/perl and /usr/bin/perl, but we set perl location
59 # for target as /usr/bin/perl, so fix it to /usr/bin/perl.
60 if [ -f ${D}${bindir}/glib-mkenums ]; then
61 sed -i -e '1s,#!.*perl,#! ${USRBINPATH}/env perl,' ${D}${bindir}/glib-mkenums
62 fi
63}