summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/gettext/gettext_0.18.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-core/gettext/gettext_0.18.2.bb')
-rw-r--r--meta/recipes-core/gettext/gettext_0.18.2.bb109
1 files changed, 109 insertions, 0 deletions
diff --git a/meta/recipes-core/gettext/gettext_0.18.2.bb b/meta/recipes-core/gettext/gettext_0.18.2.bb
new file mode 100644
index 0000000000..3e930896a5
--- /dev/null
+++ b/meta/recipes-core/gettext/gettext_0.18.2.bb
@@ -0,0 +1,109 @@
1SUMMARY = "Utilities and libraries for producing multi-lingual messages."
2DESCRIPTION = "Gettext offers to programmers, translators, and even users, a well integrated set of tools and documentation. Specifically, the GNU `gettext' utilities are a set of tools that provides a framework to help other GNU packages produce multi-lingual messages. These tools include a set of conventions about how programs should be written to support message catalogs, a directory and file naming organization for the message catalogs themselves, a runtime library supporting the retrieval of translated messages, and a few stand-alone programs to massage in various ways the sets of translatable strings, or already translated strings."
3HOMEPAGE = "http://www.gnu.org/software/gettext/gettext.html"
4SECTION = "libs"
5LICENSE = "GPLv3+ & LGPL-2.1+"
6LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
7
8PR = "r0"
9DEPENDS = "gettext-native virtual/libiconv ncurses expat"
10DEPENDS_class-native = "gettext-minimal-native"
11PROVIDES = "virtual/libintl virtual/gettext"
12PROVIDES_class-native = "virtual/gettext-native"
13RCONFLICTS_${PN} = "proxy-libintl"
14SRC_URI = "${GNU_MIRROR}/gettext/gettext-${PV}.tar.gz \
15 file://parallel.patch \
16 "
17
18SRC_URI_append_libc-uclibc = " file://wchar-uclibc.patch \
19 file://gnulib-uclibc-sched_param-def.patch \
20 "
21LDFLAGS_prepend_libc-uclibc = " -lrt -lpthread "
22
23SRC_URI[md5sum] = "0c86e5af70c195ab8bd651d17d783928"
24SRC_URI[sha256sum] = "516a6370b3b3f46e2fc5a5e222ff5ecd76f3089bc956a7587a6e4f89de17714c"
25
26inherit autotools
27
28EXTRA_OECONF += "--without-lispdir \
29 --disable-csharp \
30 --disable-libasprintf \
31 --disable-java \
32 --disable-native-java \
33 --disable-openmp \
34 --disable-acl \
35 --with-included-glib \
36 --with-libncurses-prefix=${STAGING_LIBDIR}/.. \
37 --without-emacs \
38 --without-cvs \
39 --without-git \
40 --with-included-libxml \
41 --with-included-libcroco \
42 --with-included-libunistring \
43 "
44
45acpaths = '-I ${S}/gettext-runtime/m4 \
46 -I ${S}/gettext-tools/m4'
47
48
49# these lack the .x behind the .so, but shouldn't be in the -dev package
50# Otherwise you get the following results:
51# 7.4M glibc/images/ep93xx/Angstrom-console-image-glibc-ipk-2008.1-test-20080104-ep93xx.rootfs.tar.gz
52# 25M uclibc/images/ep93xx/Angstrom-console-image-uclibc-ipk-2008.1-test-20080104-ep93xx.rootfs.tar.gz
53# because gettext depends on gettext-dev, which pulls in more -dev packages:
54# 15228 KiB /ep93xx/libstdc++-dev_4.2.2-r2_ep93xx.ipk
55# 1300 KiB /ep93xx/uclibc-dev_0.9.29-r8_ep93xx.ipk
56# 140 KiB /armv4t/gettext-dev_0.14.1-r6_armv4t.ipk
57# 4 KiB /ep93xx/libgcc-s-dev_4.2.2-r2_ep93xx.ipk
58
59PACKAGES =+ "libgettextlib libgettextsrc"
60FILES_libgettextlib = "${libdir}/libgettextlib-*.so*"
61FILES_libgettextsrc = "${libdir}/libgettextsrc-*.so*"
62
63PACKAGES =+ "gettext-runtime gettext-runtime-dev gettext-runtime-doc"
64
65FILES_${PN} += "${libdir}/${BPN}/*"
66
67FILES_gettext-runtime = "${bindir}/gettext \
68 ${bindir}/ngettext \
69 ${bindir}/envsubst \
70 ${bindir}/gettext.sh \
71 ${libdir}/libasprintf.so* \
72 ${libdir}/GNU.Gettext.dll \
73 "
74FILES_gettext-runtime_append_libc-uclibc = " ${libdir}/libintl.so.* \
75 ${libdir}/charset.alias \
76 "
77FILES_gettext-runtime-dev += "${libdir}/libasprintf.a \
78 ${includedir}/autosprintf.h \
79 "
80FILES_gettext-runtime-dev_append_libc-uclibc = " ${libdir}/libintl.so \
81 ${includedir}/libintl.h \
82 "
83FILES_gettext-runtime-doc = "${mandir}/man1/gettext.* \
84 ${mandir}/man1/ngettext.* \
85 ${mandir}/man1/envsubst.* \
86 ${mandir}/man1/.* \
87 ${mandir}/man3/* \
88 ${docdir}/gettext/gettext.* \
89 ${docdir}/gettext/ngettext.* \
90 ${docdir}/gettext/envsubst.* \
91 ${docdir}/gettext/*.3.html \
92 ${datadir}/gettext/ABOUT-NLS \
93 ${docdir}/gettext/csharpdoc/* \
94 ${docdir}/libasprintf/autosprintf.html \
95 ${infodir}/autosprintf.info \
96 "
97
98do_install_append() {
99 rm -f ${D}${libdir}/preloadable_libintl.so
100}
101
102do_install_append_class-native () {
103 rm ${D}${datadir}/aclocal/*
104 rm ${D}${datadir}/gettext/config.rpath
105 rm ${D}${datadir}/gettext/po/Makefile.in.in
106 rm ${D}${datadir}/gettext/po/remove-potcdate.sin
107}
108
109BBCLASSEXTEND = "native nativesdk"