summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/gettext/gettext_0.17.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-core/gettext/gettext_0.17.bb')
-rw-r--r--meta/recipes-core/gettext/gettext_0.17.bb55
1 files changed, 55 insertions, 0 deletions
diff --git a/meta/recipes-core/gettext/gettext_0.17.bb b/meta/recipes-core/gettext/gettext_0.17.bb
new file mode 100644
index 0000000000..c945891e26
--- /dev/null
+++ b/meta/recipes-core/gettext/gettext_0.17.bb
@@ -0,0 +1,55 @@
1DESCRIPTION = "The GNU internationalization library."
2HOMEPAGE = "http://www.gnu.org/software/gettext/gettext.html"
3SECTION = "libs"
4LICENSE = "GPLv3"
5PR = "r5"
6DEPENDS = "gettext-native virtual/libiconv ncurses expat"
7DEPENDS_virtclass-native = ""
8PROVIDES = "virtual/libintl"
9PROVIDES_virtclass-native = ""
10
11SRC_URI = "${GNU_MIRROR}/gettext/gettext-${PV}.tar.gz \
12 file://autotools.patch;patch=1 \
13 file://wchar-uclibc.patch;patch=1 \
14 file://use_open_properly.patch;patch=1 \
15 file://m4fix.patch;patch=1 \
16 "
17
18SRC_URI_append_linux-uclibc = " file://gettext-error_print_progname.patch;patch=1"
19SRC_URI_append_linux-uclibcgnueabi = " file://gettext-error_print_progname.patch;patch=1"
20
21PARALLEL_MAKE = ""
22
23inherit autotools
24
25EXTRA_OECONF += "--without-lispdir \
26 --disable-csharp \
27 --disable-libasprintf \
28 --disable-java \
29 --disable-native-java \
30 --disable-openmp \
31 --with-included-glib \
32 --with-libncurses-prefix=${STAGING_LIBDIR}/.. \
33 --without-emacs \
34 "
35
36acpaths = '-I ${S}/autoconf-lib-link/m4/ \
37 -I ${S}/gettext-runtime/m4 \
38 -I ${S}/gettext-tools/m4'
39
40
41# these lack the .x behind the .so, but shouldn't be in the -dev package
42# Otherwise you get the following results:
43# 7.4M glibc/images/ep93xx/Angstrom-console-image-glibc-ipk-2008.1-test-20080104-ep93xx.rootfs.tar.gz
44# 25M uclibc/images/ep93xx/Angstrom-console-image-uclibc-ipk-2008.1-test-20080104-ep93xx.rootfs.tar.gz
45# because gettext depends on gettext-dev, which pulls in more -dev packages:
46# 15228 KiB /ep93xx/libstdc++-dev_4.2.2-r2_ep93xx.ipk
47# 1300 KiB /ep93xx/uclibc-dev_0.9.29-r8_ep93xx.ipk
48# 140 KiB /armv4t/gettext-dev_0.14.1-r6_armv4t.ipk
49# 4 KiB /ep93xx/libgcc-s-dev_4.2.2-r2_ep93xx.ipk
50
51PACKAGES =+ "libgettextlib libgettextsrc"
52FILES_libgettextlib = "${libdir}/libgettextlib-*.so*"
53FILES_libgettextsrc = "${libdir}/libgettextsrc-*.so*"
54
55BBCLASSEXTEND = "native nativesdk"