summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/gettext/gettext_0.16.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-core/gettext/gettext_0.16.1.bb')
-rw-r--r--meta/recipes-core/gettext/gettext_0.16.1.bb55
1 files changed, 55 insertions, 0 deletions
diff --git a/meta/recipes-core/gettext/gettext_0.16.1.bb b/meta/recipes-core/gettext/gettext_0.16.1.bb
new file mode 100644
index 0000000000..754b0ad187
--- /dev/null
+++ b/meta/recipes-core/gettext/gettext_0.16.1.bb
@@ -0,0 +1,55 @@
1DESCRIPTION = "The GNU internationalization library."
2HOMEPAGE = "http://www.gnu.org/software/gettext/gettext.html"
3SECTION = "libs"
4LICENSE = "GPLv2"
5LIC_FILES_CHKSUM = "file://COPYING;md5=9ea3144f04c41cd2eada5d3f472e6ea5"
6
7PR = "r3"
8DEPENDS = "virtual/libiconv"
9DEPENDS_virtclass-native = ""
10PROVIDES = "virtual/libintl"
11PROVIDES_virtclass-native = ""
12
13SRC_URI = "${GNU_MIRROR}/gettext/gettext-${PV}.tar.gz \
14 file://gettext-vpath.patch \
15 file://linklib_from_0.17.patch \
16 file://gettext-autoconf-lib-link-no-L.patch \
17 file://disable_java.patch \
18 file://fix_aclocal_version.patch \
19 file://fix_gnu_source_circular.patch \
20 file://hardcode_macro_version.patch \
21 "
22
23
24SRC_URI_append_linux-uclibc = " file://gettext-error_print_progname.patch"
25SRC_URI_append_linux-uclibceabi = " file://gettext-error_print_progname.patch"
26
27SRC_URI[md5sum] = "3d9ad24301c6d6b17ec30704a13fe127"
28SRC_URI[sha256sum] = "0bf850d1a079fb5a61f0a47b1a9efd35eb44032255375e1cedb0253bc27b376d"
29
30PARALLEL_MAKE = ""
31
32inherit autotools
33
34EXTRA_OECONF += "--without-lisp --disable-csharp --disable-openmp"
35acpaths = '-I ${S}/autoconf-lib-link/m4/ \
36 -I ${S}/gettext-runtime/m4 \
37 -I ${S}/gettext-tools/m4'
38
39do_configure_prepend() {
40 rm -f ${S}/config/m4/libtool.m4
41}
42
43# these lack the .x behind the .so, but shouldn't be in the -dev package
44# Otherwise you get the following results:
45# 7.4M glibc/images/ep93xx/Angstrom-console-image-glibc-ipk-2008.1-test-20080104-ep93xx.rootfs.tar.gz
46# 25M uclibc/images/ep93xx/Angstrom-console-image-uclibc-ipk-2008.1-test-20080104-ep93xx.rootfs.tar.gz
47# because gettext depends on gettext-dev, which pulls in more -dev packages:
48# 15228 KiB /ep93xx/libstdc++-dev_4.2.2-r2_ep93xx.ipk
49# 1300 KiB /ep93xx/uclibc-dev_0.9.29-r8_ep93xx.ipk
50# 140 KiB /armv4t/gettext-dev_0.14.1-r6_armv4t.ipk
51# 4 KiB /ep93xx/libgcc-s-dev_4.2.2-r2_ep93xx.ipk
52
53PACKAGES =+ "libgettextlib libgettextsrc"
54FILES_libgettextlib = "${libdir}/libgettextlib-*.so*"
55FILES_libgettextsrc = "${libdir}/libgettextsrc-*.so*"