summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/gettext/gettext_0.16.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-core/gettext/gettext_0.16.1.bb')
-rw-r--r--meta/recipes-core/gettext/gettext_0.16.1.bb109
1 files changed, 109 insertions, 0 deletions
diff --git a/meta/recipes-core/gettext/gettext_0.16.1.bb b/meta/recipes-core/gettext/gettext_0.16.1.bb
new file mode 100644
index 0000000000..5725e7fe07
--- /dev/null
+++ b/meta/recipes-core/gettext/gettext_0.16.1.bb
@@ -0,0 +1,109 @@
1SUMMARY = "Utilities and libraries for producing multi-lingual messages"
2DESCRIPTION = "GNU gettext is a set of tools that provides a framework to help other programs produce multi-lingual messages. These tools include a set of conventions about how programs should be written to support message catalogs, a directory and file naming organization for the message catalogs themselves, a runtime library supporting the retrieval of translated messages, and a few stand-alone programs to massage in various ways the sets of translatable and already translated strings."
3HOMEPAGE = "http://www.gnu.org/software/gettext/gettext.html"
4SECTION = "libs"
5LICENSE = "GPLv2"
6LIC_FILES_CHKSUM = "file://COPYING;md5=9ea3144f04c41cd2eada5d3f472e6ea5"
7
8PR = "r6"
9DEPENDS = "virtual/libiconv"
10DEPENDS_class-native = ""
11PROVIDES = "virtual/libintl virtual/gettext"
12PROVIDES_class-native = ""
13
14SRC_URI = "${GNU_MIRROR}/gettext/gettext-${PV}.tar.gz \
15 file://gettext-vpath.patch \
16 file://linklib_from_0.17.patch \
17 file://gettext-autoconf-lib-link-no-L.patch \
18 file://disable_java.patch \
19 file://fix_aclocal_version.patch \
20 file://fix_gnu_source_circular.patch \
21 file://hardcode_macro_version.patch \
22 "
23
24
25SRC_URI_append_linux-uclibc = " file://gettext-error_print_progname.patch"
26SRC_URI_append_linux-uclibceabi = " file://gettext-error_print_progname.patch"
27
28SRC_URI[md5sum] = "3d9ad24301c6d6b17ec30704a13fe127"
29SRC_URI[sha256sum] = "0bf850d1a079fb5a61f0a47b1a9efd35eb44032255375e1cedb0253bc27b376d"
30
31PARALLEL_MAKE = ""
32
33inherit autotools
34
35EXTRA_OECONF += "--without-lisp --disable-csharp --disable-openmp --without-emacs"
36acpaths = '-I ${S}/autoconf-lib-link/m4/ \
37 -I ${S}/gettext-runtime/m4 \
38 -I ${S}/gettext-tools/m4'
39
40do_configure_prepend() {
41 rm -f ${S}/config/m4/libtool.m4
42}
43
44# these lack the .x behind the .so, but shouldn't be in the -dev package
45# Otherwise you get the following results:
46# 7.4M glibc/images/ep93xx/Angstrom-console-image-glibc-ipk-2008.1-test-20080104-ep93xx.rootfs.tar.gz
47# 25M uclibc/images/ep93xx/Angstrom-console-image-uclibc-ipk-2008.1-test-20080104-ep93xx.rootfs.tar.gz
48# because gettext depends on gettext-dev, which pulls in more -dev packages:
49# 15228 KiB /ep93xx/libstdc++-dev_4.2.2-r2_ep93xx.ipk
50# 1300 KiB /ep93xx/uclibc-dev_0.9.29-r8_ep93xx.ipk
51# 140 KiB /armv4t/gettext-dev_0.14.1-r6_armv4t.ipk
52# 4 KiB /ep93xx/libgcc-s-dev_4.2.2-r2_ep93xx.ipk
53
54PACKAGES =+ "libgettextlib libgettextsrc"
55FILES_libgettextlib = "${libdir}/libgettextlib-*.so*"
56FILES_libgettextsrc = "${libdir}/libgettextsrc-*.so*"
57
58PACKAGES =+ "gettext-runtime gettext-runtime-dev gettext-runtime-staticdev gettext-runtime-doc"
59
60FILES_${PN} += "${libdir}/${BPN}/*"
61
62FILES_gettext-runtime = "${bindir}/gettext \
63 ${bindir}/ngettext \
64 ${bindir}/envsubst \
65 ${bindir}/gettext.sh \
66 ${libdir}/libasprintf${SODEV} \
67 ${libdir}/GNU.Gettext.dll \
68 "
69FILES_gettext-runtime_append_libc-uclibc = " ${libdir}/libintl.so.* \
70 ${libdir}/charset.alias \
71 "
72FILES_gettext-runtime-staticdev += "${libdir}/libasprintf.a"
73FILES_gettext-runtime-dev += "${includedir}/autosprintf.h \
74 ${libdir}/libasprintf${SOLIBDEV}"
75FILES_gettext-runtime-dev_append_libc-uclibc = " ${libdir}/libintl.so \
76 ${includedir}/libintl.h \
77 "
78FILES_gettext-runtime-doc = "${mandir}/man1/gettext.* \
79 ${mandir}/man1/ngettext.* \
80 ${mandir}/man1/envsubst.* \
81 ${mandir}/man1/.* \
82 ${mandir}/man3/* \
83 ${docdir}/gettext/gettext.* \
84 ${docdir}/gettext/ngettext.* \
85 ${docdir}/gettext/envsubst.* \
86 ${docdir}/gettext/*.3.html \
87 ${datadir}/gettext/ABOUT-NLS \
88 ${docdir}/gettext/csharpdoc/* \
89 ${docdir}/libasprintf/autosprintf.html \
90 ${infodir}/autosprintf.info \
91 "
92
93
94do_install_append() {
95 rm -f ${D}${libdir}/preloadable_libintl.so
96}
97
98# Anyone inheriting gettext will have both gettext-native and gettext
99# available, and we don't want to use older macros from the target gettext in
100# a non-gplv3 build, so kill them and let dependent recipes rely on
101# gettext-native.
102
103SYSROOT_PREPROCESS_FUNCS += "remove_sysroot_m4_macros"
104
105remove_sysroot_m4_macros () {
106 rm -r "${SYSROOT_DESTDIR}${datadir}/aclocal"
107}
108
109BBCLASSEXTEND = "native nativesdk"