summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/gettext/gettext_0.16.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-core/gettext/gettext_0.16.1.bb')
-rw-r--r--meta/recipes-core/gettext/gettext_0.16.1.bb124
1 files changed, 0 insertions, 124 deletions
diff --git a/meta/recipes-core/gettext/gettext_0.16.1.bb b/meta/recipes-core/gettext/gettext_0.16.1.bb
deleted file mode 100644
index e79f4dacf3..0000000000
--- a/meta/recipes-core/gettext/gettext_0.16.1.bb
+++ /dev/null
@@ -1,124 +0,0 @@
1SUMMARY = "Utilities and libraries for producing multi-lingual messages"
2DESCRIPTION = "GNU gettext is a set of tools that provides a framework to help other programs produce multi-lingual messages. These tools include a set of conventions about how programs should be written to support message catalogs, a directory and file naming organization for the message catalogs themselves, a runtime library supporting the retrieval of translated messages, and a few stand-alone programs to massage in various ways the sets of translatable and already translated strings."
3HOMEPAGE = "http://www.gnu.org/software/gettext/gettext.html"
4SECTION = "libs"
5LICENSE = "GPLv2"
6LIC_FILES_CHKSUM = "file://COPYING;md5=9ea3144f04c41cd2eada5d3f472e6ea5"
7
8PR = "r6"
9DEPENDS = "virtual/libiconv"
10DEPENDS_class-native = ""
11PROVIDES = "virtual/libintl virtual/gettext"
12PROVIDES_class-native = "virtual/gettext-native"
13
14SRC_URI = "${GNU_MIRROR}/gettext/gettext-${PV}.tar.gz \
15 file://gettext-vpath.patch \
16 file://linklib_from_0.17.patch \
17 file://gettext-autoconf-lib-link-no-L.patch \
18 file://disable_java.patch \
19 file://fix_aclocal_version.patch \
20 file://fix_gnu_source_circular.patch \
21 file://hardcode_macro_version.patch \
22 "
23
24SRC_URI[md5sum] = "3d9ad24301c6d6b17ec30704a13fe127"
25SRC_URI[sha256sum] = "0bf850d1a079fb5a61f0a47b1a9efd35eb44032255375e1cedb0253bc27b376d"
26
27PARALLEL_MAKE = ""
28
29LDFLAGS_prepend_libc-uclibc = " -lrt -lpthread "
30
31inherit autotools texinfo
32
33EXTRA_OECONF += "--without-lispdir \
34 --disable-csharp \
35 --disable-libasprintf \
36 --disable-java \
37 --disable-native-java \
38 --disable-openmp \
39 --without-emacs \
40 "
41EXTRA_OECONF_append_libc-musl = "\
42 gt_cv_func_gnugettext1_libc=yes \
43 gt_cv_func_gnugettext2_libc=yes \
44 "
45
46acpaths = '-I ${S}/autoconf-lib-link/m4/ \
47 -I ${S}/gettext-runtime/m4 \
48 -I ${S}/gettext-tools/m4'
49
50do_configure_prepend() {
51 rm -f ${S}/config/m4/libtool.m4
52}
53
54do_install_append_libc-musl () {
55 rm -f ${D}${libdir}/charset.alias
56}
57
58# these lack the .x behind the .so, but shouldn't be in the -dev package
59# Otherwise you get the following results:
60# 7.4M glibc/images/ep93xx/Angstrom-console-image-glibc-ipk-2008.1-test-20080104-ep93xx.rootfs.tar.gz
61# 25M uclibc/images/ep93xx/Angstrom-console-image-uclibc-ipk-2008.1-test-20080104-ep93xx.rootfs.tar.gz
62# because gettext depends on gettext-dev, which pulls in more -dev packages:
63# 15228 KiB /ep93xx/libstdc++-dev_4.2.2-r2_ep93xx.ipk
64# 1300 KiB /ep93xx/uclibc-dev_0.9.29-r8_ep93xx.ipk
65# 140 KiB /armv4t/gettext-dev_0.14.1-r6_armv4t.ipk
66# 4 KiB /ep93xx/libgcc-s-dev_4.2.2-r2_ep93xx.ipk
67
68PACKAGES =+ "libgettextlib libgettextsrc"
69FILES_libgettextlib = "${libdir}/libgettextlib-*.so*"
70FILES_libgettextsrc = "${libdir}/libgettextsrc-*.so*"
71
72PACKAGES =+ "gettext-runtime gettext-runtime-dev gettext-runtime-staticdev gettext-runtime-doc"
73
74FILES_${PN} += "${libdir}/${BPN}/*"
75
76FILES_gettext-runtime = "${bindir}/gettext \
77 ${bindir}/ngettext \
78 ${bindir}/envsubst \
79 ${bindir}/gettext.sh \
80 ${libdir}/libasprintf${SODEV} \
81 ${libdir}/GNU.Gettext.dll \
82 "
83FILES_gettext-runtime_append_libc-uclibc = " ${libdir}/libintl.so.* \
84 ${libdir}/charset.alias \
85 "
86FILES_gettext-runtime-staticdev += "${libdir}/libasprintf.a"
87FILES_gettext-runtime-dev += "${includedir}/autosprintf.h \
88 ${libdir}/libasprintf${SOLIBDEV}"
89FILES_gettext-runtime-dev_append_libc-uclibc = " ${libdir}/libintl.so \
90 ${includedir}/libintl.h \
91 "
92FILES_gettext-runtime-doc = "${mandir}/man1/gettext.* \
93 ${mandir}/man1/ngettext.* \
94 ${mandir}/man1/envsubst.* \
95 ${mandir}/man1/.* \
96 ${mandir}/man3/* \
97 ${docdir}/gettext/gettext.* \
98 ${docdir}/gettext/ngettext.* \
99 ${docdir}/gettext/envsubst.* \
100 ${docdir}/gettext/*.3.html \
101 ${datadir}/gettext/ABOUT-NLS \
102 ${docdir}/gettext/csharpdoc/* \
103 ${docdir}/libasprintf/autosprintf.html \
104 ${infodir}/autosprintf.info \
105 "
106
107do_install_append() {
108 rm -f ${D}${libdir}/preloadable_libintl.so
109}
110
111do_install_append_class-native () {
112 rm ${D}${datadir}/aclocal/*
113 rm ${D}${datadir}/gettext/config.rpath
114 rm ${D}${datadir}/gettext/po/Makefile.in.in
115 rm ${D}${datadir}/gettext/po/remove-potcdate.sin
116}
117
118# Anyone inheriting gettext will have both gettext-native and gettext
119# available, and we don't want to use older macros from the target gettext in
120# a non-gplv3 build, so kill them and let dependent recipes rely on
121# gettext-native.
122SYSROOT_DIRS_BLACKLIST += "${datadir}/aclocal"
123
124BBCLASSEXTEND = "native nativesdk"