summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/gettext/gettext-minimal-native_0.19.8.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-core/gettext/gettext-minimal-native_0.19.8.1.bb')
-rw-r--r--meta/recipes-core/gettext/gettext-minimal-native_0.19.8.1.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/meta/recipes-core/gettext/gettext-minimal-native_0.19.8.1.bb b/meta/recipes-core/gettext/gettext-minimal-native_0.19.8.1.bb
new file mode 100644
index 0000000000..26ff19975d
--- /dev/null
+++ b/meta/recipes-core/gettext/gettext-minimal-native_0.19.8.1.bb
@@ -0,0 +1,31 @@
1SUMMARY = "Minimal gettext for supporting native autoconf/automake"
2DESCRIPTION = "Contains the m4 macros sufficient to support building \
3autoconf/automake. This provides a significant build time speedup by \
4the removal of gettext-native from most dependency chains (now only \
5needed for gettext for the target)."
6SRC_URI = "file://aclocal.tgz \
7 file://config.rpath \
8 file://Makefile.in.in \
9 file://remove-potcdate.sin \
10 file://COPYING \
11 file://0001-PATCH-Disable-the-test-to-convert-euc-jp.patch \
12"
13
14INHIBIT_DEFAULT_DEPS = "1"
15INHIBIT_AUTOTOOLS_DEPS = "1"
16
17LICENSE = "FSF-Unlimited"
18LIC_FILES_CHKSUM = "file://COPYING;md5=4bd090a20bfcd1a18f1f79837b5e3e91"
19
20inherit native
21
22S = "${WORKDIR}"
23
24do_install () {
25 install -d ${D}${datadir}/aclocal/
26 cp ${WORKDIR}/*.m4 ${D}${datadir}/aclocal/
27 install -d ${D}${datadir}/gettext/po/
28 cp ${WORKDIR}/config.rpath ${D}${datadir}/gettext/
29 cp ${WORKDIR}/Makefile.in.in ${D}${datadir}/gettext/po/
30 cp ${WORKDIR}/remove-potcdate.sin ${D}${datadir}/gettext/po/
31}