summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/gettext/gettext-minimal-native_0.18.3.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-core/gettext/gettext-minimal-native_0.18.3.2.bb')
-rw-r--r--meta/recipes-core/gettext/gettext-minimal-native_0.18.3.2.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/meta/recipes-core/gettext/gettext-minimal-native_0.18.3.2.bb b/meta/recipes-core/gettext/gettext-minimal-native_0.18.3.2.bb
new file mode 100644
index 0000000000..2b43b97022
--- /dev/null
+++ b/meta/recipes-core/gettext/gettext-minimal-native_0.18.3.2.bb
@@ -0,0 +1,32 @@
1SUMMARY = "Minimal gettext for supporting native autoconf/automake"
2DESCRIPTION = "Contains the m4 macros sufficient to support building \
3autoconf/automake. This provides a significant build time speedup by \
4the removal of gettext-native from most dependency chains (now only \
5needed for gettext for the target)."
6SRC_URI = "file://aclocal.tgz \
7 file://config.rpath \
8 file://Makefile.in.in \
9 file://remove-potcdate.sin \
10 file://COPYING \
11 file://iconv-m4-remove-the-test-to-convert-euc-jp.patch \
12"
13
14INHIBIT_DEFAULT_DEPS = "1"
15INHIBIT_AUTOTOOLS_DEPS = "1"
16
17LICENSE = "FSF-Unlimited"
18LIC_FILES_CHKSUM = "file://COPYING;md5=0854da868a929923087141d9d7aba7d5"
19
20inherit native
21
22
23S = "${WORKDIR}"
24
25do_install () {
26 install -d ${D}${datadir}/aclocal/
27 cp ${WORKDIR}/*.m4 ${D}${datadir}/aclocal/
28 install -d ${D}${datadir}/gettext/po/
29 cp ${WORKDIR}/config.rpath ${D}${datadir}/gettext/
30 cp ${WORKDIR}/Makefile.in.in ${D}${datadir}/gettext/po/
31 cp ${WORKDIR}/remove-potcdate.sin ${D}${datadir}/gettext/po/
32}