summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/fts/fts.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-core/fts/fts.bb')
-rw-r--r--meta/recipes-core/fts/fts.bb36
1 files changed, 8 insertions, 28 deletions
diff --git a/meta/recipes-core/fts/fts.bb b/meta/recipes-core/fts/fts.bb
index de9297ebed..02f54086a3 100644
--- a/meta/recipes-core/fts/fts.bb
+++ b/meta/recipes-core/fts/fts.bb
@@ -3,38 +3,18 @@
3 3
4SUMMARY = "POSIX file tree stream operations library" 4SUMMARY = "POSIX file tree stream operations library"
5HOMEPAGE = "https://sites.google.com/a/bostic.com/keithbostic" 5HOMEPAGE = "https://sites.google.com/a/bostic.com/keithbostic"
6LICENSE = "BSD-4-Clause" 6LICENSE = "BSD-3-Clause"
7LIC_FILES_CHKSUM = "file://fts.h;beginline=1;endline=36;md5=2532eddb3d1a21905723a4011ec4e085" 7LIC_FILES_CHKSUM = "file://COPYING;md5=5ffe358174aad383f1b69ce3b53da982"
8SECTION = "libs" 8SECTION = "libs"
9 9
10SRC_URI = "https://sites.google.com/a/bostic.com/keithbostic/files/fts.tar.gz \ 10SRCREV = "944333aed9dc24cfa76cc64bfe70c75d25652753"
11 file://fts-header-correctness.patch \ 11PV = "1.2+git${SRCPV}"
12 file://fts-uclibc.patch \
13 file://remove_cdefs.patch \
14 file://stdint.patch \
15 file://gcc5.patch \
16"
17
18SRC_URI[md5sum] = "120c14715485ec6ced14f494d059d20a"
19SRC_URI[sha256sum] = "3df9b9b5a45aeaf16f33bb84e692a10dc662e22ec8a51748f98767d67fb6f342"
20
21S = "${WORKDIR}/${BPN}"
22 12
23do_configure[noexec] = "1" 13SRC_URI = "git://github.com/voidlinux/musl-fts \
24 14"
25HASHSTYLE_mipsarch = "sysv" 15S = "${WORKDIR}/git"
26HASHSTYLE = "gnu"
27
28VER = "0"
29do_compile () {
30 ${CC} -I${S} -fPIC -shared -Wl,--hash-style=${HASHSTYLE} -o libfts.so.${VER} -Wl,-soname,libfts.so.${VER} ${S}/fts.c
31}
32 16
33do_install() { 17inherit autotools pkgconfig
34 install -Dm755 ${B}/libfts.so.${VER} ${D}${libdir}/libfts.so.${VER}
35 ln -sf libfts.so.${VER} ${D}${libdir}/libfts.so
36 install -Dm644 ${S}/fts.h ${D}${includedir}/fts.h
37}
38# 18#
39# We will skip parsing for non-musl systems 19# We will skip parsing for non-musl systems
40# 20#