summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/fts/fts.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-core/fts/fts.bb')
-rw-r--r--meta/recipes-core/fts/fts.bb39
1 files changed, 39 insertions, 0 deletions
diff --git a/meta/recipes-core/fts/fts.bb b/meta/recipes-core/fts/fts.bb
new file mode 100644
index 0000000000..d8b4ed2a93
--- /dev/null
+++ b/meta/recipes-core/fts/fts.bb
@@ -0,0 +1,39 @@
1# Copyright (C) 2015 Khem Raj <raj.khem@gmail.com>
2# Released under the MIT license (see COPYING.MIT for the terms)
3
4DESCRIPTION = "keith bostic's POSIX file tree stream operations library"
5HOMEPAGE = "https://sites.google.com/a/bostic.com/keithbostic"
6LICENSE = "BSD-4-Clause"
7LIC_FILES_CHECKSUM = "file://${COREBASE}/meta/files/common-licenses/BSD-4-Clause;md5=624d9e67e8ac41a78f6b6c2c55a83a2b"
8SECTION = "libs"
9
10SRC_URI = "https://sites.google.com/a/bostic.com/keithbostic/files/fts.tar.gz \
11 file://fts-header-correctness.patch \
12 file://fts-uclibc.patch \
13 file://remove_cdefs.patch \
14 file://stdint.patch \
15 file://gcc5.patch \
16"
17
18SRC_URI[md5sum] = "120c14715485ec6ced14f494d059d20a"
19SRC_URI[sha256sum] = "3df9b9b5a45aeaf16f33bb84e692a10dc662e22ec8a51748f98767d67fb6f342"
20
21S = "${WORKDIR}/${BPN}"
22
23do_configure[noexec] = "1"
24
25VER = "0"
26do_compile () {
27 ${CC} -I${S} -fPIC -shared -o libfts.so.${VER} -Wl,-soname,libfts.so.${VER} ${S}/fts.c
28}
29
30do_install() {
31 install -Dm755 ${B}/libfts.so.${VER} ${D}${libdir}/libfts.so.${VER}
32 ln -sf libfts.so.${VER} ${D}${libdir}/libfts.so
33 install -Dm644 ${S}/fts.h ${D}${includedir}/fts.h
34}
35#
36# We will skip parsing for non-musl systems
37#
38COMPATIBLE_HOST = ".*-musl.*"
39