summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/ell/ell_0.35.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-core/ell/ell_0.35.bb')
-rw-r--r--meta/recipes-core/ell/ell_0.35.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta/recipes-core/ell/ell_0.35.bb b/meta/recipes-core/ell/ell_0.35.bb
new file mode 100644
index 0000000000..ccc54b5ff7
--- /dev/null
+++ b/meta/recipes-core/ell/ell_0.35.bb
@@ -0,0 +1,24 @@
1SUMMARY = "Embedded Linux Library"
2DESCRIPTION = "The Embedded Linux Library (ELL) provides core, \
3low-level functionality for system daemons. It typically has no \
4dependencies other than the Linux kernel, C standard library, and \
5libdl (for dynamic linking). While ELL is designed to be efficient \
6and compact enough for use on embedded Linux platforms, it is not \
7limited to resource-constrained systems."
8SECTION = "libs"
9LICENSE = "LGPLv2.1"
10LIC_FILES_CHKSUM = "file://COPYING;md5=fb504b67c50331fc78734fed90fb0e09"
11
12DEPENDS = "dbus"
13
14inherit autotools pkgconfig
15
16SRC_URI = "https://mirrors.edge.kernel.org/pub/linux/libs/${BPN}/${BPN}-${PV}.tar.xz \
17 file://0001-ell-add-missing-include-in-dhcp-server.patch \
18 file://0001-pem.c-do-not-use-rawmemchr.patch \
19 "
20SRC_URI[sha256sum] = "2bfe9da7781f65f1cb1595a5a068a3ae74d4b68b74f287c6f0c892cfe623913f"
21
22do_configure_prepend () {
23 mkdir -p ${S}/build-aux
24}