summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/ell/ell_0.33.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-core/ell/ell_0.33.bb')
-rw-r--r--meta/recipes-core/ell/ell_0.33.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/meta/recipes-core/ell/ell_0.33.bb b/meta/recipes-core/ell/ell_0.33.bb
new file mode 100644
index 0000000000..2fa05104fb
--- /dev/null
+++ b/meta/recipes-core/ell/ell_0.33.bb
@@ -0,0 +1,21 @@
1SUMMARY = "Embedded Linux Library"
2DESCRIPTION = "The Embedded Linux Library (ELL) provides core, \
3low-level functionality for system daemons. It typically has no \
4dependencies other than the Linux kernel, C standard library, and \
5libdl (for dynamic linking). While ELL is designed to be efficient \
6and compact enough for use on embedded Linux platforms, it is not \
7limited to resource-constrained systems."
8SECTION = "libs"
9LICENSE = "LGPLv2.1"
10LIC_FILES_CHKSUM = "file://COPYING;md5=fb504b67c50331fc78734fed90fb0e09"
11
12DEPENDS = "dbus"
13
14inherit autotools pkgconfig
15
16SRC_URI = "https://mirrors.edge.kernel.org/pub/linux/libs/${BPN}/${BPN}-${PV}.tar.xz"
17SRC_URI[sha256sum] = "d9e40e641164150394b74b719b9726fc734f24b2cde679cf5f3be6915c34eded"
18
19do_configure_prepend () {
20 mkdir -p ${S}/build-aux
21}