summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/eglibc/eglibc_2.19.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-core/eglibc/eglibc_2.19.bb')
-rw-r--r--meta/recipes-core/eglibc/eglibc_2.19.bb146
1 files changed, 146 insertions, 0 deletions
diff --git a/meta/recipes-core/eglibc/eglibc_2.19.bb b/meta/recipes-core/eglibc/eglibc_2.19.bb
new file mode 100644
index 0000000000..8f096769ee
--- /dev/null
+++ b/meta/recipes-core/eglibc/eglibc_2.19.bb
@@ -0,0 +1,146 @@
1require eglibc.inc
2
3DEPENDS += "gperf-native kconfig-frontends-native"
4
5SRC_URI = "http://downloads.yoctoproject.org/releases/eglibc/eglibc-${PV}-svnr25243.tar.bz2 \
6 file://eglibc-svn-arm-lowlevellock-include-tls.patch \
7 file://IO-acquire-lock-fix.patch \
8 file://mips-rld-map-check.patch \
9 file://etc/ld.so.conf \
10 file://generate-supported.mk \
11 file://glibc.fix_sqrt2.patch \
12 file://multilib_readlib.patch \
13 file://ppc-sqrt_finite.patch \
14 file://GLRO_dl_debug_mask.patch \
15 file://initgroups_keys.patch \
16 file://eglibc_fix_findidx_parameters.patch \
17 file://ppc_slow_ieee754_sqrt.patch \
18 file://fileops-without-wchar-io.patch \
19 file://add_resource_h_to_wait_h.patch \
20 file://0001-eglibc-menuconfig-support.patch \
21 file://0002-eglibc-menuconfig-hex-string-options.patch \
22 file://0003-eglibc-menuconfig-build-instructions.patch \
23 file://fsl-ppc-no-fsqrt.patch \
24 file://0001-R_ARM_TLS_DTPOFF32.patch \
25 file://0001-eglibc-run-libm-err-tab.pl-with-specific-dirs-in-S.patch \
26 file://fix-tibetian-locales.patch \
27 file://ppce6500-32b_slow_ieee754_sqrt.patch \
28 "
29SRC_URI[md5sum] = "197836c2ba42fb146e971222647198dd"
30SRC_URI[sha256sum] = "baaa030531fc308f7820c46acdf8e1b2f8e3c1f40bcd28b6e440d1c95d170d4c"
31
32LIC_FILES_CHKSUM = "file://LICENSES;md5=e9a558e243b36d3209f380deb394b213 \
33 file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
34 file://posix/rxspencer/COPYRIGHT;md5=dc5485bb394a13b2332ec1c785f5d83a \
35 file://COPYING.LIB;md5=4fbd65380cdd255951079008b364516c"
36
37SRC_URI_append_class-nativesdk = " file://ld-search-order.patch \
38 file://relocatable_sdk.patch \
39 file://relocatable_sdk_fix_openpath.patch \
40 "
41S = "${WORKDIR}/eglibc-${PV}/libc"
42B = "${WORKDIR}/build-${TARGET_SYS}"
43
44PACKAGES_DYNAMIC = ""
45
46# the -isystem in bitbake.conf screws up glibc do_stage
47BUILD_CPPFLAGS = "-I${STAGING_INCDIR_NATIVE}"
48TARGET_CPPFLAGS = "-I${STAGING_DIR_TARGET}${includedir}"
49
50GLIBC_BROKEN_LOCALES = " _ER _ET so_ET yn_ER sid_ET tr_TR mn_MN gez_ET gez_ER bn_BD te_IN es_CR.ISO-8859-1"
51
52FILESPATH = "${@base_set_filespath([ '${FILE_DIRNAME}/eglibc-${PV}', '${FILE_DIRNAME}/eglibc', '${FILE_DIRNAME}/files', '${FILE_DIRNAME}' ], d)}"
53
54#
55# For now, we will skip building of a gcc package if it is a uclibc one
56# and our build is not a uclibc one, and we skip a glibc one if our build
57# is a uclibc build.
58#
59# See the note in gcc/gcc_3.4.0.oe
60#
61
62python __anonymous () {
63 import re
64 uc_os = (re.match('.*uclibc$', d.getVar('TARGET_OS', True)) != None)
65 if uc_os:
66 raise bb.parse.SkipPackage("incompatible with target %s" %
67 d.getVar('TARGET_OS', True))
68}
69
70export libc_cv_slibdir = "${base_libdir}"
71
72EXTRA_OECONF = "--enable-kernel=${OLDEST_KERNEL} \
73 --without-cvs --disable-profile \
74 --disable-debug --without-gd \
75 --enable-clocale=gnu \
76 --enable-add-ons \
77 --with-headers=${STAGING_INCDIR} \
78 --without-selinux \
79 --enable-obsolete-rpc \
80 --with-kconfig=${STAGING_BINDIR_NATIVE} \
81 ${GLIBC_EXTRA_OECONF}"
82
83EXTRA_OECONF += "${@get_libc_fpu_setting(bb, d)}"
84
85do_patch_append() {
86 bb.build.exec_func('do_fix_readlib_c', d)
87}
88
89# for mips eglibc now builds syscall tables for all abi's
90# so we make sure that we choose right march option which is
91# compatible with o32,n32 and n64 abi's
92# e.g. -march=mips32 is not compatible with n32 and n64 therefore
93# we filter it out in such case -march=from-abi which will be
94# mips1 when using o32 and mips3 when using n32/n64
95
96TUNE_CCARGS_mips := "${@oe_filter_out('-march=mips32', '${TUNE_CCARGS}', d)}"
97TUNE_CCARGS_mipsel := "${@oe_filter_out('-march=mips32', '${TUNE_CCARGS}', d)}"
98
99do_fix_readlib_c () {
100 sed -i -e 's#OECORE_KNOWN_INTERPRETER_NAMES#${EGLIBC_KNOWN_INTERPRETER_NAMES}#' ${S}/elf/readlib.c
101}
102
103do_configure () {
104# override this function to avoid the autoconf/automake/aclocal/autoheader
105# calls for now
106# don't pass CPPFLAGS into configure, since it upsets the kernel-headers
107# version check and doesn't really help with anything
108 if [ -z "`which rpcgen`" ]; then
109 echo "rpcgen not found. Install glibc-devel."
110 exit 1
111 fi
112 (cd ${S} && gnu-configize) || die "failure in running gnu-configize"
113 find ${S} -name "configure" | xargs touch
114 CPPFLAGS="" oe_runconf
115}
116
117rpcsvc = "bootparam_prot.x nlm_prot.x rstat.x \
118 yppasswd.x klm_prot.x rex.x sm_inter.x mount.x \
119 rusers.x spray.x nfs_prot.x rquota.x key_prot.x"
120
121do_compile () {
122 # -Wl,-rpath-link <staging>/lib in LDFLAGS can cause breakage if another glibc is in staging
123 unset LDFLAGS
124 base_do_compile
125 (
126 cd ${S}/sunrpc/rpcsvc
127 for r in ${rpcsvc}; do
128 h=`echo $r|sed -e's,\.x$,.h,'`
129 rpcgen -h $r -o $h || bbwarn "unable to generate header for $r"
130 done
131 )
132 echo "Adjust ldd script"
133 if [ -n "${RTLDLIST}" ]
134 then
135 prevrtld=`cat ${B}/elf/ldd | grep "^RTLDLIST=" | sed 's#^RTLDLIST="\?\([^"]*\)"\?$#\1#'`
136 if [ "${prevrtld}" != "${RTLDLIST}" ]
137 then
138 sed -i ${B}/elf/ldd -e "s#^RTLDLIST=.*\$#RTLDLIST=\"${prevrtld} ${RTLDLIST}\"#"
139 fi
140 fi
141
142}
143
144require eglibc-package.inc
145
146BBCLASSEXTEND = "nativesdk"