summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/eglibc/eglibc_2.17.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-core/eglibc/eglibc_2.17.bb')
-rw-r--r--meta/recipes-core/eglibc/eglibc_2.17.bb155
1 files changed, 155 insertions, 0 deletions
diff --git a/meta/recipes-core/eglibc/eglibc_2.17.bb b/meta/recipes-core/eglibc/eglibc_2.17.bb
new file mode 100644
index 0000000000..22129e6bc3
--- /dev/null
+++ b/meta/recipes-core/eglibc/eglibc_2.17.bb
@@ -0,0 +1,155 @@
1require eglibc.inc
2
3PR = "r3"
4
5DEPENDS += "gperf-native kconfig-frontends-native"
6
7SRC_URI = "http://downloads.yoctoproject.org/releases/eglibc/eglibc-${PV}-svnr22064.tar.bz2 \
8 file://eglibc-svn-arm-lowlevellock-include-tls.patch \
9 file://IO-acquire-lock-fix.patch \
10 file://mips-rld-map-check.patch \
11 file://etc/ld.so.conf \
12 file://generate-supported.mk \
13 file://glibc.fix_sqrt2.patch \
14 file://multilib_readlib.patch \
15 file://ppc-sqrt_finite.patch \
16 file://GLRO_dl_debug_mask.patch \
17 file://initgroups_keys.patch \
18 file://eglibc_fix_findidx_parameters.patch \
19 file://ppc_slow_ieee754_sqrt.patch \
20 file://fileops-without-wchar-io.patch \
21 file://add_resource_h_to_wait_h.patch \
22 file://0001-eglibc-menuconfig-support.patch \
23 file://0002-eglibc-menuconfig-hex-string-options.patch \
24 file://0003-eglibc-menuconfig-build-instructions.patch \
25 file://fsl-ppc-no-fsqrt.patch \
26 file://0001-R_ARM_TLS_DTPOFF32.patch \
27 file://tzselect-sh.patch \
28 file://tzselect-awk.patch \
29 file://0001-eglibc-run-libm-err-tab.pl-with-specific-dirs-in-S.patch \
30 file://fix-tibetian-locales.patch \
31 ${BACKPORTS} \
32 "
33BACKPORTS = "\
34 file://eglibc-2.17/eglibc-2.17-r22178.patch \
35 file://eglibc-2.17/eglibc-2.17-PR15003-r22243.patch \
36 "
37
38SRC_URI[md5sum] = "1464af54779c2c7d1078df9ce2e41791"
39SRC_URI[sha256sum] = "97c3991a3772f513cf704841d20c275ac48895fad2e27802dda557c0196cba6b"
40
41LIC_FILES_CHKSUM = "file://LICENSES;md5=e9a558e243b36d3209f380deb394b213 \
42 file://COPYING;md5=393a5ca445f6965873eca0259a17f833 \
43 file://posix/rxspencer/COPYRIGHT;md5=dc5485bb394a13b2332ec1c785f5d83a \
44 file://COPYING.LIB;md5=bbb461211a33b134d42ed5ee802b37ff "
45
46SRC_URI_append_class-nativesdk = " file://ld-search-order.patch \
47 file://relocatable_sdk.patch \
48 file://relocatable_sdk_fix_openpath.patch \
49 "
50S = "${WORKDIR}/eglibc-${PV}/libc"
51B = "${WORKDIR}/build-${TARGET_SYS}"
52
53PACKAGES_DYNAMIC = ""
54
55# the -isystem in bitbake.conf screws up glibc do_stage
56BUILD_CPPFLAGS = "-I${STAGING_INCDIR_NATIVE}"
57TARGET_CPPFLAGS = "-I${STAGING_DIR_TARGET}${includedir}"
58
59GLIBC_BROKEN_LOCALES = " _ER _ET so_ET yn_ER sid_ET tr_TR mn_MN gez_ET gez_ER bn_BD te_IN es_CR.ISO-8859-1"
60
61FILESPATH = "${@base_set_filespath([ '${FILE_DIRNAME}/eglibc-${PV}', '${FILE_DIRNAME}/eglibc', '${FILE_DIRNAME}/files', '${FILE_DIRNAME}' ], d)}"
62
63#
64# For now, we will skip building of a gcc package if it is a uclibc one
65# and our build is not a uclibc one, and we skip a glibc one if our build
66# is a uclibc build.
67#
68# See the note in gcc/gcc_3.4.0.oe
69#
70
71python __anonymous () {
72 import re
73 uc_os = (re.match('.*uclibc$', d.getVar('TARGET_OS', True)) != None)
74 if uc_os:
75 raise bb.parse.SkipPackage("incompatible with target %s" %
76 d.getVar('TARGET_OS', True))
77}
78
79export libc_cv_slibdir = "${base_libdir}"
80
81EXTRA_OECONF = "--enable-kernel=${OLDEST_KERNEL} \
82 --without-cvs --disable-profile \
83 --disable-debug --without-gd \
84 --enable-clocale=gnu \
85 --enable-add-ons \
86 --with-headers=${STAGING_INCDIR} \
87 --without-selinux \
88 --enable-obsolete-rpc \
89 --with-kconfig=${STAGING_BINDIR_NATIVE} \
90 ${GLIBC_EXTRA_OECONF}"
91
92EXTRA_OECONF += "${@get_libc_fpu_setting(bb, d)}"
93
94do_patch_append() {
95 bb.build.exec_func('do_fix_readlib_c', d)
96}
97
98# for mips eglibc now builds syscall tables for all abi's
99# so we make sure that we choose right march option which is
100# compatible with o32,n32 and n64 abi's
101# e.g. -march=mips32 is not compatible with n32 and n64 therefore
102# we filter it out in such case -march=from-abi which will be
103# mips1 when using o32 and mips3 when using n32/n64
104
105TUNE_CCARGS_mips := "${@oe_filter_out('-march=mips32', '${TUNE_CCARGS}', d)}"
106TUNE_CCARGS_mipsel := "${@oe_filter_out('-march=mips32', '${TUNE_CCARGS}', d)}"
107
108do_fix_readlib_c () {
109 sed -i -e 's#OECORE_KNOWN_INTERPRETER_NAMES#${EGLIBC_KNOWN_INTERPRETER_NAMES}#' ${S}/elf/readlib.c
110}
111
112do_configure () {
113# override this function to avoid the autoconf/automake/aclocal/autoheader
114# calls for now
115# don't pass CPPFLAGS into configure, since it upsets the kernel-headers
116# version check and doesn't really help with anything
117 if [ -z "`which rpcgen`" ]; then
118 echo "rpcgen not found. Install glibc-devel."
119 exit 1
120 fi
121 (cd ${S} && gnu-configize) || die "failure in running gnu-configize"
122 find ${S} -name "configure" | xargs touch
123 CPPFLAGS="" oe_runconf
124}
125
126rpcsvc = "bootparam_prot.x nlm_prot.x rstat.x \
127 yppasswd.x klm_prot.x rex.x sm_inter.x mount.x \
128 rusers.x spray.x nfs_prot.x rquota.x key_prot.x"
129
130do_compile () {
131 # -Wl,-rpath-link <staging>/lib in LDFLAGS can cause breakage if another glibc is in staging
132 unset LDFLAGS
133 base_do_compile
134 (
135 cd ${S}/sunrpc/rpcsvc
136 for r in ${rpcsvc}; do
137 h=`echo $r|sed -e's,\.x$,.h,'`
138 rpcgen -h $r -o $h || bbwarn "unable to generate header for $r"
139 done
140 )
141 echo "Adjust ldd script"
142 if [ -n "${RTLDLIST}" ]
143 then
144 prevrtld=`cat ${B}/elf/ldd | grep "^RTLDLIST=" | sed 's#^RTLDLIST="\?\([^"]*\)"\?$#\1#'`
145 if [ "${prevrtld}" != "${RTLDLIST}" ]
146 then
147 sed -i ${B}/elf/ldd -e "s#^RTLDLIST=.*\$#RTLDLIST=\"${prevrtld} ${RTLDLIST}\"#"
148 fi
149 fi
150
151}
152
153require eglibc-package.inc
154
155BBCLASSEXTEND = "nativesdk"