summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/eglibc/eglibc_2.17.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-core/eglibc/eglibc_2.17.bb')
-rw-r--r--meta/recipes-core/eglibc/eglibc_2.17.bb156
1 files changed, 0 insertions, 156 deletions
diff --git a/meta/recipes-core/eglibc/eglibc_2.17.bb b/meta/recipes-core/eglibc/eglibc_2.17.bb
deleted file mode 100644
index c62ff36ee8..0000000000
--- a/meta/recipes-core/eglibc/eglibc_2.17.bb
+++ /dev/null
@@ -1,156 +0,0 @@
1require eglibc.inc
2
3PR = "r3"
4
5DEPENDS += "gperf-native kconfig-frontends-native"
6
7SRC_URI = "http://downloads.yoctoproject.org/releases/eglibc/eglibc-${PV}-svnr22064.tar.bz2 \
8 file://eglibc-svn-arm-lowlevellock-include-tls.patch \
9 file://IO-acquire-lock-fix.patch \
10 file://mips-rld-map-check.patch \
11 file://etc/ld.so.conf \
12 file://generate-supported.mk \
13 file://glibc.fix_sqrt2.patch \
14 file://multilib_readlib.patch \
15 file://ppc-sqrt_finite.patch \
16 file://GLRO_dl_debug_mask.patch \
17 file://initgroups_keys.patch \
18 file://eglibc_fix_findidx_parameters.patch \
19 file://ppc_slow_ieee754_sqrt.patch \
20 file://fileops-without-wchar-io.patch \
21 file://add_resource_h_to_wait_h.patch \
22 file://0001-eglibc-menuconfig-support.patch \
23 file://0002-eglibc-menuconfig-hex-string-options.patch \
24 file://0003-eglibc-menuconfig-build-instructions.patch \
25 file://fsl-ppc-no-fsqrt.patch \
26 file://0001-R_ARM_TLS_DTPOFF32.patch \
27 file://tzselect-sh.patch \
28 file://tzselect-awk.patch \
29 file://0001-eglibc-run-libm-err-tab.pl-with-specific-dirs-in-S.patch \
30 file://fix-tibetian-locales.patch \
31 file://make-4.patch \
32 ${BACKPORTS} \
33 "
34BACKPORTS = "\
35 file://eglibc-2.17/eglibc-2.17-r22178.patch \
36 file://eglibc-2.17/eglibc-2.17-PR15003-r22243.patch \
37 "
38
39SRC_URI[md5sum] = "1464af54779c2c7d1078df9ce2e41791"
40SRC_URI[sha256sum] = "97c3991a3772f513cf704841d20c275ac48895fad2e27802dda557c0196cba6b"
41
42LIC_FILES_CHKSUM = "file://LICENSES;md5=e9a558e243b36d3209f380deb394b213 \
43 file://COPYING;md5=393a5ca445f6965873eca0259a17f833 \
44 file://posix/rxspencer/COPYRIGHT;md5=dc5485bb394a13b2332ec1c785f5d83a \
45 file://COPYING.LIB;md5=bbb461211a33b134d42ed5ee802b37ff "
46
47SRC_URI_append_class-nativesdk = " file://ld-search-order.patch \
48 file://relocatable_sdk.patch \
49 file://relocatable_sdk_fix_openpath.patch \
50 "
51S = "${WORKDIR}/eglibc-${PV}/libc"
52B = "${WORKDIR}/build-${TARGET_SYS}"
53
54PACKAGES_DYNAMIC = ""
55
56# the -isystem in bitbake.conf screws up glibc do_stage
57BUILD_CPPFLAGS = "-I${STAGING_INCDIR_NATIVE}"
58TARGET_CPPFLAGS = "-I${STAGING_DIR_TARGET}${includedir}"
59
60GLIBC_BROKEN_LOCALES = " _ER _ET so_ET yn_ER sid_ET tr_TR mn_MN gez_ET gez_ER bn_BD te_IN es_CR.ISO-8859-1"
61
62FILESPATH = "${@base_set_filespath([ '${FILE_DIRNAME}/eglibc-${PV}', '${FILE_DIRNAME}/eglibc', '${FILE_DIRNAME}/files', '${FILE_DIRNAME}' ], d)}"
63
64#
65# For now, we will skip building of a gcc package if it is a uclibc one
66# and our build is not a uclibc one, and we skip a glibc one if our build
67# is a uclibc build.
68#
69# See the note in gcc/gcc_3.4.0.oe
70#
71
72python __anonymous () {
73 import re
74 uc_os = (re.match('.*uclibc$', d.getVar('TARGET_OS', True)) != None)
75 if uc_os:
76 raise bb.parse.SkipPackage("incompatible with target %s" %
77 d.getVar('TARGET_OS', True))
78}
79
80export libc_cv_slibdir = "${base_libdir}"
81
82EXTRA_OECONF = "--enable-kernel=${OLDEST_KERNEL} \
83 --without-cvs --disable-profile \
84 --disable-debug --without-gd \
85 --enable-clocale=gnu \
86 --enable-add-ons \
87 --with-headers=${STAGING_INCDIR} \
88 --without-selinux \
89 --enable-obsolete-rpc \
90 --with-kconfig=${STAGING_BINDIR_NATIVE} \
91 ${GLIBC_EXTRA_OECONF}"
92
93EXTRA_OECONF += "${@get_libc_fpu_setting(bb, d)}"
94
95do_patch_append() {
96 bb.build.exec_func('do_fix_readlib_c', d)
97}
98
99# for mips eglibc now builds syscall tables for all abi's
100# so we make sure that we choose right march option which is
101# compatible with o32,n32 and n64 abi's
102# e.g. -march=mips32 is not compatible with n32 and n64 therefore
103# we filter it out in such case -march=from-abi which will be
104# mips1 when using o32 and mips3 when using n32/n64
105
106TUNE_CCARGS_mips := "${@oe_filter_out('-march=mips32', '${TUNE_CCARGS}', d)}"
107TUNE_CCARGS_mipsel := "${@oe_filter_out('-march=mips32', '${TUNE_CCARGS}', d)}"
108
109do_fix_readlib_c () {
110 sed -i -e 's#OECORE_KNOWN_INTERPRETER_NAMES#${EGLIBC_KNOWN_INTERPRETER_NAMES}#' ${S}/elf/readlib.c
111}
112
113do_configure () {
114# override this function to avoid the autoconf/automake/aclocal/autoheader
115# calls for now
116# don't pass CPPFLAGS into configure, since it upsets the kernel-headers
117# version check and doesn't really help with anything
118 if [ -z "`which rpcgen`" ]; then
119 echo "rpcgen not found. Install glibc-devel."
120 exit 1
121 fi
122 (cd ${S} && gnu-configize) || die "failure in running gnu-configize"
123 find ${S} -name "configure" | xargs touch
124 CPPFLAGS="" oe_runconf
125}
126
127rpcsvc = "bootparam_prot.x nlm_prot.x rstat.x \
128 yppasswd.x klm_prot.x rex.x sm_inter.x mount.x \
129 rusers.x spray.x nfs_prot.x rquota.x key_prot.x"
130
131do_compile () {
132 # -Wl,-rpath-link <staging>/lib in LDFLAGS can cause breakage if another glibc is in staging
133 unset LDFLAGS
134 base_do_compile
135 (
136 cd ${S}/sunrpc/rpcsvc
137 for r in ${rpcsvc}; do
138 h=`echo $r|sed -e's,\.x$,.h,'`
139 rpcgen -h $r -o $h || bbwarn "unable to generate header for $r"
140 done
141 )
142 echo "Adjust ldd script"
143 if [ -n "${RTLDLIST}" ]
144 then
145 prevrtld=`cat ${B}/elf/ldd | grep "^RTLDLIST=" | sed 's#^RTLDLIST="\?\([^"]*\)"\?$#\1#'`
146 if [ "${prevrtld}" != "${RTLDLIST}" ]
147 then
148 sed -i ${B}/elf/ldd -e "s#^RTLDLIST=.*\$#RTLDLIST=\"${prevrtld} ${RTLDLIST}\"#"
149 fi
150 fi
151
152}
153
154require eglibc-package.inc
155
156BBCLASSEXTEND = "nativesdk"