summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/eglibc/eglibc_2.16.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-core/eglibc/eglibc_2.16.bb')
-rw-r--r--meta/recipes-core/eglibc/eglibc_2.16.bb11
1 files changed, 0 insertions, 11 deletions
diff --git a/meta/recipes-core/eglibc/eglibc_2.16.bb b/meta/recipes-core/eglibc/eglibc_2.16.bb
index 71bcc308b3..aa9256cdc1 100644
--- a/meta/recipes-core/eglibc/eglibc_2.16.bb
+++ b/meta/recipes-core/eglibc/eglibc_2.16.bb
@@ -87,17 +87,6 @@ EXTRA_OECONF = "--enable-kernel=${OLDEST_KERNEL} \
87 87
88EXTRA_OECONF += "${@get_libc_fpu_setting(bb, d)}" 88EXTRA_OECONF += "${@get_libc_fpu_setting(bb, d)}"
89 89
90# eglibc can't be built without optimization, if someone tries to compile an
91# entire image as -O0, we override it with -O2 here and give a note about it.
92def get_optimization(d):
93 selected_optimization = d.getVar("SELECTED_OPTIMIZATION", True)
94 if base_contains("SELECTED_OPTIMIZATION", "-O0", "x", "", d) == "x":
95 bb.note("eglibc can't be built with -O0, -O2 will be used instead.")
96 return selected_optimization.replace("-O0", "-O2")
97 return selected_optimization
98
99SELECTED_OPTIMIZATION := "${@get_optimization(d)}"
100
101do_unpack_append() { 90do_unpack_append() {
102 bb.build.exec_func('do_move_ports', d) 91 bb.build.exec_func('do_move_ports', d)
103} 92}