summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/eglibc/eglibc_2.15.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-core/eglibc/eglibc_2.15.bb')
-rw-r--r--meta/recipes-core/eglibc/eglibc_2.15.bb239
1 files changed, 0 insertions, 239 deletions
diff --git a/meta/recipes-core/eglibc/eglibc_2.15.bb b/meta/recipes-core/eglibc/eglibc_2.15.bb
deleted file mode 100644
index 69db5c91ae..0000000000
--- a/meta/recipes-core/eglibc/eglibc_2.15.bb
+++ /dev/null
@@ -1,239 +0,0 @@
1require eglibc.inc
2
3SRCREV = "19294"
4
5DEPENDS += "gperf-native"
6PR = "r13"
7PR_append = "+svnr${SRCPV}"
8
9EGLIBC_BRANCH="eglibc-2_15"
10SRC_URI = "svn://www.eglibc.org/svn/branches/;module=${EGLIBC_BRANCH};protocol=http \
11 file://eglibc-svn-arm-lowlevellock-include-tls.patch \
12 file://IO-acquire-lock-fix.patch \
13 file://mips-rld-map-check.patch \
14 file://stack-protector-test.patch \
15 file://etc/ld.so.conf \
16 file://generate-supported.mk \
17 file://ppc-sqrt.patch \
18 file://multilib_readlib.patch \
19 file://eglibc-rpc-export-again.patch \
20 file://glibc-2.14-libdl-crash.patch \
21 file://use-sysroot-cxx-headers.patch \
22 file://x86_fenv.patch \
23 file://ppc-sqrt_finite.patch \
24 file://GLRO_dl_debug_mask.patch \
25 file://initgroups_keys.patch \
26 file://use-localstatedir-for-vardbdir.patch \
27 file://eglibc_fix_findidx_parameters.patch \
28 file://add_HAVE_ARM_PCS_VFP.patch \
29 file://ldso_arm_hf_support.patch \
30 "
31LIC_FILES_CHKSUM = "file://LICENSES;md5=98a1128c4b58120182cbea3b1752d8b9 \
32 file://COPYING;md5=393a5ca445f6965873eca0259a17f833 \
33 file://posix/rxspencer/COPYRIGHT;md5=dc5485bb394a13b2332ec1c785f5d83a \
34 file://COPYING.LIB;md5=bbb461211a33b134d42ed5ee802b37ff "
35
36SRC_URI_append_virtclass-nativesdk = " file://ld-search-order.patch \
37 file://relocatable_sdk.patch \
38 "
39S = "${WORKDIR}/${EGLIBC_BRANCH}/libc"
40B = "${WORKDIR}/build-${TARGET_SYS}"
41
42PACKAGES_DYNAMIC = "libc6*"
43RPROVIDES_${PN}-dev = "libc6-dev virtual-libc-dev"
44PROVIDES_${PN}-dbg = "glibc-dbg"
45
46# the -isystem in bitbake.conf screws up glibc do_stage
47BUILD_CPPFLAGS = "-I${STAGING_INCDIR_NATIVE}"
48TARGET_CPPFLAGS = "-I${STAGING_DIR_TARGET}${layout_includedir}"
49
50GLIBC_BROKEN_LOCALES = " _ER _ET so_ET yn_ER sid_ET tr_TR mn_MN gez_ET gez_ER bn_BD te_IN es_CR.ISO-8859-1"
51
52FILESPATH = "${@base_set_filespath([ '${FILE_DIRNAME}/eglibc-${PV}', '${FILE_DIRNAME}/eglibc', '${FILE_DIRNAME}/files', '${FILE_DIRNAME}' ], d)}"
53
54#
55# For now, we will skip building of a gcc package if it is a uclibc one
56# and our build is not a uclibc one, and we skip a glibc one if our build
57# is a uclibc build.
58#
59# See the note in gcc/gcc_3.4.0.oe
60#
61
62python __anonymous () {
63 import re
64 uc_os = (re.match('.*uclibc$', d.getVar('TARGET_OS', True)) != None)
65 if uc_os:
66 raise bb.parse.SkipPackage("incompatible with target %s" %
67 d.getVar('TARGET_OS', True))
68}
69
70export libc_cv_slibdir = "${base_libdir}"
71
72EXTRA_OECONF = "--enable-kernel=${OLDEST_KERNEL} \
73 --without-cvs --disable-profile --disable-debug --without-gd \
74 --enable-clocale=gnu \
75 --enable-add-ons \
76 --with-headers=${STAGING_INCDIR} \
77 --without-selinux \
78 ${GLIBC_EXTRA_OECONF}"
79
80EXTRA_OECONF += "${@get_libc_fpu_setting(bb, d)}"
81
82do_unpack_append() {
83 bb.build.exec_func('do_move_ports', d)
84}
85
86do_move_ports() {
87 if test -d ${WORKDIR}/${EGLIBC_BRANCH}/ports ; then
88 rm -rf ${S}/ports
89 mv ${WORKDIR}/${EGLIBC_BRANCH}/ports ${S}/
90 fi
91}
92
93do_patch_append() {
94 bb.build.exec_func('do_fix_ia_headers', d)
95 bb.build.exec_func('do_fix_readlib_c', d)
96}
97
98# for mips eglibc now builds syscall tables for all abi's
99# so we make sure that we choose right march option which is
100# compatible with o32,n32 and n64 abi's
101# e.g. -march=mips32 is not compatible with n32 and n64 therefore
102# we filter it out in such case -march=from-abi which will be
103# mips1 when using o32 and mips3 when using n32/n64
104
105TUNE_CCARGS_mips := "${@oe_filter_out('-march=mips32', '${TUNE_CCARGS}', d)}"
106TUNE_CCARGS_mipsel := "${@oe_filter_out('-march=mips32', '${TUNE_CCARGS}', d)}"
107
108# We need to ensure that all of the i386 and x86_64 headers are identical
109# to support the multilib case. We do this by copying headers from x86_64
110# to i386 directories. Normally when hand building eglibc or a combined
111# system you would build 32-bit, and then overwrite any files with the x86_64
112# versions.
113#
114# Each time eglibc is updated, this will need to be re-evaluated. In order
115# to do this, disable this function. Build eglibc for a 32-bit and a 64-bit
116# IA32 target. Compare the contents of the include files -- comments specific
117# to the x86_64 version compared to the 32-bit one.
118#
119# For eglibc 2.13, each conflict noted below:
120# bits/a.out.h - Add support for __WORDSIZE = 64
121# bits/byteswap.h - Copyright date mismatch, add support for __WORDSIZE = 64
122# bits/endian.h - Comment mismatch
123# bits/environment.h - add support for __WORDSIZE = 64
124# bits/fcntl.h - Comment/Copyright date mismatch, add support for __WORDSIZE = 64
125# bits/fenv.h - Copyright date mismatch, add support for __WORDSIZE = 64
126# bits/huge_vall.h - Comment/Copyright date mismatch, remove support for older gcc
127# bits/link.h - Function name difference, add x86_64 definitions
128# bits/mathdef.h - Copyright date mismatch, add support for __WORDSIZE = 64
129# bits/mathinline.h - Copyright date mismatch, contributed by mismatch, remove support for older gcc/assembly optimization, add support for __WORDSIZE = 64
130# bits/mman.h - Header/Copyright date mismatch, add MAP_32BIT definition
131# bits/msq.h - Copyright date mismatch, add __WORDSIZE = 32 definitions
132# bits/pthread_type.h -- Contributed by added, add support for __WORDSIZE = 64
133# bits/select.h - Copyright date mismatch, add support for __WORDSIZE = 64
134# bits/semaphore.h - Copyright date mismatch, add support for __WORDSIZE = 64
135# bits/sem.h - Copyright date mismatch
136# bits/setjmp.h - Copyrgiht date mismatch, add support for __WORDSIZE = 64
137# bits/shm.h - Copyright date mismatch, add support for __WORDSIZE = 32
138# bits/sigcontext.h - Copyright date mismatch, license wording mismatch, add support for __WORDSIZE = 32
139# bits/stat.h - Copyright date mismatch, add support for __WORDSIZE = 32 and __WORDSIZE = 64
140# bits/string.h - Header/Copyright date mismatch, remove assembly optimizations
141# bits/syscall.h - different order, some different syscalls listed
142# bits/wchar.h - Change the way the definitions are done
143# bits/wordsize.h - Different header, remove license notice, add __x86_64__ support
144# bits/xtitypes.h - Header difference, different typedef format
145# bits/fpu_control.h - header difference, revised comments, updated assembly macros
146# sys/debugreg.h - Copyright date mismatch, new definition and added __WORDSIZE=64 support
147# sys/epoll.h - Copyright date mismatch, slightly different definitions
148# sys/io.h - Copyright date mismatch, slightly different assembly formats
149# sys/perm.h - Copyright date mismatch
150# sys/procfs.h - Copyright date mismatch, support for __WORDSIZE = 32
151# sys/reg.h - Copyright date mismatch, support for __WORDSIZE = 64
152# sys/ucontext.h - Copyright date mismatch, support for __WORDSIZE = 64
153# sys/user.h - Copyright date mismatch, support for __WORDSIZE = 64
154#
155# we rm something to return to the default version
156#
157do_fix_ia_headers() {
158 cp ${S}/sysdeps/unix/sysv/linux/x86_64/bits/a.out.h ${S}/sysdeps/unix/sysv/linux/i386/bits/a.out.h
159 cp ${S}/sysdeps/x86_64/bits/byteswap.h ${S}/sysdeps/i386/bits/byteswap.h
160 cp ${S}/sysdeps/x86_64/bits/endian.h ${S}/sysdeps/i386/bits/endian.h
161 cp ${S}/sysdeps/unix/sysv/linux/x86_64/bits/environments.h ${S}/sysdeps/unix/sysv/linux/i386/bits/environments.h
162 cp ${S}/sysdeps/unix/sysv/linux/x86_64/bits/fcntl.h ${S}/sysdeps/unix/sysv/linux/i386/bits/fcntl.h
163 cp ${S}/sysdeps/x86_64/fpu/bits/fenv.h ${S}/sysdeps/i386/fpu/bits/fenv.h
164 rm -f ${S}/sysdeps/i386/bits/huge_vall.h
165 cp ${S}/sysdeps/x86_64/bits/link.h ${S}/sysdeps/i386/bits/link.h
166 cp ${S}/sysdeps/x86_64/bits/mathdef.h ${S}/sysdeps/i386/bits/mathdef.h
167 cp ${S}/sysdeps/x86_64/fpu/bits/mathinline.h ${S}/sysdeps/i386/fpu/bits/mathinline.h
168 cp ${S}/sysdeps/unix/sysv/linux/x86_64/bits/mman.h ${S}/sysdeps/unix/sysv/linux/i386/bits/mman.h
169 cp ${S}/sysdeps/unix/sysv/linux/x86_64/bits/msq.h ${S}/sysdeps/unix/sysv/linux/i386/bits/msq.h
170 cp ${S}/nptl/sysdeps/unix/sysv/linux/x86_64/bits/pthreadtypes.h ${S}/nptl/sysdeps/unix/sysv/linux/i386/bits/pthreadtypes.h
171 cp ${S}/sysdeps/x86_64/bits/select.h ${S}/sysdeps/i386/bits/select.h
172 cp ${S}/nptl/sysdeps/unix/sysv/linux/x86_64/bits/semaphore.h ${S}/nptl/sysdeps/unix/sysv/linux/i386/bits/semaphore.h
173 rm -f ${S}/sysdeps/unix/sysv/linux/x86_64/bits/sem.h
174 cp ${S}/sysdeps/x86_64/bits/setjmp.h ${S}/sysdeps/i386/bits/setjmp.h
175 cp ${S}/sysdeps/unix/sysv/linux/x86_64/bits/shm.h ${S}/sysdeps/unix/sysv/linux/i386/bits/shm.h
176 cp ${S}/sysdeps/unix/sysv/linux/x86_64/bits/sigcontext.h ${S}/sysdeps/unix/sysv/linux/i386/bits/sigcontext.h
177 cp ${S}/sysdeps/unix/sysv/linux/x86_64/bits/stat.h ${S}/sysdeps/unix/sysv/linux/i386/bits/stat.h
178 rm -f ${S}/sysdeps/i386/i486/bits/string.h ; cp ${S}/sysdeps/x86_64/bits/string.h ${S}/sysdeps/i386/bits/string.h
179 # Skip syscall.h, see do_install
180 rm -f ${S}/sysdeps/unix/sysv/linux/i386/bits/wchar.h
181 cp ${S}/sysdeps/x86_64/bits/wordsize.h ${S}/sysdeps/i386/bits/wordsize.h
182 cp ${S}/sysdeps/x86_64/bits/xtitypes.h ${S}/sysdeps/i386/bits/xtitypes.h
183 # i386 version is correct, x86_64 is incorrect for fpu_control.h
184 cp ${S}/sysdeps/i386/fpu_control.h ${S}/sysdeps/x86_64/fpu_control.h
185 cp ${S}/sysdeps/unix/sysv/linux/x86_64/sys/debugreg.h ${S}/sysdeps/unix/sysv/linux/i386/sys/debugreg.h
186 cp ${S}/sysdeps/unix/sysv/linux/x86_64/sys/epoll.h ${S}/sysdeps/unix/sysv/linux/i386/sys/epoll.h
187 cp ${S}/sysdeps/unix/sysv/linux/x86_64/sys/io.h ${S}/sysdeps/unix/sysv/linux/i386/sys/io.h
188 cp ${S}/sysdeps/unix/sysv/linux/x86_64/sys/perm.h ${S}/sysdeps/unix/sysv/linux/i386/sys/perm.h
189 cp ${S}/sysdeps/unix/sysv/linux/x86_64/sys/procfs.h ${S}/sysdeps/unix/sysv/linux/i386/sys/procfs.h
190 cp ${S}/sysdeps/unix/sysv/linux/x86_64/sys/reg.h ${S}/sysdeps/unix/sysv/linux/i386/sys/reg.h
191 cp ${S}/sysdeps/unix/sysv/linux/x86_64/sys/ucontext.h ${S}/sysdeps/unix/sysv/linux/i386/sys/ucontext.h
192 cp ${S}/sysdeps/unix/sysv/linux/x86_64/sys/user.h ${S}/sysdeps/unix/sysv/linux/i386/sys/user.h
193}
194
195do_fix_readlib_c () {
196 sed -i -e 's#OECORE_KNOWN_INTERPRETER_NAMES#${EGLIBC_KNOWN_INTERPRETER_NAMES}#' ${S}/elf/readlib.c
197}
198
199do_configure () {
200# override this function to avoid the autoconf/automake/aclocal/autoheader
201# calls for now
202# don't pass CPPFLAGS into configure, since it upsets the kernel-headers
203# version check and doesn't really help with anything
204 if [ -z "`which rpcgen`" ]; then
205 echo "rpcgen not found. Install glibc-devel."
206 exit 1
207 fi
208 (cd ${S} && gnu-configize) || die "failure in running gnu-configize"
209 find ${S} -name "configure" | xargs touch
210 CPPFLAGS="" oe_runconf
211}
212
213rpcsvc = "bootparam_prot.x nlm_prot.x rstat.x \
214 yppasswd.x klm_prot.x rex.x sm_inter.x mount.x \
215 rusers.x spray.x nfs_prot.x rquota.x key_prot.x"
216
217do_compile () {
218 # -Wl,-rpath-link <staging>/lib in LDFLAGS can cause breakage if another glibc is in staging
219 unset LDFLAGS
220 base_do_compile
221 (
222 cd ${S}/sunrpc/rpcsvc
223 for r in ${rpcsvc}; do
224 h=`echo $r|sed -e's,\.x$,.h,'`
225 rpcgen -h $r -o $h || bbwarn "unable to generate header for $r"
226 done
227 )
228 echo "Adjust ldd script"
229 if [ -n "${RTLDLIST}" ]
230 then
231 sed -i ${B}/elf/ldd -e 's#^\(RTLDLIST=\)"\(.*\)"$#\1\2#'
232 sed -i ${B}/elf/ldd -e 's#^\(RTLDLIST=\)\(.*\)$#\1"${RTLDLIST} \2"#'
233 fi
234
235}
236
237require eglibc-package.inc
238
239BBCLASSEXTEND = "nativesdk"