summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/eglibc/eglibc_2.14.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-core/eglibc/eglibc_2.14.bb')
-rw-r--r--meta/recipes-core/eglibc/eglibc_2.14.bb219
1 files changed, 219 insertions, 0 deletions
diff --git a/meta/recipes-core/eglibc/eglibc_2.14.bb b/meta/recipes-core/eglibc/eglibc_2.14.bb
new file mode 100644
index 0000000000..b2821db283
--- /dev/null
+++ b/meta/recipes-core/eglibc/eglibc_2.14.bb
@@ -0,0 +1,219 @@
1require eglibc.inc
2
3SRCREV = "15225"
4
5DEPENDS += "gperf-native"
6PR = "r0"
7PR_append = "+svnr${SRCPV}"
8
9EGLIBC_BRANCH="eglibc-2_14"
10SRC_URI = "svn://www.eglibc.org/svn/branches/;module=${EGLIBC_BRANCH};proto=http \
11 file://eglibc-svn-arm-lowlevellock-include-tls.patch \
12 file://IO-acquire-lock-fix.patch \
13 file://shorten-build-commands.patch \
14 file://mips-rld-map-check.patch \
15 file://stack-protector-test.patch \
16 file://armv4-eabi-compile-fix.patch \
17 file://etc/ld.so.conf \
18 file://generate-supported.mk \
19 file://ppc-sqrt.patch \
20 file://multilib_readlib.patch \
21 file://eglibc-rpc-export-again.patch \
22 "
23LIC_FILES_CHKSUM = "file://LICENSES;md5=98a1128c4b58120182cbea3b1752d8b9 \
24 file://COPYING;md5=393a5ca445f6965873eca0259a17f833 \
25 file://posix/rxspencer/COPYRIGHT;md5=dc5485bb394a13b2332ec1c785f5d83a \
26 file://COPYING.LIB;md5=bbb461211a33b134d42ed5ee802b37ff "
27
28SRC_URI_append_virtclass-nativesdk = " file://ld-search-order.patch"
29S = "${WORKDIR}/${EGLIBC_BRANCH}/libc"
30B = "${WORKDIR}/build-${TARGET_SYS}"
31
32PACKAGES_DYNAMIC = "libc6*"
33RPROVIDES_${PN}-dev = "libc6-dev virtual-libc-dev"
34PROVIDES_${PN}-dbg = "glibc-dbg"
35
36# the -isystem in bitbake.conf screws up glibc do_stage
37BUILD_CPPFLAGS = "-I${STAGING_INCDIR_NATIVE}"
38TARGET_CPPFLAGS = "-I${STAGING_DIR_TARGET}${layout_includedir}"
39
40GLIBC_ADDONS ?= "ports,nptl,libidn"
41
42GLIBC_BROKEN_LOCALES = " _ER _ET so_ET yn_ER sid_ET tr_TR mn_MN gez_ET gez_ER bn_BD te_IN es_CR.ISO-8859-1"
43
44FILESPATH = "${@base_set_filespath([ '${FILE_DIRNAME}/eglibc-${PV}', '${FILE_DIRNAME}/eglibc', '${FILE_DIRNAME}/files', '${FILE_DIRNAME}' ], d)}"
45
46#
47# For now, we will skip building of a gcc package if it is a uclibc one
48# and our build is not a uclibc one, and we skip a glibc one if our build
49# is a uclibc build.
50#
51# See the note in gcc/gcc_3.4.0.oe
52#
53
54python __anonymous () {
55 import bb, re
56 uc_os = (re.match('.*uclibc$', bb.data.getVar('TARGET_OS', d, 1)) != None)
57 if uc_os:
58 raise bb.parse.SkipPackage("incompatible with target %s" %
59 bb.data.getVar('TARGET_OS', d, 1))
60}
61
62export libc_cv_slibdir = "${base_libdir}"
63
64EXTRA_OECONF = "--enable-kernel=${OLDEST_KERNEL} \
65 --without-cvs --disable-profile --disable-debug --without-gd \
66 --enable-clocale=gnu \
67 --enable-add-ons=${GLIBC_ADDONS},ports \
68 --with-headers=${STAGING_INCDIR} \
69 --without-selinux \
70 ${GLIBC_EXTRA_OECONF}"
71
72EXTRA_OECONF += "${@get_libc_fpu_setting(bb, d)}"
73
74do_unpack_append() {
75 bb.build.exec_func('do_move_ports', d)
76}
77
78do_move_ports() {
79 if test -d ${WORKDIR}/${EGLIBC_BRANCH}/ports ; then
80 rm -rf ${S}/ports
81 mv ${WORKDIR}/${EGLIBC_BRANCH}/ports ${S}/
82 fi
83}
84
85do_patch_append() {
86 bb.build.exec_func('do_fix_ia_headers', d)
87 bb.build.exec_func('do_fix_readlib_c', d)
88}
89
90# We need to ensure that all of the i386 and x86_64 headers are identical
91# to support the multilib case. We do this by copying headers from x86_64
92# to i386 directories. Normally when hand building eglibc or a combined
93# system you would build 32-bit, and then overwrite any files with the x86_64
94# versions.
95#
96# Each time eglibc is updated, this will need to be re-evaluated. In order
97# to do this, disable this function. Build eglibc for a 32-bit and a 64-bit
98# IA32 target. Compare the contents of the include files -- comments specific
99# to the x86_64 version compared to the 32-bit one.
100#
101# For eglibc 2.13, each conflict noted below:
102# bits/a.out.h - Add support for __WORDSIZE = 64
103# bits/byteswap.h - Copyright date mismatch, add support for __WORDSIZE = 64
104# bits/endian.h - Comment mismatch
105# bits/environment.h - add support for __WORDSIZE = 64
106# bits/fcntl.h - Comment/Copyright date mismatch, add support for __WORDSIZE = 64
107# bits/fenv.h - Copyright date mismatch, add support for __WORDSIZE = 64
108# bits/huge_vall.h - Comment/Copyright date mismatch, remove support for older gcc
109# bits/link.h - Function name difference, add x86_64 definitions
110# bits/mathdef.h - Copyright date mismatch, add support for __WORDSIZE = 64
111# bits/mathinline.h - Copyright date mismatch, contributed by mismatch, remove support for older gcc/assembly optimization, add support for __WORDSIZE = 64
112# bits/mman.h - Header/Copyright date mismatch, add MAP_32BIT definition
113# bits/msq.h - Copyright date mismatch, add __WORDSIZE = 32 definitions
114# bits/pthread_type.h -- Contributed by added, add support for __WORDSIZE = 64
115# bits/select.h - Copyright date mismatch, add support for __WORDSIZE = 64
116# bits/semaphore.h - Copyright date mismatch, add support for __WORDSIZE = 64
117# bits/sem.h - Copyright date mismatch
118# bits/setjmp.h - Copyrgiht date mismatch, add support for __WORDSIZE = 64
119# bits/shm.h - Copyright date mismatch, add support for __WORDSIZE = 32
120# bits/sigcontext.h - Copyright date mismatch, license wording mismatch, add support for __WORDSIZE = 32
121# bits/stat.h - Copyright date mismatch, add support for __WORDSIZE = 32 and __WORDSIZE = 64
122# bits/string.h - Header/Copyright date mismatch, remove assembly optimizations
123# bits/syscall.h - different order, some different syscalls listed
124# bits/wchar.h - Change the way the definitions are done
125# bits/wordsize.h - Different header, remove license notice, add __x86_64__ support
126# bits/xtitypes.h - Header difference, different typedef format
127# bits/fpu_control.h - header difference, revised comments, updated assembly macros
128# sys/debugreg.h - Copyright date mismatch, new definition and added __WORDSIZE=64 support
129# sys/epoll.h - Copyright date mismatch, slightly different definitions
130# sys/io.h - Copyright date mismatch, slightly different assembly formats
131# sys/perm.h - Copyright date mismatch
132# sys/procfs.h - Copyright date mismatch, support for __WORDSIZE = 32
133# sys/reg.h - Copyright date mismatch, support for __WORDSIZE = 64
134# sys/ucontext.h - Copyright date mismatch, support for __WORDSIZE = 64
135# sys/user.h - Copyright date mismatch, support for __WORDSIZE = 64
136#
137# we rm something to return to the default version
138#
139do_fix_ia_headers() {
140 cp ${S}/sysdeps/unix/sysv/linux/x86_64/bits/a.out.h ${S}/sysdeps/unix/sysv/linux/i386/bits/a.out.h
141 cp ${S}/sysdeps/x86_64/bits/byteswap.h ${S}/sysdeps/i386/bits/byteswap.h
142 cp ${S}/sysdeps/x86_64/bits/endian.h ${S}/sysdeps/i386/bits/endian.h
143 cp ${S}/sysdeps/unix/sysv/linux/x86_64/bits/environments.h ${S}/sysdeps/unix/sysv/linux/i386/bits/environments.h
144 cp ${S}/sysdeps/unix/sysv/linux/x86_64/bits/fcntl.h ${S}/sysdeps/unix/sysv/linux/i386/bits/fcntl.h
145 cp ${S}/sysdeps/x86_64/fpu/bits/fenv.h ${S}/sysdeps/i386/fpu/bits/fenv.h
146 rm ${S}/sysdeps/i386/bits/huge_vall.h
147 cp ${S}/sysdeps/x86_64/bits/link.h ${S}/sysdeps/i386/bits/link.h
148 cp ${S}/sysdeps/x86_64/bits/mathdef.h ${S}/sysdeps/i386/bits/mathdef.h
149 cp ${S}/sysdeps/x86_64/fpu/bits/mathinline.h ${S}/sysdeps/i386/fpu/bits/mathinline.h
150 cp ${S}/sysdeps/unix/sysv/linux/x86_64/bits/mman.h ${S}/sysdeps/unix/sysv/linux/i386/bits/mman.h
151 cp ${S}/sysdeps/unix/sysv/linux/x86_64/bits/msq.h ${S}/sysdeps/unix/sysv/linux/i386/bits/msq.h
152 cp ${S}/nptl/sysdeps/unix/sysv/linux/x86_64/bits/pthreadtypes.h ${S}/nptl/sysdeps/unix/sysv/linux/i386/bits/pthreadtypes.h
153 cp ${S}/sysdeps/x86_64/bits/select.h ${S}/sysdeps/i386/bits/select.h
154 cp ${S}/nptl/sysdeps/unix/sysv/linux/x86_64/bits/semaphore.h ${S}/nptl/sysdeps/unix/sysv/linux/i386/bits/semaphore.h
155 rm ${S}/sysdeps/unix/sysv/linux/x86_64/bits/sem.h
156 cp ${S}/sysdeps/x86_64/bits/setjmp.h ${S}/sysdeps/i386/bits/setjmp.h
157 cp ${S}/sysdeps/unix/sysv/linux/x86_64/bits/shm.h ${S}/sysdeps/unix/sysv/linux/i386/bits/shm.h
158 cp ${S}/sysdeps/unix/sysv/linux/x86_64/bits/sigcontext.h ${S}/sysdeps/unix/sysv/linux/i386/bits/sigcontext.h
159 cp ${S}/sysdeps/unix/sysv/linux/x86_64/bits/stat.h ${S}/sysdeps/unix/sysv/linux/i386/bits/stat.h
160 rm ${S}/sysdeps/i386/i486/bits/string.h ; cp ${S}/sysdeps/x86_64/bits/string.h ${S}/sysdeps/i386/bits/string.h
161 # Skip syscall.h, see do_install
162 rm ${S}/sysdeps/unix/sysv/linux/i386/bits/wchar.h
163 cp ${S}/sysdeps/x86_64/bits/wordsize.h ${S}/sysdeps/i386/bits/wordsize.h
164 cp ${S}/sysdeps/x86_64/bits/xtitypes.h ${S}/sysdeps/i386/bits/xtitypes.h
165 # i386 version is correct, x86_64 is incorrect for fpu_control.h
166 cp ${S}/sysdeps/i386/fpu_control.h ${S}/sysdeps/x86_64/fpu_control.h
167 cp ${S}/sysdeps/unix/sysv/linux/x86_64/sys/debugreg.h ${S}/sysdeps/unix/sysv/linux/i386/sys/debugreg.h
168 cp ${S}/sysdeps/unix/sysv/linux/x86_64/sys/epoll.h ${S}/sysdeps/unix/sysv/linux/i386/sys/epoll.h
169 cp ${S}/sysdeps/unix/sysv/linux/x86_64/sys/io.h ${S}/sysdeps/unix/sysv/linux/i386/sys/io.h
170 cp ${S}/sysdeps/unix/sysv/linux/x86_64/sys/perm.h ${S}/sysdeps/unix/sysv/linux/i386/sys/perm.h
171 cp ${S}/sysdeps/unix/sysv/linux/x86_64/sys/procfs.h ${S}/sysdeps/unix/sysv/linux/i386/sys/procfs.h
172 cp ${S}/sysdeps/unix/sysv/linux/x86_64/sys/reg.h ${S}/sysdeps/unix/sysv/linux/i386/sys/reg.h
173 cp ${S}/sysdeps/unix/sysv/linux/x86_64/sys/ucontext.h ${S}/sysdeps/unix/sysv/linux/i386/sys/ucontext.h
174 cp ${S}/sysdeps/unix/sysv/linux/x86_64/sys/user.h ${S}/sysdeps/unix/sysv/linux/i386/sys/user.h
175}
176
177do_fix_readlib_c () {
178 sed -i -e 's#OECORE_KNOWN_INTERPRETER_NAMES#${EGLIBC_KNOWN_INTERPRETER_NAMES}#' ${S}/elf/readlib.c
179}
180
181do_configure () {
182# override this function to avoid the autoconf/automake/aclocal/autoheader
183# calls for now
184# don't pass CPPFLAGS into configure, since it upsets the kernel-headers
185# version check and doesn't really help with anything
186 if [ -z "`which rpcgen`" ]; then
187 echo "rpcgen not found. Install glibc-devel."
188 exit 1
189 fi
190 (cd ${S} && gnu-configize) || die "failure in running gnu-configize"
191 find ${S} -name "configure" | xargs touch
192 CPPFLAGS="" oe_runconf
193}
194
195rpcsvc = "bootparam_prot.x nlm_prot.x rstat.x \
196 yppasswd.x klm_prot.x rex.x sm_inter.x mount.x \
197 rusers.x spray.x nfs_prot.x rquota.x key_prot.x"
198
199do_compile () {
200 # -Wl,-rpath-link <staging>/lib in LDFLAGS can cause breakage if another glibc is in staging
201 unset LDFLAGS
202 base_do_compile
203 (
204 cd ${S}/sunrpc/rpcsvc
205 for r in ${rpcsvc}; do
206 h=`echo $r|sed -e's,\.x$,.h,'`
207 rpcgen -h $r -o $h || bbwarn "unable to generate header for $r"
208 done
209 )
210 echo "Adjust ldd script"
211 [ -z "${RTLDLIST}" ] && return
212 sed -i ${B}/elf/ldd -e 's#^\(RTLDLIST=\)"\(.*\)"$#\1\2#'
213 sed -i ${B}/elf/ldd -e 's#^\(RTLDLIST=\)\(.*\)$#\1"${RTLDLIST} \2"#'
214
215}
216
217require eglibc-package.inc
218
219BBCLASSEXTEND = "nativesdk"