summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/eglibc/eglibc_2.14.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-core/eglibc/eglibc_2.14.bb')
-rw-r--r--meta/recipes-core/eglibc/eglibc_2.14.bb114
1 files changed, 114 insertions, 0 deletions
diff --git a/meta/recipes-core/eglibc/eglibc_2.14.bb b/meta/recipes-core/eglibc/eglibc_2.14.bb
new file mode 100644
index 0000000000..8936d9ca91
--- /dev/null
+++ b/meta/recipes-core/eglibc/eglibc_2.14.bb
@@ -0,0 +1,114 @@
1require eglibc.inc
2
3SRCREV = "14285"
4
5DEPENDS += "gperf-native"
6PR = "r0"
7PR_append = "+svnr${SRCPV}"
8
9EGLIBC_BRANCH="eglibc-2_14"
10SRC_URI = "svn://www.eglibc.org/svn/branches/;module=${EGLIBC_BRANCH};proto=http \
11 file://eglibc-svn-arm-lowlevellock-include-tls.patch \
12 file://IO-acquire-lock-fix.patch \
13 file://shorten-build-commands.patch \
14 file://mips-rld-map-check.patch \
15 file://stack-protector-test.patch \
16 file://etc/ld.so.conf \
17 file://generate-supported.mk \
18 "
19LIC_FILES_CHKSUM = "file://LICENSES;md5=98a1128c4b58120182cbea3b1752d8b9 \
20 file://COPYING;md5=393a5ca445f6965873eca0259a17f833 \
21 file://posix/rxspencer/COPYRIGHT;md5=dc5485bb394a13b2332ec1c785f5d83a \
22 file://COPYING.LIB;md5=bbb461211a33b134d42ed5ee802b37ff "
23
24SRC_URI_append_virtclass-nativesdk = " file://ld-search-order.patch"
25S = "${WORKDIR}/${EGLIBC_BRANCH}/libc"
26B = "${WORKDIR}/build-${TARGET_SYS}"
27
28PACKAGES_DYNAMIC = "libc6*"
29RPROVIDES_${PN}-dev = "libc6-dev virtual-libc-dev"
30PROVIDES_${PN}-dbg = "glibc-dbg"
31
32# the -isystem in bitbake.conf screws up glibc do_stage
33BUILD_CPPFLAGS = "-I${STAGING_INCDIR_NATIVE}"
34TARGET_CPPFLAGS = "-I${STAGING_DIR_TARGET}${layout_includedir}"
35
36GLIBC_ADDONS ?= "ports,nptl,libidn"
37
38GLIBC_BROKEN_LOCALES = " _ER _ET so_ET yn_ER sid_ET tr_TR mn_MN gez_ET gez_ER bn_BD te_IN es_CR.ISO-8859-1"
39
40FILESPATH = "${@base_set_filespath([ '${FILE_DIRNAME}/eglibc-${PV}', '${FILE_DIRNAME}/eglibc', '${FILE_DIRNAME}/files', '${FILE_DIRNAME}' ], d)}"
41
42#
43# For now, we will skip building of a gcc package if it is a uclibc one
44# and our build is not a uclibc one, and we skip a glibc one if our build
45# is a uclibc build.
46#
47# See the note in gcc/gcc_3.4.0.oe
48#
49
50python __anonymous () {
51 import bb, re
52 uc_os = (re.match('.*uclibc$', bb.data.getVar('TARGET_OS', d, 1)) != None)
53 if uc_os:
54 raise bb.parse.SkipPackage("incompatible with target %s" %
55 bb.data.getVar('TARGET_OS', d, 1))
56}
57
58export libc_cv_slibdir = "${base_libdir}"
59
60EXTRA_OECONF = "--enable-kernel=${OLDEST_KERNEL} \
61 --without-cvs --disable-profile --disable-debug --without-gd \
62 --enable-clocale=gnu \
63 --enable-add-ons=${GLIBC_ADDONS},ports \
64 --with-headers=${STAGING_INCDIR} \
65 --without-selinux \
66 ${GLIBC_EXTRA_OECONF}"
67
68EXTRA_OECONF += "${@get_libc_fpu_setting(bb, d)}"
69
70do_unpack_append() {
71 bb.build.exec_func('do_move_ports', d)
72}
73
74do_move_ports() {
75 if test -d ${WORKDIR}/${EGLIBC_BRANCH}/ports ; then
76 rm -rf ${S}/ports
77 mv ${WORKDIR}/${EGLIBC_BRANCH}/ports ${S}/
78 fi
79}
80
81do_configure () {
82# override this function to avoid the autoconf/automake/aclocal/autoheader
83# calls for now
84# don't pass CPPFLAGS into configure, since it upsets the kernel-headers
85# version check and doesn't really help with anything
86 if [ -z "`which rpcgen`" ]; then
87 echo "rpcgen not found. Install glibc-devel."
88 exit 1
89 fi
90 (cd ${S} && gnu-configize) || die "failure in running gnu-configize"
91 find ${S} -name "configure" | xargs touch
92 CPPFLAGS="" oe_runconf
93}
94
95rpcsvc = "bootparam_prot.x nlm_prot.x rstat.x \
96 yppasswd.x klm_prot.x rex.x sm_inter.x mount.x \
97 rusers.x spray.x nfs_prot.x rquota.x key_prot.x"
98
99do_compile () {
100 # -Wl,-rpath-link <staging>/lib in LDFLAGS can cause breakage if another glibc is in staging
101 unset LDFLAGS
102 base_do_compile
103 (
104 cd ${S}/sunrpc/rpcsvc
105 for r in ${rpcsvc}; do
106 h=`echo $r|sed -e's,\.x$,.h,'`
107 rpcgen -h $r -o $h || oewarn "unable to generate header for $r"
108 done
109 )
110}
111
112require eglibc-package.inc
113
114BBCLASSEXTEND = "nativesdk"