summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/eglibc/eglibc_2.12.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-core/eglibc/eglibc_2.12.bb')
-rw-r--r--meta/recipes-core/eglibc/eglibc_2.12.bb109
1 files changed, 0 insertions, 109 deletions
diff --git a/meta/recipes-core/eglibc/eglibc_2.12.bb b/meta/recipes-core/eglibc/eglibc_2.12.bb
deleted file mode 100644
index 42202196da..0000000000
--- a/meta/recipes-core/eglibc/eglibc_2.12.bb
+++ /dev/null
@@ -1,109 +0,0 @@
1require eglibc.inc
2
3DEPENDS += "gperf-native"
4PR = "r27"
5
6SRCREV = "14158"
7
8EGLIBC_BRANCH="eglibc-2_12"
9SRC_URI = "svn://www.eglibc.org/svn/branches/;module=${EGLIBC_BRANCH};proto=http \
10 file://eglibc-svn-arm-lowlevellock-include-tls.patch \
11 file://IO-acquire-lock-fix.patch \
12 file://shorten-build-commands.patch \
13 file://mips-rld-map-check.patch \
14 file://armv4-eabi-compile-fix.patch \
15 file://ppc-enable-603e-cpu.patch \
16 file://etc/ld.so.conf \
17 file://generate-supported.mk \
18 "
19SRC_URI_append_virtclass-nativesdk = " file://ld-search-order.patch"
20S = "${WORKDIR}/${EGLIBC_BRANCH}/libc"
21B = "${WORKDIR}/build-${TARGET_SYS}"
22
23PACKAGES_DYNAMIC = "libc6*"
24RPROVIDES_${PN}-dev = "libc6-dev virtual-libc-dev"
25PROVIDES_${PN}-dbg = "glibc-dbg"
26
27# the -isystem in bitbake.conf screws up glibc do_stage
28BUILD_CPPFLAGS = "-I${STAGING_INCDIR_NATIVE}"
29TARGET_CPPFLAGS = "-I${STAGING_DIR_TARGET}${layout_includedir}"
30
31GLIBC_ADDONS ?= "ports,nptl,libidn"
32
33GLIBC_BROKEN_LOCALES = " _ER _ET so_ET yn_ER sid_ET tr_TR mn_MN gez_ET gez_ER bn_BD te_IN es_CR.ISO-8859-1"
34
35FILESPATH = "${@base_set_filespath([ '${FILE_DIRNAME}/eglibc-${PV}', '${FILE_DIRNAME}/eglibc', '${FILE_DIRNAME}/files', '${FILE_DIRNAME}' ], d)}"
36
37#
38# For now, we will skip building of a gcc package if it is a uclibc one
39# and our build is not a uclibc one, and we skip a glibc one if our build
40# is a uclibc build.
41#
42# See the note in gcc/gcc_3.4.0.oe
43#
44
45python __anonymous () {
46 import bb, re
47 uc_os = (re.match('.*uclibc$', bb.data.getVar('TARGET_OS', d, 1)) != None)
48 if uc_os:
49 raise bb.parse.SkipPackage("incompatible with target %s" %
50 bb.data.getVar('TARGET_OS', d, 1))
51}
52
53export libc_cv_slibdir = "${base_libdir}"
54
55EXTRA_OECONF = "--enable-kernel=${OLDEST_KERNEL} \
56 --without-cvs --disable-profile --disable-debug --without-gd \
57 --enable-clocale=gnu \
58 --enable-add-ons=${GLIBC_ADDONS},ports \
59 --with-headers=${STAGING_INCDIR} \
60 --without-selinux \
61 ${GLIBC_EXTRA_OECONF}"
62
63EXTRA_OECONF += "${@get_libc_fpu_setting(bb, d)}"
64
65do_unpack_append() {
66 bb.build.exec_func('do_move_ports', d)
67}
68
69do_move_ports() {
70 if test -d ${WORKDIR}/${EGLIBC_BRANCH}/ports ; then
71 rm -rf ${S}/ports
72 mv ${WORKDIR}/${EGLIBC_BRANCH}/ports ${S}/
73 fi
74}
75
76do_configure () {
77# override this function to avoid the autoconf/automake/aclocal/autoheader
78# calls for now
79# don't pass CPPFLAGS into configure, since it upsets the kernel-headers
80# version check and doesn't really help with anything
81 if [ -z "`which rpcgen`" ]; then
82 echo "rpcgen not found. Install glibc-devel."
83 exit 1
84 fi
85 (cd ${S} && gnu-configize) || die "failure in running gnu-configize"
86 find ${S} -name "configure" | xargs touch
87 CPPFLAGS="" oe_runconf
88}
89
90rpcsvc = "bootparam_prot.x nlm_prot.x rstat.x \
91 yppasswd.x klm_prot.x rex.x sm_inter.x mount.x \
92 rusers.x spray.x nfs_prot.x rquota.x key_prot.x"
93
94do_compile () {
95 # -Wl,-rpath-link <staging>/lib in LDFLAGS can cause breakage if another glibc is in staging
96 unset LDFLAGS
97 base_do_compile
98 (
99 cd ${S}/sunrpc/rpcsvc
100 for r in ${rpcsvc}; do
101 h=`echo $r|sed -e's,\.x$,.h,'`
102 rpcgen -h $r -o $h || bbwarn "unable to generate header for $r"
103 done
104 )
105}
106
107require eglibc-package.inc
108
109BBCLASSEXTEND = "nativesdk"