summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/eglibc/eglibc_2.12.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-core/eglibc/eglibc_2.12.bb')
-rw-r--r--meta/recipes-core/eglibc/eglibc_2.12.bb97
1 files changed, 97 insertions, 0 deletions
diff --git a/meta/recipes-core/eglibc/eglibc_2.12.bb b/meta/recipes-core/eglibc/eglibc_2.12.bb
new file mode 100644
index 0000000000..a214980707
--- /dev/null
+++ b/meta/recipes-core/eglibc/eglibc_2.12.bb
@@ -0,0 +1,97 @@
1require eglibc.inc
2
3DEPENDS += "gperf-native"
4FILESPATHPKG =. "eglibc-svn:"
5PR = "r0"
6SRCREV="10809"
7EGLIBC_BRANCH="eglibc-2_12"
8SRC_URI = "svn://www.eglibc.org/svn/branches/;module=${EGLIBC_BRANCH};proto=http \
9 file://eglibc-svn-arm-lowlevellock-include-tls.patch \
10 file://IO-acquire-lock-fix.patch \
11 file://shorten-build-commands.patch \
12 file://etc/ld.so.conf \
13 file://generate-supported.mk"
14S = "${WORKDIR}/${EGLIBC_BRANCH}/libc"
15B = "${WORKDIR}/build-${TARGET_SYS}"
16
17PACKAGES_DYNAMIC = "libc6*"
18RPROVIDES_${PN}-dev = "libc6-dev virtual-libc-dev"
19PROVIDES_${PN}-dbg = "glibc-dbg"
20
21# the -isystem in bitbake.conf screws up glibc do_stage
22BUILD_CPPFLAGS = "-I${STAGING_INCDIR_NATIVE}"
23TARGET_CPPFLAGS = "-I${STAGING_DIR_TARGET}${layout_includedir}"
24
25GLIBC_ADDONS ?= "ports,nptl,libidn"
26
27GLIBC_BROKEN_LOCALES = " _ER _ET so_ET yn_ER sid_ET tr_TR mn_MN gez_ET gez_ER bn_BD te_IN es_CR.ISO-8859-1"
28
29#
30# For now, we will skip building of a gcc package if it is a uclibc one
31# and our build is not a uclibc one, and we skip a glibc one if our build
32# is a uclibc build.
33#
34# See the note in gcc/gcc_3.4.0.oe
35#
36
37python __anonymous () {
38 import bb, re
39 uc_os = (re.match('.*uclibc$', bb.data.getVar('TARGET_OS', d, 1)) != None)
40 if uc_os:
41 raise bb.parse.SkipPackage("incompatible with target %s" %
42 bb.data.getVar('TARGET_OS', d, 1))
43}
44
45EXTRA_OECONF = "--enable-kernel=${OLDEST_KERNEL} \
46 --without-cvs --disable-profile --disable-debug --without-gd \
47 --enable-clocale=gnu \
48 --enable-add-ons=${GLIBC_ADDONS},ports \
49 --with-headers=${STAGING_INCDIR} \
50 --without-selinux \
51 ${GLIBC_EXTRA_OECONF}"
52
53EXTRA_OECONF += "${@get_eglibc_fpu_setting(bb, d)}"
54
55do_unpack_append() {
56 bb.build.exec_func('do_move_ports', d)
57}
58
59do_move_ports() {
60 if test -d ${WORKDIR}/${EGLIBC_BRANCH}/ports ; then
61 rm -rf ${S}/ports
62 mv ${WORKDIR}/${EGLIBC_BRANCH}/ports ${S}/
63 fi
64}
65
66do_configure () {
67# override this function to avoid the autoconf/automake/aclocal/autoheader
68# calls for now
69# don't pass CPPFLAGS into configure, since it upsets the kernel-headers
70# version check and doesn't really help with anything
71 if [ -z "`which rpcgen`" ]; then
72 echo "rpcgen not found. Install glibc-devel."
73 exit 1
74 fi
75 (cd ${S} && gnu-configize) || die "failure in running gnu-configize"
76 find ${S} -name "configure" | xargs touch
77 CPPFLAGS="" oe_runconf
78}
79
80rpcsvc = "bootparam_prot.x nlm_prot.x rstat.x \
81 yppasswd.x klm_prot.x rex.x sm_inter.x mount.x \
82 rusers.x spray.x nfs_prot.x rquota.x key_prot.x"
83
84do_compile () {
85 # -Wl,-rpath-link <staging>/lib in LDFLAGS can cause breakage if another glibc is in staging
86 unset LDFLAGS
87 base_do_compile
88 (
89 cd ${S}/sunrpc/rpcsvc
90 for r in ${rpcsvc}; do
91 h=`echo $r|sed -e's,\.x$,.h,'`
92 rpcgen -h $r -o $h || oewarn "unable to generate header for $r"
93 done
94 )
95}
96
97require eglibc-package.bbclass