summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/dbus/dbus-ptest_1.6.10.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-core/dbus/dbus-ptest_1.6.10.bb')
-rw-r--r--meta/recipes-core/dbus/dbus-ptest_1.6.10.bb49
1 files changed, 49 insertions, 0 deletions
diff --git a/meta/recipes-core/dbus/dbus-ptest_1.6.10.bb b/meta/recipes-core/dbus/dbus-ptest_1.6.10.bb
new file mode 100644
index 0000000000..6c0f4040f8
--- /dev/null
+++ b/meta/recipes-core/dbus/dbus-ptest_1.6.10.bb
@@ -0,0 +1,49 @@
1DESCRIPTION = "D-Bus test package, only used for D-bus functionality test."
2HOMEPAGE = "http://dbus.freedesktop.org"
3SECTION = "base"
4LICENSE = "AFL-2 | GPLv2+"
5LIC_FILES_CHKSUM = "file://COPYING;md5=10dded3b58148f3f1fd804b26354af3e \
6 file://dbus/dbus.h;beginline=6;endline=20;md5=7755c9d7abccd5dbd25a6a974538bb3c"
7
8DEPENDS = "python-pygobject dbus dbus-glib"
9
10RDEPENDS_${PN} += "make"
11
12SRC_URI = "http://dbus.freedesktop.org/releases/dbus/dbus-${PV}.tar.gz \
13 file://tmpdir.patch \
14 file://ptest.patch \
15 file://dbus-1.init \
16 file://run-ptest \
17 "
18
19SRC_URI[md5sum] = "de4970c20629aeb958a12132415b3630"
20SRC_URI[sha256sum] = "1f3d6f4a53a7121328f6cd685fc14440d72e6c0006ecb3312cc779c495915e86"
21
22S="${WORKDIR}/dbus-${PV}"
23FILESPATH = "${FILE_DIRNAME}/dbus-${PV}"
24
25inherit autotools pkgconfig gettext ptest
26
27EXTRA_OECONF_X = "${@base_contains('DISTRO_FEATURES', 'x11', '--with-x', '--without-x', d)}"
28EXTRA_OECONF_X_virtclass-native = "--without-x"
29
30EXTRA_OECONF = "--enable-tests \
31 --enable-modular-tests \
32 --enable-installed-tests \
33 --enable-checks \
34 --enable-asserts \
35 --enable-verbose-mode \
36 --disable-xml-docs \
37 --disable-doxygen-docs \
38 --disable-libaudit \
39 --with-xml=expat \
40 --with-systemdsystemunitdir=${systemd_unitdir}/system/ \
41 --with-dbus-test-dir=${PTEST_PATH} \
42 ${EXTRA_OECONF_X}"
43
44do_install() {
45}
46
47do_install_ptest() {
48 find ${D}${PTEST_PATH} -name Makefile | xargs sed -i 's/^Makefile:/_Makefile:/'
49}