summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/coreutils/coreutils_8.9.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-core/coreutils/coreutils_8.9.bb')
-rw-r--r--meta/recipes-core/coreutils/coreutils_8.9.bb74
1 files changed, 74 insertions, 0 deletions
diff --git a/meta/recipes-core/coreutils/coreutils_8.9.bb b/meta/recipes-core/coreutils/coreutils_8.9.bb
new file mode 100644
index 0000000000..4b9a655e50
--- /dev/null
+++ b/meta/recipes-core/coreutils/coreutils_8.9.bb
@@ -0,0 +1,74 @@
1SUMMARY = "The basic file, shell and text manipulation utilities."
2DESCRIPTION = "The GNU Core Utilities provide the basic file, shell and text \
3manipulation utilities. These are the core utilities which are expected to exist on \
4every system."
5HOMEPAGE = "http://www.gnu.org/software/coreutils/"
6BUGTRACKER = "http://debbugs.gnu.org/coreutils"
7LICENSE = "GPLv3+"
8LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504\
9 file://src/ls.c;startline=5;endline=16;md5=e1a509558876db58fb6667ba140137ad"
10PR = "r0"
11DEPENDS = "perl-native gmp"
12DEPENDS_virtclass-native = "perl-native gmp-native"
13
14inherit autotools gettext
15
16SRC_URI = "http://ftp.gnu.org/gnu/coreutils/${BP}.tar.gz"
17
18SRC_URI[md5sum] = "36909ae68840d73a800120cf74af794a"
19SRC_URI[sha256sum] = "aa991fa4296b22ff929a31a5cb5528bb783c84cdef4503c4ff311cfbeaebf50a"
20
21# [ gets a special treatment and is not included in this
22bindir_progs = "base64 basename chcon cksum comm csplit cut dir dircolors dirname du \
23 env expand expr factor fmt fold groups head hostid id install \
24 join link logname md5sum mkfifo mktemp nice nl nohup nproc od paste pathchk \
25 pinky pr printenv printf ptx readlink runcon seq sha1sum sha224sum sha256sum \
26 sha384sum sha512sum shred shuf sort split stat stdbuf sum tac tail tee test timeout\
27 tr truncate tsort tty unexpand uniq unlink uptime users vdir wc who whoami yes"
28
29# hostname gets a special treatment and is not included in this
30base_bindir_progs = "cat chgrp chmod chown cp date dd echo false kill ln ls mkdir \
31 mknod mv pwd rm rmdir sleep stty sync touch true uname"
32
33sbindir_progs= "chroot"
34
35do_install_append() {
36 for i in ${bindir_progs}; do mv ${D}${bindir}/$i ${D}${bindir}/$i.${PN}; done
37
38 install -d ${D}${base_bindir}
39 for i in ${base_bindir_progs}; do mv ${D}${bindir}/$i ${D}${base_bindir}/$i.${PN}; done
40
41 install -d ${D}${sbindir}
42 for i in ${sbindir_progs}; do mv ${D}${bindir}/$i ${D}${sbindir}/$i.${PN}; done
43
44 # [ requires special handling because [.coreutils will cause the sed stuff
45 # in update-alternatives to fail, therefore use lbracket - the name used
46 # for the actual source file.
47 mv ${D}${bindir}/[ ${D}${bindir}/lbracket.${PN}
48}
49
50pkg_postinst_${PN} () {
51 for i in ${bindir_progs}; do update-alternatives --install ${bindir}/$i $i $i.${PN} 100; done
52
53 for i in ${base_bindir_progs}; do update-alternatives --install ${base_bindir}/$i $i $i.${PN} 100; done
54
55 for i in ${sbindir_progs}; do update-alternatives --install ${sbindir}/$i $i $i.${PN} 100; done
56
57 # Special cases. [ needs to be treated separately.
58 update-alternatives --install '${bindir}/[' '[' 'lbracket.${PN}' 100
59}
60
61pkg_prerm_${PN} () {
62 for i in ${bindir_progs}; do update-alternatives --remove $i $i.${PN}; done
63
64 for i in ${base_bindir_progs}; do update-alternatives --remove $i $i.${PN}; done
65
66 for i in ${sbindir_progs}; do update-alternatives --remove $i $i.${PN}; done
67
68 # The special cases
69 update-alternatives --remove hostname hostname.${PN}
70 update-alternatives --remove uptime uptime.${PN}
71 update-alternatives --remove '[' 'lbracket.${PN}'
72}
73
74BBCLASSEXTEND = "native"