summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/coreutils/coreutils_8.5.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-core/coreutils/coreutils_8.5.bb')
-rw-r--r--meta/recipes-core/coreutils/coreutils_8.5.bb67
1 files changed, 67 insertions, 0 deletions
diff --git a/meta/recipes-core/coreutils/coreutils_8.5.bb b/meta/recipes-core/coreutils/coreutils_8.5.bb
new file mode 100644
index 0000000000..5213fa2937
--- /dev/null
+++ b/meta/recipes-core/coreutils/coreutils_8.5.bb
@@ -0,0 +1,67 @@
1DESCRIPTION = "The GNU Core Utilities are the basic file, shell and text manipulation utilities of the GNU operating system. These are the core utilities which are expected to exist on every operating system"
2HOMEPAGE = "http://www.gnu.org/software/coreutils/"
3BUGTRACKER = "http://debbugs.gnu.org/coreutils"
4LICENSE = "GPLv3+"
5LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504\
6 file://src/ls.c;startline=5;endline=16;md5=bb14ed3c4cda583abc85401304b5cd4e"
7PR = "r0"
8DEPENDS = "perl-native"
9
10inherit autotools gettext
11
12SRC_URI = "http://ftp.gnu.org/gnu/coreutils/${BP}.tar.gz"
13
14# [ gets a special treatment and is not included in this
15bindir_progs = "base64 basename chcon cksum comm csplit cut dir dircolors dirname du \
16 env expand expr factor fmt fold groups head hostid id install \
17 join link logname md5sum mkfifo mktemp nice nl nohup nproc od paste pathchk \
18 pinky pr printenv printf ptx readlink runcon seq sha1sum sha224sum sha256sum \
19 sha384sum sha512sum shred shuf sort split stat stdbuf sum tac tail tee test timeout\
20 tr truncate tsort tty unexpand uniq unlink uptime users vdir wc who whoami yes"
21
22# hostname gets a special treatment and is not included in this
23base_bindir_progs = "cat chgrp chmod chown cp date dd echo false kill ln ls mkdir \
24 mknod mv pwd rm rmdir sleep stty sync touch true uname"
25
26sbindir_progs= "chroot"
27
28do_install_append() {
29 for i in ${bindir_progs}; do mv ${D}${bindir}/$i ${D}${bindir}/$i.${PN}; done
30
31 install -d ${D}${base_bindir}
32 for i in ${base_bindir_progs}; do mv ${D}${bindir}/$i ${D}${base_bindir}/$i.${PN}; done
33
34 install -d ${D}${sbindir}
35 for i in ${sbindir_progs}; do mv ${D}${bindir}/$i ${D}${sbindir}/$i.${PN}; done
36
37 # [ requires special handling because [.coreutils will cause the sed stuff
38 # in update-alternatives to fail, therefore use lbracket - the name used
39 # for the actual source file.
40 mv ${D}${bindir}/[ ${D}${bindir}/lbracket.${PN}
41}
42
43pkg_postinst_${PN} () {
44 for i in ${bindir_progs}; do update-alternatives --install ${bindir}/$i $i $i.${PN} 100; done
45
46 for i in ${base_bindir_progs}; do update-alternatives --install ${base_bindir}/$i $i $i.${PN} 100; done
47
48 for i in ${sbindir_progs}; do update-alternatives --install ${sbindir}/$i $i $i.${PN} 100; done
49
50 # Special cases. [ needs to be treated separately.
51 update-alternatives --install '${bindir}/[' '[' 'lbracket.${PN}' 100
52}
53
54pkg_prerm_${PN} () {
55 for i in ${bindir_progs}; do update-alternatives --remove $i $i.${PN}; done
56
57 for i in ${base_bindir_progs}; do update-alternatives --remove $i $i.${PN}; done
58
59 for i in ${sbindir_progs}; do update-alternatives --remove $i $i.${PN}; done
60
61 # The special cases
62 update-alternatives --remove hostname hostname.${PN}
63 update-alternatives --remove uptime uptime.${PN}
64 update-alternatives --remove '[' 'lbracket.${PN}'
65}
66
67BBCLASSEXTEND = "native"