summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/coreutils/coreutils_8.30.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-core/coreutils/coreutils_8.30.bb')
-rw-r--r--meta/recipes-core/coreutils/coreutils_8.30.bb14
1 files changed, 9 insertions, 5 deletions
diff --git a/meta/recipes-core/coreutils/coreutils_8.30.bb b/meta/recipes-core/coreutils/coreutils_8.30.bb
index 053891f6ea..eb1dd2a93a 100644
--- a/meta/recipes-core/coreutils/coreutils_8.30.bb
+++ b/meta/recipes-core/coreutils/coreutils_8.30.bb
@@ -42,10 +42,10 @@ PACKAGECONFIG[acl] = "--enable-acl,--disable-acl,acl,"
42PACKAGECONFIG[xattr] = "--enable-xattr,--disable-xattr,attr," 42PACKAGECONFIG[xattr] = "--enable-xattr,--disable-xattr,attr,"
43PACKAGECONFIG[single-binary] = "--enable-single-binary,--disable-single-binary,," 43PACKAGECONFIG[single-binary] = "--enable-single-binary,--disable-single-binary,,"
44 44
45# [ df mktemp base64 gets a special treatment and is not included in this 45# [ df mktemp nice base64 gets a special treatment and is not included in this
46bindir_progs = "arch basename chcon cksum comm csplit cut dir dircolors dirname du \ 46bindir_progs = "arch basename chcon cksum comm csplit cut dir dircolors dirname du \
47 env expand expr factor fmt fold groups head hostid id install \ 47 env expand expr factor fmt fold groups head hostid id install \
48 join link logname md5sum mkfifo nice nl nohup nproc od paste pathchk \ 48 join link logname md5sum mkfifo nl nohup nproc od paste pathchk \
49 pinky pr printenv printf ptx readlink realpath runcon seq sha1sum sha224sum sha256sum \ 49 pinky pr printenv printf ptx readlink realpath runcon seq sha1sum sha224sum sha256sum \
50 sha384sum sha512sum shred shuf sort split stdbuf sum tac tail tee test timeout\ 50 sha384sum sha512sum shred shuf sort split stdbuf sum tac tail tee test timeout\
51 tr truncate tsort tty unexpand uniq unlink uptime users vdir wc who whoami yes" 51 tr truncate tsort tty unexpand uniq unlink uptime users vdir wc who whoami yes"
@@ -77,7 +77,7 @@ do_install_class-native() {
77} 77}
78 78
79do_install_append() { 79do_install_append() {
80 for i in df mktemp base64; do mv ${D}${bindir}/$i ${D}${bindir}/$i.${BPN}; done 80 for i in df mktemp nice base64; do mv ${D}${bindir}/$i ${D}${bindir}/$i.${BPN}; done
81 81
82 install -d ${D}${base_bindir} 82 install -d ${D}${base_bindir}
83 [ "${base_bindir}" != "${bindir}" ] && for i in ${base_bindir_progs}; do mv ${D}${bindir}/$i ${D}${base_bindir}/$i.${BPN}; done 83 [ "${base_bindir}" != "${bindir}" ] && for i in ${base_bindir_progs}; do mv ${D}${bindir}/$i ${D}${base_bindir}/$i.${BPN}; done
@@ -96,8 +96,8 @@ inherit update-alternatives
96ALTERNATIVE_PRIORITY = "100" 96ALTERNATIVE_PRIORITY = "100"
97# Make hostname's priority higher than busybox but lower than net-tools 97# Make hostname's priority higher than busybox but lower than net-tools
98ALTERNATIVE_PRIORITY[hostname] = "90" 98ALTERNATIVE_PRIORITY[hostname] = "90"
99ALTERNATIVE_${PN} = "lbracket ${bindir_progs} ${base_bindir_progs} ${sbindir_progs} base64 mktemp df" 99ALTERNATIVE_${PN} = "lbracket ${bindir_progs} ${base_bindir_progs} ${sbindir_progs} base64 nice mktemp df"
100ALTERNATIVE_${PN}-doc = "base64.1 mktemp.1 df.1 groups.1 kill.1 uptime.1 stat.1 hostname.1" 100ALTERNATIVE_${PN}-doc = "base64.1 nice.1 mktemp.1 df.1 groups.1 kill.1 uptime.1 stat.1 hostname.1"
101 101
102ALTERNATIVE_LINK_NAME[hostname.1] = "${mandir}/man1/hostname.1" 102ALTERNATIVE_LINK_NAME[hostname.1] = "${mandir}/man1/hostname.1"
103 103
@@ -113,6 +113,10 @@ ALTERNATIVE_LINK_NAME[df] = "${base_bindir}/df"
113ALTERNATIVE_TARGET[df] = "${bindir}/df.${BPN}" 113ALTERNATIVE_TARGET[df] = "${bindir}/df.${BPN}"
114ALTERNATIVE_LINK_NAME[df.1] = "${mandir}/man1/df.1" 114ALTERNATIVE_LINK_NAME[df.1] = "${mandir}/man1/df.1"
115 115
116ALTERNATIVE_LINK_NAME[nice] = "${base_bindir}/nice"
117ALTERNATIVE_TARGET[nice] = "${bindir}/nice.${BPN}"
118ALTERNATIVE_LINK_NAME[nice.1] = "${mandir}/man1/nice.1"
119
116ALTERNATIVE_LINK_NAME[lbracket] = "${bindir}/[" 120ALTERNATIVE_LINK_NAME[lbracket] = "${bindir}/["
117ALTERNATIVE_TARGET[lbracket] = "${bindir}/lbracket.${BPN}" 121ALTERNATIVE_TARGET[lbracket] = "${bindir}/lbracket.${BPN}"
118 122