summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/coreutils/coreutils_8.25.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-core/coreutils/coreutils_8.25.bb')
-rw-r--r--meta/recipes-core/coreutils/coreutils_8.25.bb132
1 files changed, 132 insertions, 0 deletions
diff --git a/meta/recipes-core/coreutils/coreutils_8.25.bb b/meta/recipes-core/coreutils/coreutils_8.25.bb
new file mode 100644
index 0000000000..650008e528
--- /dev/null
+++ b/meta/recipes-core/coreutils/coreutils_8.25.bb
@@ -0,0 +1,132 @@
1SUMMARY = "The basic file, shell and text manipulation utilities"
2DESCRIPTION = "The GNU Core Utilities provide the basic file, shell and text \
3manipulation utilities. These are the core utilities which are expected to exist on \
4every system."
5HOMEPAGE = "http://www.gnu.org/software/coreutils/"
6BUGTRACKER = "http://debbugs.gnu.org/coreutils"
7LICENSE = "GPLv3+"
8LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504\
9 file://src/ls.c;beginline=5;endline=16;md5=38b79785ca88537b75871782a2a3c6b8"
10DEPENDS = "gmp libcap"
11DEPENDS_class-native = ""
12
13inherit autotools gettext texinfo
14
15SRC_URI = "${GNU_MIRROR}/coreutils/${BP}.tar.xz;name=tarball \
16 http://distfiles.gentoo.org/distfiles/${BP}-man.tar.xz;name=manpages \
17 file://man-decouple-manpages-from-build.patch \
18 file://remove-usr-local-lib-from-m4.patch \
19 file://fix-selinux-flask.patch \
20 file://0001-Unset-need_charset_alias-when-building-for-musl.patch \
21 "
22
23SRC_URI[tarball.md5sum] = "070e43ba7f618d747414ef56ab248a48"
24SRC_URI[tarball.sha256sum] = "31e67c057a5b32a582f26408c789e11c2e8d676593324849dcf5779296cdce87"
25SRC_URI[manpages.md5sum] = "415cc0552bc4e480b27ce8b2aebfdeb5"
26SRC_URI[manpages.sha256sum] = "2ee31c3a6d2276f49c5515375d4a0c1047580da6ac10536898e0f0de81707f29"
27
28EXTRA_OECONF_class-native = "--without-gmp"
29EXTRA_OECONF_class-target = "--enable-install-program=arch --libexecdir=${libdir}"
30
31# acl and xattr are not default features
32#
33PACKAGECONFIG_class-target ??= "\
34 ${@bb.utils.contains('DISTRO_FEATURES', 'acl', 'acl', '', d)} \
35 ${@bb.utils.contains('DISTRO_FEATURES', 'xattr', 'xattr', '', d)} \
36"
37
38PACKAGECONFIG_class-native ??= ""
39
40# with, without, depends, rdepends
41#
42PACKAGECONFIG[acl] = "--enable-acl,--disable-acl,acl,"
43PACKAGECONFIG[xattr] = "--enable-xattr,--disable-xattr,attr,"
44
45# [ df mktemp base64 gets a special treatment and is not included in this
46bindir_progs = "arch basename chcon cksum comm csplit cut dir dircolors dirname du \
47 env expand expr factor fmt fold groups head hostid id install \
48 join link logname md5sum mkfifo nice nl nohup nproc od paste pathchk \
49 pinky pr printenv printf ptx readlink realpath runcon seq sha1sum sha224sum sha256sum \
50 sha384sum sha512sum shred shuf sort split stdbuf sum tac tail tee test timeout\
51 tr truncate tsort tty unexpand uniq unlink uptime users vdir wc who whoami yes"
52
53# hostname gets a special treatment and is not included in this
54base_bindir_progs = "cat chgrp chmod chown cp date dd echo false kill ln ls mkdir \
55 mknod mv pwd rm rmdir sleep stty sync touch true uname stat"
56
57sbindir_progs= "chroot"
58
59# Let aclocal use the relative path for the m4 file rather than the
60# absolute since coreutils has a lot of m4 files, otherwise there might
61# be an "Argument list too long" error when it is built in a long/deep
62# directory.
63acpaths = "-I ./m4"
64
65# Deal with a separate builddir failure if src doesn't exist when creating version.c/version.h
66do_compile_prepend () {
67 mkdir -p ${B}/src
68}
69
70do_install_append_class-target() {
71 for i in df mktemp base64; do mv ${D}${bindir}/$i ${D}${bindir}/$i.${BPN}; done
72
73 install -d ${D}${base_bindir}
74 [ "${base_bindir}" != "${bindir}" ] && for i in ${base_bindir_progs}; do mv ${D}${bindir}/$i ${D}${base_bindir}/$i.${BPN}; done
75
76 install -d ${D}${sbindir}
77 [ "${sbindir}" != "${bindir}" ] && for i in ${sbindir_progs}; do mv ${D}${bindir}/$i ${D}${sbindir}/$i.${BPN}; done
78
79 # [ requires special handling because [.coreutils will cause the sed stuff
80 # in update-alternatives to fail, therefore use lbracket - the name used
81 # for the actual source file.
82 mv ${D}${bindir}/[ ${D}${bindir}/lbracket.${BPN}
83
84 # prebuilt man pages
85 install -d ${D}/${mandir}/man1
86 install -t ${D}/${mandir}/man1 ${S}/man/*.1
87 # prebuilt man pages don't do a separate man page for [ vs test.
88 # see comment above r.e. sed and update-alternatives
89 cp -a ${D}${mandir}/man1/test.1 ${D}${mandir}/man1/lbracket.1.${BPN}
90}
91
92do_install_append_class-native(){
93 # remove groups to fix conflict with shadow-native
94 rm -f ${D}${STAGING_BINDIR_NATIVE}/groups
95}
96
97inherit update-alternatives
98
99ALTERNATIVE_PRIORITY = "100"
100ALTERNATIVE_${PN} = "lbracket ${bindir_progs} ${base_bindir_progs} ${sbindir_progs} base64 mktemp df"
101ALTERNATIVE_${PN}-doc = "base64.1 mktemp.1 df.1 lbracket.1 groups.1 kill.1 uptime.1 stat.1"
102
103ALTERNATIVE_LINK_NAME[base64] = "${base_bindir}/base64"
104ALTERNATIVE_TARGET[base64] = "${bindir}/base64.${BPN}"
105ALTERNATIVE_LINK_NAME[base64.1] = "${mandir}/man1/base64.1"
106
107ALTERNATIVE_LINK_NAME[mktemp] = "${base_bindir}/mktemp"
108ALTERNATIVE_TARGET[mktemp] = "${bindir}/mktemp.${BPN}"
109ALTERNATIVE_LINK_NAME[mktemp.1] = "${mandir}/man1/mktemp.1"
110
111ALTERNATIVE_LINK_NAME[df] = "${base_bindir}/df"
112ALTERNATIVE_TARGET[df] = "${bindir}/df.${BPN}"
113ALTERNATIVE_LINK_NAME[df.1] = "${mandir}/man1/df.1"
114
115ALTERNATIVE_LINK_NAME[lbracket] = "${bindir}/["
116ALTERNATIVE_TARGET[lbracket] = "${bindir}/lbracket.${BPN}"
117ALTERNATIVE_LINK_NAME[lbracket.1] = "${mandir}/man1/lbracket.1"
118
119ALTERNATIVE_LINK_NAME[groups.1] = "${mandir}/man1/groups.1"
120ALTERNATIVE_LINK_NAME[uptime.1] = "${mandir}/man1/uptime.1"
121ALTERNATIVE_LINK_NAME[kill.1] = "${mandir}/man1/kill.1"
122ALTERNATIVE_LINK_NAME[stat.1] = "${mandir}/man1/stat.1"
123
124python __anonymous() {
125 for prog in d.getVar('base_bindir_progs', True).split():
126 d.setVarFlag('ALTERNATIVE_LINK_NAME', prog, '%s/%s' % (d.getVar('base_bindir', True), prog))
127
128 for prog in d.getVar('sbindir_progs', True).split():
129 d.setVarFlag('ALTERNATIVE_LINK_NAME', prog, '%s/%s' % (d.getVar('sbindir', True), prog))
130}
131
132BBCLASSEXTEND = "native nativesdk"