summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/coreutils/coreutils_8.22.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-core/coreutils/coreutils_8.22.bb')
-rw-r--r--meta/recipes-core/coreutils/coreutils_8.22.bb108
1 files changed, 108 insertions, 0 deletions
diff --git a/meta/recipes-core/coreutils/coreutils_8.22.bb b/meta/recipes-core/coreutils/coreutils_8.22.bb
new file mode 100644
index 0000000000..4a1aee6260
--- /dev/null
+++ b/meta/recipes-core/coreutils/coreutils_8.22.bb
@@ -0,0 +1,108 @@
1SUMMARY = "The basic file, shell and text manipulation utilities"
2DESCRIPTION = "The GNU Core Utilities provide the basic file, shell and text \
3manipulation utilities. These are the core utilities which are expected to exist on \
4every system."
5HOMEPAGE = "http://www.gnu.org/software/coreutils/"
6BUGTRACKER = "http://debbugs.gnu.org/coreutils"
7LICENSE = "GPLv3+"
8LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504\
9 file://src/ls.c;beginline=5;endline=16;md5=38b79785ca88537b75871782a2a3c6b8"
10DEPENDS = "gmp libcap"
11DEPENDS_class-native = ""
12
13inherit autotools gettext texinfo
14
15SRC_URI = "${GNU_MIRROR}/coreutils/${BP}.tar.xz \
16 file://remove-usr-local-lib-from-m4.patch \
17 file://dummy_help2man.patch \
18 file://fix-for-dummy-man-usage.patch \
19 file://fix-selinux-flask.patch \
20 file://date-tz-crash.patch \
21 "
22
23SRC_URI[md5sum] = "8fb0ae2267aa6e728958adc38f8163a2"
24SRC_URI[sha256sum] = "5b3e94998152c017e6c75d56b9b994188eb71bf46d4038a642cb9141f6ff1212"
25
26EXTRA_OECONF_class-native = "--without-gmp"
27EXTRA_OECONF_class-target = "--enable-install-program=arch --libexecdir=${libdir}"
28
29# acl is not a default feature
30#
31PACKAGECONFIG_class-target ??= "${@bb.utils.contains('DISTRO_FEATURES', 'acl', 'acl', '', d)}"
32PACKAGECONFIG_class-native ??= ""
33
34# with, without, depends, rdepends
35#
36PACKAGECONFIG[acl] = "--enable-acl,--disable-acl,acl,"
37
38# [ df mktemp base64 gets a special treatment and is not included in this
39bindir_progs = "arch basename chcon cksum comm csplit cut dir dircolors dirname du \
40 env expand expr factor fmt fold groups head hostid id install \
41 join link logname md5sum mkfifo nice nl nohup nproc od paste pathchk \
42 pinky pr printenv printf ptx readlink realpath runcon seq sha1sum sha224sum sha256sum \
43 sha384sum sha512sum shred shuf sort split stdbuf sum tac tail tee test timeout\
44 tr truncate tsort tty unexpand uniq unlink uptime users vdir wc who whoami yes"
45
46# hostname gets a special treatment and is not included in this
47base_bindir_progs = "cat chgrp chmod chown cp date dd echo false kill ln ls mkdir \
48 mknod mv pwd rm rmdir sleep stty sync touch true uname stat"
49
50sbindir_progs= "chroot"
51
52# Let aclocal use the relative path for the m4 file rather than the
53# absolute since coreutils has a lot of m4 files, otherwise there might
54# be an "Argument list too long" error when it is built in a long/deep
55# directory.
56acpaths = "-I ./m4"
57
58# Deal with a separate builddir failure if src doesn't exist when creating version.c/version.h
59do_compile_prepend () {
60 mkdir -p ${B}/src
61}
62
63do_install_append() {
64 for i in df mktemp base64; do mv ${D}${bindir}/$i ${D}${bindir}/$i.${BPN}; done
65
66 install -d ${D}${base_bindir}
67 [ "${base_bindir}" != "${bindir}" ] && for i in ${base_bindir_progs}; do mv ${D}${bindir}/$i ${D}${base_bindir}/$i.${BPN}; done
68
69 install -d ${D}${sbindir}
70 [ "${sbindir}" != "${bindir}" ] && for i in ${sbindir_progs}; do mv ${D}${bindir}/$i ${D}${sbindir}/$i.${BPN}; done
71
72 # [ requires special handling because [.coreutils will cause the sed stuff
73 # in update-alternatives to fail, therefore use lbracket - the name used
74 # for the actual source file.
75 mv ${D}${bindir}/[ ${D}${bindir}/lbracket.${BPN}
76}
77
78do_install_append_class-native(){
79 # remove groups to fix conflict with shadow-native
80 rm -f ${D}${STAGING_BINDIR_NATIVE}/groups
81}
82
83inherit update-alternatives
84
85ALTERNATIVE_PRIORITY = "100"
86ALTERNATIVE_${PN} = "lbracket ${bindir_progs} ${base_bindir_progs} ${sbindir_progs} base64 mktemp df"
87
88ALTERNATIVE_LINK_NAME[base64] = "${base_bindir}/base64"
89ALTERNATIVE_TARGET[base64] = "${bindir}/base64.${BPN}"
90
91ALTERNATIVE_LINK_NAME[mktemp] = "${base_bindir}/mktemp"
92ALTERNATIVE_TARGET[mktemp] = "${bindir}/mktemp.${BPN}"
93
94ALTERNATIVE_LINK_NAME[df] = "${base_bindir}/df"
95ALTERNATIVE_TARGET[df] = "${bindir}/df.${BPN}"
96
97ALTERNATIVE_LINK_NAME[lbracket] = "${bindir}/["
98ALTERNATIVE_TARGET[lbracket] = "${bindir}/lbracket.${BPN}"
99
100python __anonymous() {
101 for prog in d.getVar('base_bindir_progs', True).split():
102 d.setVarFlag('ALTERNATIVE_LINK_NAME', prog, '%s/%s' % (d.getVar('base_bindir', True), prog))
103
104 for prog in d.getVar('sbindir_progs', True).split():
105 d.setVarFlag('ALTERNATIVE_LINK_NAME', prog, '%s/%s' % (d.getVar('sbindir', True), prog))
106}
107
108BBCLASSEXTEND = "native nativesdk"