summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/coreutils/coreutils_8.21.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-core/coreutils/coreutils_8.21.bb')
-rw-r--r--meta/recipes-core/coreutils/coreutils_8.21.bb103
1 files changed, 103 insertions, 0 deletions
diff --git a/meta/recipes-core/coreutils/coreutils_8.21.bb b/meta/recipes-core/coreutils/coreutils_8.21.bb
new file mode 100644
index 0000000000..da14303286
--- /dev/null
+++ b/meta/recipes-core/coreutils/coreutils_8.21.bb
@@ -0,0 +1,103 @@
1SUMMARY = "The basic file, shell and text manipulation utilities."
2DESCRIPTION = "The GNU Core Utilities provide the basic file, shell and text \
3manipulation utilities. These are the core utilities which are expected to exist on \
4every system."
5HOMEPAGE = "http://www.gnu.org/software/coreutils/"
6BUGTRACKER = "http://debbugs.gnu.org/coreutils"
7LICENSE = "GPLv3+"
8LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504\
9 file://src/ls.c;beginline=5;endline=16;md5=38b79785ca88537b75871782a2a3c6b8"
10PR = "r0"
11DEPENDS = "gmp libcap"
12DEPENDS_class-native = ""
13
14inherit autotools gettext
15
16SRC_URI = "${GNU_MIRROR}/coreutils/${BP}.tar.xz \
17 file://remove-usr-local-lib-from-m4.patch \
18 file://coreutils-build-with-acl.patch \
19 file://dummy_help2man.patch \
20 "
21
22SRC_URI[md5sum] = "065ba41828644eca5dd8163446de5d64"
23SRC_URI[sha256sum] = "adaa44bdab3fa5eb352e80d8a31fdbf957b78653d0c2cd30d63e161444288e18"
24
25EXTRA_OECONF_class-native = "--without-gmp"
26
27# acl is not a default feature
28#
29PACKAGECONFIG_class-target ??= "${@base_contains('DISTRO_FEATURES', 'acl', 'acl', '', d)}"
30PACKAGECONFIG_class-native ??= ""
31
32# with, without, depends, rdepends
33#
34PACKAGECONFIG[acl] = "--enable-acl,--disable-acl,acl,"
35
36# [ df mktemp base64 gets a special treatment and is not included in this
37bindir_progs = "basename chcon cksum comm csplit cut dir dircolors dirname du \
38 env expand expr factor fmt fold groups head hostid id install \
39 join link logname md5sum mkfifo nice nl nohup nproc od paste pathchk \
40 pinky pr printenv printf ptx readlink realpath runcon seq sha1sum sha224sum sha256sum \
41 sha384sum sha512sum shred shuf sort split stat stdbuf sum tac tail tee test timeout\
42 tr truncate tsort tty unexpand uniq unlink uptime users vdir wc who whoami yes"
43
44# hostname gets a special treatment and is not included in this
45base_bindir_progs = "cat chgrp chmod chown cp date dd echo false kill ln ls mkdir \
46 mknod mv pwd rm rmdir sleep stty sync touch true uname"
47
48sbindir_progs= "chroot"
49
50# Let aclocal use the relative path for the m4 file rather than the
51# absolute since coreutils has a lot of m4 files, otherwise there might
52# be an "Argument list too long" error when it is built in a long/deep
53# directory.
54acpaths = "-I ./m4"
55
56# Deal with a separate builddir failure if src doesn't exist when creating version.c/version.h
57do_compile_prepend () {
58 mkdir -p ${B}/src
59}
60
61do_install_append() {
62 for i in df mktemp base64; do mv ${D}${bindir}/$i ${D}${bindir}/$i.${BPN}; done
63
64 install -d ${D}${base_bindir}
65 [ "${base_bindir}" != "${bindir}" ] && for i in ${base_bindir_progs}; do mv ${D}${bindir}/$i ${D}${base_bindir}/$i.${BPN}; done
66
67 install -d ${D}${sbindir}
68 [ "${sbindir}" != "${bindir}" ] && for i in ${sbindir_progs}; do mv ${D}${bindir}/$i ${D}${sbindir}/$i.${BPN}; done
69
70 # [ requires special handling because [.coreutils will cause the sed stuff
71 # in update-alternatives to fail, therefore use lbracket - the name used
72 # for the actual source file.
73 mv ${D}${bindir}/[ ${D}${bindir}/lbracket.${BPN}
74 install -d ${D}${libdir}/coreutils
75 mv ${D}${libexecdir}/coreutils/libstdbuf.so ${D}${libdir}/coreutils
76}
77
78inherit update-alternatives
79
80ALTERNATIVE_PRIORITY = "100"
81ALTERNATIVE_${PN} = "lbracket ${bindir_progs} ${base_bindir_progs} ${sbindir_progs} base64 mktemp df"
82
83ALTERNATIVE_LINK_NAME[base64] = "${base_bindir}/base64"
84ALTERNATIVE_TARGET[base64] = "${bindir}/base64.${BPN}"
85
86ALTERNATIVE_LINK_NAME[mktemp] = "${base_bindir}/mktemp"
87ALTERNATIVE_TARGET[mktemp] = "${bindir}/mktemp.${BPN}"
88
89ALTERNATIVE_LINK_NAME[df] = "${base_bindir}/df"
90ALTERNATIVE_TARGET[df] = "${bindir}/df.${BPN}"
91
92ALTERNATIVE_LINK_NAME[lbracket] = "${bindir}/["
93ALTERNATIVE_TARGET[lbracket] = "${bindir}/lbracket.${BPN}"
94
95python __anonymous() {
96 for prog in d.getVar('base_bindir_progs', True).split():
97 d.setVarFlag('ALTERNATIVE_LINK_NAME', prog, '%s/%s' % (d.getVar('base_bindir', True), prog))
98
99 for prog in d.getVar('sbindir_progs', True).split():
100 d.setVarFlag('ALTERNATIVE_LINK_NAME', prog, '%s/%s' % (d.getVar('sbindir', True), prog))
101}
102
103BBCLASSEXTEND = "native"