summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/coreutils/coreutils_8.21.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-core/coreutils/coreutils_8.21.bb')
-rw-r--r--meta/recipes-core/coreutils/coreutils_8.21.bb84
1 files changed, 84 insertions, 0 deletions
diff --git a/meta/recipes-core/coreutils/coreutils_8.21.bb b/meta/recipes-core/coreutils/coreutils_8.21.bb
new file mode 100644
index 0000000000..e789f59f0b
--- /dev/null
+++ b/meta/recipes-core/coreutils/coreutils_8.21.bb
@@ -0,0 +1,84 @@
1SUMMARY = "The basic file, shell and text manipulation utilities."
2DESCRIPTION = "The GNU Core Utilities provide the basic file, shell and text \
3manipulation utilities. These are the core utilities which are expected to exist on \
4every system."
5HOMEPAGE = "http://www.gnu.org/software/coreutils/"
6BUGTRACKER = "http://debbugs.gnu.org/coreutils"
7LICENSE = "GPLv3+"
8LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504\
9 file://src/ls.c;beginline=5;endline=16;md5=38b79785ca88537b75871782a2a3c6b8"
10PR = "r0"
11DEPENDS = "gmp libcap"
12DEPENDS_class-native = ""
13
14inherit autotools gettext
15
16SRC_URI = "${GNU_MIRROR}/coreutils/${BP}.tar.xz \
17 file://remove-usr-local-lib-from-m4.patch \
18 file://coreutils-build-with-acl.patch \
19 file://dummy_help2man.patch \
20 "
21
22SRC_URI[md5sum] = "065ba41828644eca5dd8163446de5d64"
23SRC_URI[sha256sum] = "adaa44bdab3fa5eb352e80d8a31fdbf957b78653d0c2cd30d63e161444288e18"
24
25EXTRA_OECONF = "--disable-acl"
26EXTRA_OECONF_class-native = "--disable-acl --without-gmp"
27
28# [ df mktemp base64 gets a special treatment and is not included in this
29bindir_progs = "basename chcon cksum comm csplit cut dir dircolors dirname du \
30 env expand expr factor fmt fold groups head hostid id install \
31 join link logname md5sum mkfifo nice nl nohup nproc od paste pathchk \
32 pinky pr printenv printf ptx readlink runcon seq sha1sum sha224sum sha256sum \
33 sha384sum sha512sum shred shuf sort split stat stdbuf sum tac tail tee test timeout\
34 tr truncate tsort tty unexpand uniq unlink uptime users vdir wc who whoami yes"
35
36# hostname gets a special treatment and is not included in this
37base_bindir_progs = "cat chgrp chmod chown cp date dd echo false kill ln ls mkdir \
38 mknod mv pwd rm rmdir sleep stty sync touch true uname"
39
40sbindir_progs= "chroot"
41
42do_install_append() {
43 for i in df mktemp base64; do mv ${D}${bindir}/$i ${D}${bindir}/$i.${BPN}; done
44
45 install -d ${D}${base_bindir}
46 [ "${base_bindir}" != "${bindir}" ] && for i in ${base_bindir_progs}; do mv ${D}${bindir}/$i ${D}${base_bindir}/$i.${BPN}; done
47
48 install -d ${D}${sbindir}
49 [ "${sbindir}" != "${bindir}" ] && for i in ${sbindir_progs}; do mv ${D}${bindir}/$i ${D}${sbindir}/$i.${BPN}; done
50
51 # [ requires special handling because [.coreutils will cause the sed stuff
52 # in update-alternatives to fail, therefore use lbracket - the name used
53 # for the actual source file.
54 mv ${D}${bindir}/[ ${D}${bindir}/lbracket.${BPN}
55 install -d ${D}${libdir}/coreutils
56 mv ${D}${libexecdir}/coreutils/libstdbuf.so ${D}${libdir}/coreutils
57}
58
59inherit update-alternatives
60
61ALTERNATIVE_PRIORITY = "100"
62ALTERNATIVE_${PN} = "lbracket ${bindir_progs} ${base_bindir_progs} ${sbindir_progs} base64 mktemp df"
63
64ALTERNATIVE_LINK_NAME[base64] = "${base_bindir}/base64"
65ALTERNATIVE_TARGET[base64] = "${bindir}/base64.${BPN}"
66
67ALTERNATIVE_LINK_NAME[mktemp] = "${base_bindir}/mktemp"
68ALTERNATIVE_TARGET[mktemp] = "${bindir}/mktemp.${BPN}"
69
70ALTERNATIVE_LINK_NAME[df] = "${base_bindir}/df"
71ALTERNATIVE_TARGET[df] = "${bindir}/df.${BPN}"
72
73ALTERNATIVE_LINK_NAME[lbracket] = "${bindir}/["
74ALTERNATIVE_TARGET[lbracket] = "${bindir}/lbracket.${BPN}"
75
76python __anonymous() {
77 for prog in d.getVar('base_bindir_progs', True).split():
78 d.setVarFlag('ALTERNATIVE_LINK_NAME', prog, '%s/%s' % (d.getVar('base_bindir', True), prog))
79
80 for prog in d.getVar('sbindir_progs', True).split():
81 d.setVarFlag('ALTERNATIVE_LINK_NAME', prog, '%s/%s' % (d.getVar('sbindir', True), prog))
82}
83
84BBCLASSEXTEND = "native"